Latest Server Crashes Regularly

server-windows

#1

Title says it all. Since upgrading to 1.7.6 (skipped 1.7.5) plex has been crashing regularly. At least once or twice a day. I am not sure exactly when or what is causing it, but the unreliability is a major pain. Looking in task manager, the dlna service often seems to be stuck running, but I dont know if thats the cause or what. I have to shut it down from task manager before restarting plex or I cant access plex after restarting.

I am running Windows Server 2016 Essential, build 14393. Attaching logs.


#2

I have 3 servers. A Win10 Skull NUC and a Shield 16gb and a Shield Pro.

The last day or 2 or 3 - maybe since 1.7.6 I have Plexpy telling me the NUC is down and then is back up - sometimes in a minute sometime upto 10 minutes.
And yes the streaming stops so not a Plexpy issue (?)

At the same time both shields stay up !!

I have update my library Automatically Off - at this was thought to be an issue a week or 2 back.

Very frustrating !!


#3

I have to manually log onto my server and often times close processes that are stuck running and then restart plex myself. I saw some of the threads that recommended turning off the automatic library updates... but... that seems like a pretty important feature to have to turn off. I saw another thread that suggested it was to do with the latest version of windows 10... but Im not running windows 10.

I dont know how to interpret the logs so I am hoping someone might be able to find something better than what my brief search led me to. Or that plex will respond and say a fix is incoming shortly... Because this is bad.


#4

Anecdotal I know but... I'm having issues with the latest builds also

Plex will work for a few hours, then will just get stuck 'loading' when trying to play an item. One of the logs says: WARN - Waited one whole second for a busy database.

I did update my Windows 10 box this week, and the issues coincide with the update.


#5

Same issue here, windows server 2012R2 plex crashes and I get to 13% on my players and then it says transcoder error. Reboot is the only way to get it working again. Plex app, Python, and Plex update service running and killing and restarting them seems to work but when I try to browse website it says page cannot be displayed. Was a rock until an upgrade a few weeks ago don't know the version or what not because I usually just upgrade when its available.


#6

@phreaq said:
Anecdotal I know but... I'm having issues with the latest builds also

Plex will work for a few hours, then will just get stuck 'loading' when trying to play an item. One of the logs says: WARN - Waited one whole second for a busy database.

I did update my Windows 10 box this week, and the issues coincide with the update.

I am back with 1.7.5 and will see if that changes anything!

I need to add one of my Shields has also been going down for few minutes then back up.
So doesn't appear to be unique to Windows 10 PMS.


#7

i also have issues with the latest build of Plex reboot server and plex is up for a few moment then it exists on it own.


#8

@Jdratcliffe said:
i also have issues with the latest build of Plex reboot server and plex is up for a few moment then it exists on it own.

I can see you have a server crashing when recording from DVR - your crash is similar to one in this thread which is to do with recording digital radio channels. It has been referred to the development team
http://forums.plex.tv/discussion/277213/version-1-7-5-4035-crashing-randomly/p1


#9

@mashuto said:
Title says it all. Since upgrading to 1.7.6 (skipped 1.7.5) plex has been crashing regularly. At least once or twice a day. I am not sure exactly when or what is causing it, but the unreliability is a major pain. Looking in task manager, the dlna service often seems to be stuck running, but I dont know if thats the cause or what. I have to shut it down from task manager before restarting plex or I cant access plex after restarting.

I am running Windows Server 2016 Essential, build 14393. Attaching logs.

I am afraid i could find references to a crash a few days earlier - the server logs only covered 19th July.
So would need logs collected soon after a crash


#10

hi @sa2000 unfortunate i cannot currently get Plex to stay up long enough at the moment to get the logs. is there a location on windows 10 i can get them to you?

edit got them
James


#11

@Jdratcliffe said:
hi @sa2000 unfortunate i cannot currently get Plex to stay up long enought at th emoment to get the logs. is there a locaion on windows 10 i can get tthem to you?

James

By default they would be here
C:\Users\xxxxxxxxx\AppData\Local\Plex Media Server\Logs

Do you have any scheduled DVR recordings for radio channels?


#12

@sa2000 said:

@mashuto said:
Title says it all. Since upgrading to 1.7.6 (skipped 1.7.5) plex has been crashing regularly. At least once or twice a day. I am not sure exactly when or what is causing it, but the unreliability is a major pain. Looking in task manager, the dlna service often seems to be stuck running, but I dont know if thats the cause or what. I have to shut it down from task manager before restarting plex or I cant access plex after restarting.

I am running Windows Server 2016 Essential, build 14393. Attaching logs.

I am afraid i could find references to a crash a few days earlier - the server logs only covered 19th July.
So would need logs collected soon after a crash

The logs were collected maybe 10 or 15 minutes after I had a crash on the 19th when I posted this. Or at least 10 or 15 minutes after I restarted plex after I discovered it had crashed.

However, I have not had a crash all day today (as far as I can tell... its still up and running), and I don't think I had any crashes yesterday either. So I will keep monitoring it, and will try again to grab logs next time after I discover a crash.


#13

@mashuto said:

@sa2000 said:

@mashuto said:
Title says it all. Since upgrading to 1.7.6 (skipped 1.7.5) plex has been crashing regularly. At least once or twice a day. I am not sure exactly when or what is causing it, but the unreliability is a major pain. Looking in task manager, the dlna service often seems to be stuck running, but I dont know if thats the cause or what. I have to shut it down from task manager before restarting plex or I cant access plex after restarting.

I am running Windows Server 2016 Essential, build 14393. Attaching logs.

I am afraid i could find references to a crash a few days earlier - the server logs only covered 19th July.
So would need logs collected soon after a crash

The logs were collected maybe 10 or 15 minutes after I had a crash on the 19th when I posted this. Or at least 10 or 15 minutes after I restarted plex after I discovered it had crashed.

However, I have not had a crash all day today (as far as I can tell... its still up and running), and I don't think I had any crashes yesterday either. So I will keep monitoring it, and will try again to grab logs next time after I discover a crash.

Thanks - if there is no Plex Crash Uploader log generated at the time of the crash (or after restart) - please could you also check the Application Event Log in Windows to see if any Application Error got logged


#14

@sa2000 said:

@mashuto said:

@sa2000 said:

@mashuto said:
Title says it all. Since upgrading to 1.7.6 (skipped 1.7.5) plex has been crashing regularly. At least once or twice a day. I am not sure exactly when or what is causing it, but the unreliability is a major pain. Looking in task manager, the dlna service often seems to be stuck running, but I dont know if thats the cause or what. I have to shut it down from task manager before restarting plex or I cant access plex after restarting.

I am running Windows Server 2016 Essential, build 14393. Attaching logs.

I am afraid i could find references to a crash a few days earlier - the server logs only covered 19th July.
So would need logs collected soon after a crash

The logs were collected maybe 10 or 15 minutes after I had a crash on the 19th when I posted this. Or at least 10 or 15 minutes after I restarted plex after I discovered it had crashed.

However, I have not had a crash all day today (as far as I can tell... its still up and running), and I don't think I had any crashes yesterday either. So I will keep monitoring it, and will try again to grab logs next time after I discover a crash.

Thanks - if there is no Plex Crash Uploader log generated at the time of the crash (or after restart) - please could you also check the Application Event Log in Windows to see if any Application Error got logged

Got it. Well I went back and checked and this was what I found with a quick search in the logs, for the 19th, at around the time I think it crashed. I have no idea if this is helpful or even what you are looking for. The other two I saw around that time related to plex were I think more related to windows crash reporting.

Faulting application name: Plex Media Server.exe, version: 1.7.6.4058, time stamp: 0x595cddd3
Faulting module name: ntdll.dll, version: 10.0.14393.479, time stamp: 0x58256ca0
Exception code: 0xc0000374
Fault offset: 0x000d9d11
Faulting process id: 0x26bc
Faulting application start time: 0x01d30028bbfe10d5
Faulting application path: C:\Program Files (x86)\Plex\Plex Media Server\Plex Media Server.exe
Faulting module path: C:\Windows\SYSTEM32
tdll.dll
Report Id: 9e5fd964-dd47-4761-bd55-98f123e7d746
Faulting package full name:
Faulting package-relative application ID:


#15

@mashuto said:

@sa2000 said:

@mashuto said:

@sa2000 said:

@mashuto said:
Title says it all. Since upgrading to 1.7.6 (skipped 1.7.5) plex has been crashing regularly. At least once or twice a day. I am not sure exactly when or what is causing it, but the unreliability is a major pain. Looking in task manager, the dlna service often seems to be stuck running, but I dont know if thats the cause or what. I have to shut it down from task manager before restarting plex or I cant access plex after restarting.

I am running Windows Server 2016 Essential, build 14393. Attaching logs.

I am afraid i could find references to a crash a few days earlier - the server logs only covered 19th July.
So would need logs collected soon after a crash

The logs were collected maybe 10 or 15 minutes after I had a crash on the 19th when I posted this. Or at least 10 or 15 minutes after I restarted plex after I discovered it had crashed.

However, I have not had a crash all day today (as far as I can tell... its still up and running), and I don't think I had any crashes yesterday either. So I will keep monitoring it, and will try again to grab logs next time after I discover a crash.

Thanks - if there is no Plex Crash Uploader log generated at the time of the crash (or after restart) - please could you also check the Application Event Log in Windows to see if any Application Error got logged

Got it. Well I went back and checked and this was what I found with a quick search in the logs, for the 19th, at around the time I think it crashed. I have no idea if this is helpful or even what you are looking for. The other two I saw around that time related to plex were I think more related to windows crash reporting.

Faulting application name: Plex Media Server.exe, version: 1.7.6.4058, time stamp: 0x595cddd3
Faulting module name: ntdll.dll, version: 10.0.14393.479, time stamp: 0x58256ca0
Exception code: 0xc0000374
Fault offset: 0x000d9d11
Faulting process id: 0x26bc
Faulting application start time: 0x01d30028bbfe10d5
Faulting application path: C:\Program Files (x86)\Plex\Plex Media Server\Plex Media Server.exe
Faulting module path: C:\Windows\SYSTEM32
tdll.dll
Report Id: 9e5fd964-dd47-4761-bd55-98f123e7d746
Faulting package full name:
Faulting package-relative application ID:

Exact time - to relate it to the logs ?

Looks like heap corruption crash - there is an ffmpeg issue giving heap corruption crashes affecting scanner analysis and transcoding but would not expect it to crash the Plex Media Server.exe process


#16

@sa2000 said:

@mashuto said:

@sa2000 said:

@mashuto said:

@sa2000 said:

@mashuto said:
Title says it all. Since upgrading to 1.7.6 (skipped 1.7.5) plex has been crashing regularly. At least once or twice a day. I am not sure exactly when or what is causing it, but the unreliability is a major pain. Looking in task manager, the dlna service often seems to be stuck running, but I dont know if thats the cause or what. I have to shut it down from task manager before restarting plex or I cant access plex after restarting.

I am running Windows Server 2016 Essential, build 14393. Attaching logs.

I am afraid i could find references to a crash a few days earlier - the server logs only covered 19th July.
So would need logs collected soon after a crash

The logs were collected maybe 10 or 15 minutes after I had a crash on the 19th when I posted this. Or at least 10 or 15 minutes after I restarted plex after I discovered it had crashed.

However, I have not had a crash all day today (as far as I can tell... its still up and running), and I don't think I had any crashes yesterday either. So I will keep monitoring it, and will try again to grab logs next time after I discover a crash.

Thanks - if there is no Plex Crash Uploader log generated at the time of the crash (or after restart) - please could you also check the Application Event Log in Windows to see if any Application Error got logged

Got it. Well I went back and checked and this was what I found with a quick search in the logs, for the 19th, at around the time I think it crashed. I have no idea if this is helpful or even what you are looking for. The other two I saw around that time related to plex were I think more related to windows crash reporting.

Faulting application name: Plex Media Server.exe, version: 1.7.6.4058, time stamp: 0x595cddd3
Faulting module name: ntdll.dll, version: 10.0.14393.479, time stamp: 0x58256ca0
Exception code: 0xc0000374
Fault offset: 0x000d9d11
Faulting process id: 0x26bc
Faulting application start time: 0x01d30028bbfe10d5
Faulting application path: C:\Program Files (x86)\Plex\Plex Media Server\Plex Media Server.exe
Faulting module path: C:\Windows\SYSTEM32
tdll.dll
Report Id: 9e5fd964-dd47-4761-bd55-98f123e7d746
Faulting package full name:
Faulting package-relative application ID:

Exact time - to relate it to the logs ?

Looks like heap corruption crash - there is an ffmpeg issue giving heap corruption crashes affecting scanner analysis and transcoding but would not expect it to crash the Plex Media Server.exe process

Sorry, that one was pulled from 7/19 at 10:00:14 AM server time.

If there is anything else that can help, let me know. In the meantime, the last crash I had was about 9PM for me on the 19th (according to the event logs) and I havent had a crash since. I did attempt a windows update between then so I dont know if that maybe affected something... but I also got a message that the update failed, so I imagine it didnt affect anything. So, at this point, I will monitor for crashes and pull logs again after I notice.


#17

I have not had any downtime in 2 days on my win10 PMS!
I am on 1.7.5 since my crashes - might try going back to 1.7.6 again

But had my shield pro went down this morning for 16 minutes!!

FYI all my PMS are connected to UPS's so I doubt it's a power issue.


#18

@sa2000 said:

@Jdratcliffe said:
hi @sa2000 unfortunate i cannot currently get Plex to stay up long enought at th emoment to get the logs. is there a locaion on windows 10 i can get tthem to you?

James

By default they would be here
C:\Users\xxxxxxxxx\AppData\Local\Plex Media Server\Logs

Do you have any scheduled DVR recordings for radio channels?

@sa2000
i had no recordings of radio shows - but i had tried to record a few things and i have since removed these items from the record schedule and not had a crash since! :smile:


#19

@Jdratcliffe said:

@sa2000 said:

@Jdratcliffe said:
hi @sa2000 unfortunate i cannot currently get Plex to stay up long enought at th emoment to get the logs. is there a locaion on windows 10 i can get tthem to you?

James

By default they would be here
C:\Users\xxxxxxxxx\AppData\Local\Plex Media Server\Logs

Do you have any scheduled DVR recordings for radio channels?

@sa2000
i had no recordings of radio shows - but i had tried to record a few things and i have since removed these items from the record schedule and not had a crash since! :smile:

Do you still have logs for the time you had crashes ?

I can't remember if I looked at any from you


#20

I have not had a crash yet, but ver 1.7.6.4058 running on a Personal Cloud NAS looks like it is recording and goes to 100% but never finishes. It is pretty stable on my i-7 but I am getting some unexplained failures to start a recording. I had to drop back to the Plex version included on my NAS and it seem to be stable. I am still testing in my i-7 to see how bad my unexplained failure to start recording issues are going to be.