LG WebOS 3.0 Player - Subtitles showing during playback whether enabled or not

smart-tv

#1

I did a search to see if this was a known issue, but couldn't find any questions here. I've tried multiple settings for subtitle mode under Server > Languages to no avail. The items being played have subtitles set to none. The subtitle files are tx3g, but I think also happened with and srt file. Is this a know bug? I'm newly on PMS 1.0.x version, but still the same issue. I've explored the LG settings menu as well, but couldn't find an offending setting.

Is there a setting I'm missing or is this a bug in the LG client program? Thanks in advance.

Rich


#2

Nothing in over a month, am I the only one on LG WebOS 3.0 Plex app with subs showing, like it or not???


#3

This makes the LG Plex app unusable with subs on all the time without a means to turn off. My joy turned to sadness when this came out :(


#4

No you are not the only one. In my case this often happens when i change the audio language, suddenly subs appear though the subtitle setting is set to none. When i stop the video and start it again the subtitle setting is set to some language and i am able to disable them.


#5

No, this is happening with my Plex (Version 1.5.2.3557) and 2 of the latest LG web 3.0 TVs also (My 2 older pre 2016 Samsung Plex TV app all fine... yes I havge 4 TV's in my house). So defo LG Plex app .

My workaround was I had to go into Plex movies and for subtitles I had to systematically choose "None" from drop down for all the individual movies. On the LG TV's this removes subtitles from the movies (including for foreign language scenes), but on older Samsung Tv/ Plex App I can still choose subtitles manually (again reinforcing its a LG TV app issues/needing subtitle feature request)

Hope LG give the ability to choose subtitles manually soon.

Hope my work around helps... although admin intensive, but better that buying a new TV :smile: )


#6

Did anyone find a solution to this, I cannot get Subtitles to turn off on my LG TV. They don’t show on any other Plex Player, just the LG no matter what setting I use.