LG WebOS 4.0 wrong language

smart-tv

#1

I just bought a new LG 4K TV today and noticed that while it plays 4K movies fine it seems to be fixed on the wrong audio track.
I played a movie with 2 tracks, German (DTS) and English (AC3), and no matter if I select german or english it always plays the english track.
When I play it in my web browser it plays the audio that was selected correctly. So there's definitely a german and an english track.
I haven't found anything here about this issue and I even switched to "Early access" on LG but the problem remains the same. Only the english track is played. Or am I doing something wrong here?


#2

you can look into “Language and Subtitle Settings” in your account:
https://app.plex.tv/desktop#!/account

however… that should only impact the default audio track selection – not impact you manually setting the language for the movie you want tot play. and even if your TV cannot deal with the DTS track, Plex will transcode it to AC3


#3

@“Master of Tragedy” said:
I just bought a new LG 4K TV today and noticed that while it plays 4K movies fine it seems to be fixed on the wrong audio track.
I played a movie with 2 tracks, German (DTS) and English (AC3), and no matter if I select german or english it always plays the english track.
When I play it in my web browser it plays the audio that was selected correctly. So there’s definitely a german and an english track.
I haven’t found anything here about this issue and I even switched to “Early access” on LG but the problem remains the same. Only the english track is played. Or am I doing something wrong here?

I would try to duplicate your movie and use handbrake ( Free Software) to remove the English audio track from duplicate. Then create a separate German Library if that is what you desire. That way it will play the German track as default.


#4

I’ve installed XPlex now and this is actually playing the german and english tracks correctly when selected.
So there definitely has to be something wrong in the Plex app.