LG WebOS plex app + 4K hevc HDR + subtitles - need help

smart-tv

#1

Hi,

My setup is the following:

Plexserver = QNAP TVS-471
Plex client= WebOS plex app on LG OLED65c7v connected via ethernet)

Problem:

I can play my 4K movies with HDR activated perfectly but only when I disable the subtitles. If I use the embedded subtitles, the server starts transcoding and the movie stutters and HDR is never activated.

What I have tried so far:

  • remux the movie with mkvtoolnix to replace the VOBsub with embedded srt subtitles.
  • remux the movie with mkvtoolnix to remove all embedded subtitles and only use external srt subtitles.
  • tried to play the movie in Xplay both with vobsub and srt (horrible app btw, want to keep away from that).

The above steps do not work and all give the same result.

I am not a native English speaker but my English is ok. So if the choice is HDR enabled or subtitles, it's an easy one. Still I would prefer to have the option to add subtitles.

Does anyone know of this issue and have a solution to it? (aside from hardcoding the subtitles which will take forever with my pc and moving the 4K movies back and forth between my NAS and PC)

Thanks for any info!


#2

You won’t be the only one with this issue. While LG’s OLEDs do support embedded srt subtitles by either playing the movie from storage attached directly to the TV or through DLNA I suspect this may use a different player than the one available to the Plex app. Now @mattseeley has got HEVC direct playing on relevant models maybe he could look at whether it is possible to pass srt subtitles to the TV as well without transcoding?


#3

Ok thanks for the quick reply. So I guess there is nothing to do but wait for LG to tackle this issue. Is mattseeley someone working for LG?


#4

mattseeley works for Plex. He is one of our Smart TV developers.


#5

You definitely aren’t the only one !

I’ll add my name to the list :slight_smile:

a video with or without HDR enabled really is night and day.

It would be amazing to have a feedback from plex, even if it is to say they won’t prioritize it yet. At least we can then move on and try to find other solutions :wink:


#6

@P21 I have the exact same problem on the same TV with the same formats. My CPU isn’t even used for 100% but around 70 - 80. It indeed buffers and HDR get turned off when adding subs. Sometimes HDR wasnt turned of by luck i guess, but then you still have the buffering issue. With Xplay, HDR was kept on while subtitles were added. I really hope that 4k transcoding will be optimized somehow.

If anyone has a solution, let me know. For one or both of the issues.

Does it help to convert HVEC to something else?


#7

@P21 said:
Hi,

My setup is the following:

Plexserver = QNAP TVS-471
Plex client= WebOS plex app on LG OLED65c7v connected via ethernet)

Problem:

I can play my 4K movies with HDR activated perfectly but only when I disable the subtitles. If I use the embedded subtitles, the server starts transcoding and the movie stutters and HDR is never activated.

What I have tried so far:

  • remux the movie with mkvtoolnix to replace the VOBsub with embedded srt subtitles.
  • remux the movie with mkvtoolnix to remove all embedded subtitles and only use external srt subtitles.
  • tried to play the movie in Xplay both with vobsub and srt (horrible app btw, want to keep away from that).

The above steps do not work and all give the same result.

I am not a native English speaker but my English is ok. So if the choice is HDR enabled or subtitles, it’s an easy one. Still I would prefer to have the option to add subtitles.

Does anyone know of this issue and have a solution to it? (aside from hardcoding the subtitles which will take forever with my pc and moving the 4K movies back and forth between my NAS and PC)

Thanks for any info!

P21,

I got the solution.

Use xplay, an external SRT file! The movie won’t be transcoding and HDR stays on. This is the bewst solution i found so far, and it’s a good one IMO. You can use Xplay free for 4 or 5 days, then you need to buy and it will cost you only like one time 7,50 euros. The player is specially made for LF webOS, so it works great. You can also use a slider and start playing the movie in the 60th minute or whatever you want.


#8

Xplay is not a valid solution, it even reminds of the response for people wanting to play flac in itunes back in the day, where the solution was to transcode those files to alac, I mean come on.

Anyway I am excited to finally have the official plex app on webos playing HEVC, but bummed that it doesn’t work with subtitles enabled. It works on Xplay with external subs and so it should also be possible on the official plex app.


#9

Same issue here :frowning:


#10

Yup, same issue here with LG OLED55C7V. Any subtitles cause transcoding, and the transcoder apparently strips HDR metadata from the video stream, so HDR mode is not triggered on the TV.


#11

Good progress, atlast official plex TVos app direct plays 4k HEVC and HDR!
Now if you only could stop the transcode to 1080p that happens when you select a subtitle.
As earlier statement says it works on other apps with external srt subs so it shouldnt be impossible.
Anyways thanks for the update, but im not sure that i like the new ui.


#12

I am afraid this will never get fixed. :frowning:


#13

Yup, the fact that WebOS client was last updated in July 2016 says it all.


#14

@Psych0pomp said:
Yup, the fact that WebOS client was last updated in July 2016 says it all.

The WebOS client is just a container/shell. It is automatically updated. Check the version number in the Settings menu.


#15

@mm98 said:

@Psych0pomp said:
Yup, the fact that WebOS client was last updated in July 2016 says it all.

The WebOS client is just a container/shell. It is automatically updated. Check the version number in the Settings menu.

Yes, I stand corrected. Apparently the “last updated” date in WebOS app store is irrelevant to the actual version of the client installed.


#16

I’ve been following this issue for some time now, as I’m among those impacted – but I have a few clarifying questions.

Who has ownership of this issue? Is it an issue with the Plex software for LG TVs, or is Plex suggesting it’s an issue with the LG Smart TV OS itself? I’ve seen threads supporting both sides of that argument.

Is Plex actively working to address this issue? LG has a markedly increased percentage of the TV market share – for those unaware, the highest rated 4K TVs are LG and that will likely continue to be the case in at least the short term. Simple math tells us there is also an uptick in the use of the LG TV Plex client. Is there a commensurate increase in effort on Plex’s part to resolve issues with this client?

Finally – and I don’t think I’m alone here – I’m a little concerned by what seems to be a lack of acknowledgement of the issue on Plex’s part… unless I’ve missed it somewhere.

Plex folks – any thoughts to assuage the fears of your loyal but concerned user base?


#17

I agree.
I’m in the same boat.
I have a 2017 OLED, and the smart functions are generally pretty good, the apps run at decent speed. Netflix is LIGHTNING fast.
so the TV can do stuff. Plex on the other hand…
Lately they showed the webos Plex app some love, but still, no info, or anything.
the only time i’ve seen any info from the app developer, is when a quick update completely broke the whole player, and it wasn’t working for anybody. he rolled out an update, and that’s it.

The TV can handle srt subtitles from PLEX via the default DNLA player, but it’s not really a solution/option.
XPLAY can do the same (for a small fee)
So the hardware is there, other developers, could get there.

I’d be happy with some acknowledgement, that the issue is on the radar, but it’s not really a priority, we are looking into it, when it’s done, etc, anything.
BUT NOTHING.

Is Plex only used by native speakers, and noone uses subtitles? Or everyone is fine with transcoding??
It’s not even an option with HDR files, cos the metadata is lost, so the colors are messed up, and it needs a really powerful server anyway, all because the software can’t pass a 100kb file to the TV…

well, i guess i just keep waiting.
There is a small light at the end of a tunnel, that WEBOS is not abandoned. This year they added HDR direct play, and last week, they rolled out a brand new player (PMP ui, exoplayer v2) for plexpass users (opt in in the menu).
It’s prettier, but it seems slower, and still no srt support.

maybe someday…
@mattseeley sorry to bother you with the tag, I hope you see the post. Thanks!

EDIT:
I stand corrected.
Markus posted the following in another LG thread:
It does not, supporting direct playing of subtitles is definitely on our radar, especially with 4k becoming more widespread.

So thanks, I’ll keep waiting, and i’ll keep checking the changelogs.


#18

I’m also on the same boat. Watching without subtitles is not an option for me and turn out HDR seems to be a bit silly when I have the OLED TV. It’d be really nice if it worked as soon as possible. It works with XPlay, but it has artefacts sometimes (the source is a remux, so no bad rip).


#19

Soo while subtitles seems to be a problem how are you all getting 4K content to play with the WebOS client? I try to play Dunkirk and its buffering/stuttering all over the place. It does see HDR but after that its not viewable. I am pulling the content from my Synology NAS. Do I need to strip out the subtitles from the main content?

If you can give me some guidance I would be immensely happy. I actually think the WebOS client is the best for my LG OLED TV. It seems to be more crisp than any other streaming device, and is playing audio natively.

Thanks,
Steve


#20

Hi Steve,

To get the PlexOS to play HEVC with HDR you do not need to strip the subtitles from the file, just disabling them in the play settings is enough. However, since you state that HDR does get activated, I assume you already disabled them. If not HDR would not get activated.

To me it seems that your issue is with your connection not being fast enough to play 4K movies. Another possibility is that the server is still transcoding the file for some reason. However, aside from the subtitles I don’t really see what it would transcode.

Maybe you have a (non gigabit) switch in the line perhaps causing a bottleneck?

In any case this does not seem to be related to the topic here and I would start a new post for it.