Library scan not picking up duplicate files in multiple stores

server-linux

#1

Hey all

x2 PMS servers both at v1.8.0.4109 on Centos 6.6 & 7.

I have a NAS serving media to both PMS servers. Each sees the common media store fine and accesses mixed content without issue. The Centos 7 box also has access to a local drive and each of its libraries are pointing to these two sources: the NAS (mounted over the 'net via SSH) and the local drive. Media plays from either location without issue (permissions not a problem).

I now want to move the media from the local drive to the remote NAS drive. The transfer works fine BUT (in the case of the Movies library) the Centos 7 box will not recognise a duplicate media file at the remote location. I want to keep the library data in the DB intact ('date added' for example) so the file is copied as opposed to move with one at both locations. Repeated media scans will not pick it up whereas the library is correctly pointing to both locations.

Does anyone have a suggestion for this behaviour?

Cheers
Pops


#2

Can you give a Host -> dir -> file
or

host/
local-dir-or-remote-share-name/
file

depiction of your media structure ?

If you are trying to do what I think you are by your words, PMS won't be able to detect duplicates in different libraries (directories it's not including in the 'section definition' (where you add folders to library [section] )


#3

ChuckPA

The media structure is as follows: -

NAS (mounted via ssh remotely)

/mnt/FreeNAS/MEDIA/Movies

Local drive

/run/media/plex/PlexDatastore/Movies

Each of the movies are loose files within the main folder, unless there are parts for which a subfolder is used. The current config of the Movies library is therefore as follows: -

Cheers
Pops


#4

You're expressing to me that if you place a file in the remote share (/mnt), which is a duplicate copy of the local one, PMS will not see it?


#5

ChuckPA

Correct. The scanner doesn't notice the same file on the remote mount and update the library entry to say so.

It has access to both shares and plays media from both locations which makes this very odd.

Cheers
Pops


#6

when you go to /mnt, type ls -la, all is good ?

Does user plex have read permission of the parent directory?

I will say this but know you're aware, having a consistent and proper naming structure (Plex standard) does help in these cases. Weird things happen when weird characters are in names. Who knows what characters sshfs doesn't support ?


#7

Chuck

Problem solved. In the end it was indeed a permissions issue. However, because the Plex server connects via SSH to the content server, options for UID and GID were needed for that connection as it did not grant the local mount sufficient permissions of the remote filesystem for RW access. So, when a file was moved across from the Plex server to the content server, it maintained the original (wrong) permissions. As a consequence, there was a mish-mash of permissions in each media folder which conflicted to prevent the scanner from doing its thing. This explains why some files worked and others didn't.

So, a rather boring matter of permissions.

Thanks for your efforts all the same.

Pops