# Linux/Plex preferences.xml failed to load

**URL:** <https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436>\
**Category:** Plex Media Server\
**Tags:** server-linux\
**Created:** [March 13, 2022, 1:33pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436 "2022-03-13T13:33:16Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![hoopie88](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/hoopie88/32/273630_2.png) [@hoopie88](https://forums.plex.tv/u/hoopie88)\
**Post date:** [March 13, 2022, 1:33pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/1 "2022-03-13T13:33:16Z")

</div>

Server Version#:1.25.7.5604-980a13e02  
Player Version#: N/A

I got plex up and running last night, was able to watch a few shows on it no problem no hitch or anything.

This morning, I go to continue watching and I see that plex is down? I login and see what I can’t access [http://localhost:32400/web](http://localhost:32400/web). I check the status of plex and I see that it failed to load the preferences.xml file? It also shows active for 8 hours, what could have caused this or where can I go from here to troubleshoot? I am new to linux so any help would be appreciated!

● plexmediaserver.service - Plex Media Server  
Loaded: loaded (/usr/lib/systemd/system/plexmediaserver.service; enabled; vendor preset: disabled)  
Active: active (running) since Sat 2022-03-12 23:40:03 EST; 8h ago  
Process: 1664 ExecStartPre=/bin/sh -c /usr/bin/test -d “${PLEX\_MEDIA\_SERVER\_APPLICATION\_SUPPORT\_DIR}” || /bin/mkdir -p “${PLEX\_MEDIA\_SERVER\_APPLICATION\_SUPPORT\_DIR}” (code=exited, status=0/SUCCESS)  
Main PID: 1703 (PMS RunServer)  
Tasks: 2 (limit: 408206)  
Memory: 67.0M  
CGroup: /system.slice/plexmediaserver.service  
└─1703 /usr/lib/plexmediaserver/Plex Media Server

Mar 12 23:40:03 BigDaddyServer systemd[1]: Starting Plex Media Server…  
Mar 12 23:40:03 BigDaddyServer systemd[1]: Started Plex Media Server.  
Mar 12 23:40:03 BigDaddyServer sh[1703]: Failed to load preferences at /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml  
Mar 12 23:40:05 BigDaddyServer sh[1703]: Failed to load preferences at /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml

Not sure if this is also something I needed to do but I tried to re-claim my server and this is the error I get:

curl -X POST ‘[http://127.0.0.1:32400/myplex/claim?token=TOKENREMOVED](http://127.0.0.1:32400/myplex/claim?token=TOKENREMOVED)’

curl: (7) Failed to connect to 127.0.0.1 port 32400: Connection refused

---

<div class="post-metadata">

**Author:** ![hoopie88](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/hoopie88/32/273630_2.png) [@hoopie88](https://forums.plex.tv/u/hoopie88)\
**Post date:** [March 13, 2022, 7:12pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/2 "2022-03-13T19:12:50Z")

</div>

As an update I followed the steps at the bottom even though I am not using Ubuntu, I was able to get everything set back up.

> **[How to Install Plex Media Server on Ubuntu 18.04 LTS Server or Desktop](https://www.linuxbabe.com/ubuntu/install-plex-media-server-ubuntu-18-04)**
>
> This tutorial shows you how to install Plex media server on Ubuntu 18.04 LTS server/desktop. Enable Plex repository and access external hard drive

---

<div class="post-metadata">

**Author:** ![CostaHT](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/costaht/32/193414_2.png) [@CostaHT](https://forums.plex.tv/u/CostaHT)\
**Post date:** [March 13, 2022, 7:35pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/3 "2022-03-13T19:35:37Z")

</div>

The `curl` connection was refused because the server was down. To me, the error loading Preferences file is a symptom of another problem you might have with your host, but I’m glad you’ve got it running again

---

<div class="post-metadata">

**Author:** ![hoopie88](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/hoopie88/32/273630_2.png) [@hoopie88](https://forums.plex.tv/u/hoopie88)\
**Post date:** [March 13, 2022, 7:47pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/4 "2022-03-13T19:47:12Z")

</div>

Is there anywhere I can possibly look into linux that would show what might have caused it?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [March 13, 2022, 7:48pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/5 "2022-03-13T19:48:19Z")

</div>

To add,

The plex package has been completely overhauled since Ubuntu 18.

Removing Preferences.xml is not necessary and will ‘make a mess’ by causing duplicate servers with the same hostname.

---

<div class="post-metadata">

**Author:** ![hoopie88](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/hoopie88/32/273630_2.png) [@hoopie88](https://forums.plex.tv/u/hoopie88)\
**Post date:** [March 13, 2022, 7:52pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/6 "2022-03-13T19:52:07Z")

</div>

I wasn’t even able to get to the GUI, I wasn’t sure what the best practice approach should have been and was only guessing.

Is there a link to what I should have done, in case this happens again?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [March 13, 2022, 7:53pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/7 "2022-03-13T19:53:29Z")

</div>

How far along are you in the setup process?

I ask because there are two approaches.

---

<div class="post-metadata">

**Author:** ![hoopie88](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/hoopie88/32/273630_2.png) [@hoopie88](https://forums.plex.tv/u/hoopie88)\
**Post date:** [March 13, 2022, 7:56pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/8 "2022-03-13T19:56:12Z")

</div>

Once I deleted the xml file I was able to bring everything back up as if nothing had happened, it took me back through the setup process but my server was still there

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [March 13, 2022, 7:58pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/9 "2022-03-13T19:58:30Z")

</div>

Preferences.xml contains the server’s identity information too.  
It’s important to NOT delete it.

The instructions you showed, with exception of the SSH tunnel, aren’t applicable anymore.

---

<div class="post-metadata">

**Author:** ![hoopie88](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/hoopie88/32/273630_2.png) [@hoopie88](https://forums.plex.tv/u/hoopie88)\
**Post date:** [March 13, 2022, 7:59pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/10 "2022-03-13T19:59:20Z")

</div>

I get that, but something happened. Is there a log somewhere that I can pull to see what might have caused it?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [March 13, 2022, 8:03pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/11 "2022-03-13T20:03:44Z")

</div>

the only log you might find is the system log (journalctl)

---

<div class="post-metadata">

**Author:** ![hoopie88](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/hoopie88/32/273630_2.png) [@hoopie88](https://forums.plex.tv/u/hoopie88)\
**Post date:** [March 13, 2022, 8:07pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/12 "2022-03-13T20:07:28Z")

</div>

I will take a look, I also did check the .xml file before deleting it and it was empty. Is that to be expected?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [March 13, 2022, 8:14pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/13 "2022-03-13T20:14:39Z")

</div>

If it’s empty, the only way that’ll happen (99% of the time) is when the runtime username changes or the directories are moved (APP\_SUPPORT\_DIR changes) and perms are not set correctly)

---

<div class="post-metadata">

**Author:** ![hoopie88](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/hoopie88/32/273630_2.png) [@hoopie88](https://forums.plex.tv/u/hoopie88)\
**Post date:** [March 13, 2022, 9:57pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/14 "2022-03-13T21:57:35Z")

</div>

What do you need to see so I can show you my perms to make sure they are setup correctly? I think maybe that was it? Because it looks like it is happening again

---

<div class="post-metadata">

**Author:** ![hoopie88](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/hoopie88/32/273630_2.png) [@hoopie88](https://forums.plex.tv/u/hoopie88)\
**Post date:** [March 13, 2022, 11:43pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/15 "2022-03-13T23:43:00Z")

</div>

Anything you recommend that I can check on?

---

<div class="post-metadata">

**Author:** ![jbriard](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/jbriard/32/234824_2.png) [@jbriard](https://forums.plex.tv/u/jbriard)\
**Post date:** [March 14, 2022, 12:18pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/16 "2022-03-14T12:18:21Z")

</div>

Hello,

I’m running Plex 1.25.6.5577 on Fedora, and I had to restart the server for an update, and I get the same error message.  
The server is not starting and the Preferences.xml file is empty…

---

<div class="post-metadata">

**Author:** ![hoopie88](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/hoopie88/32/273630_2.png) [@hoopie88](https://forums.plex.tv/u/hoopie88)\
**Post date:** [March 14, 2022, 5:22pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/17 "2022-03-14T17:22:08Z")

</div>

If you stop plex then delete the preferences file, then start plex again are you able to get the setup menu to show when logging in locally?

---

<div class="post-metadata">

**Author:** ![hoopie88](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/hoopie88/32/273630_2.png) [@hoopie88](https://forums.plex.tv/u/hoopie88)\
**Post date:** [March 14, 2022, 6:56pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/18 "2022-03-14T18:56:28Z")

</div>

What info as far as permissions do you need to check to confirm everything is setup correctly?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [March 14, 2022, 7:19pm UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/19 "2022-03-14T19:19:43Z")

</div>

@hoopie88

If you haven’t customized Plex and it’s running as the default username `plex:plex`,  
you can confirm everything is as it should be with the command:

```auto
sudo chown -R plex:plex /var/lib/plexmediaserver

```

This will set, without looking, the ownership of all files in /var/lib/plexmediaserver to plex’s ownership (as it should be).

If anything was changed (damaged) in there, this will correct it.

**If you customized PMS to run as a different user, repeat the above command to be that username**

---

<div class="post-metadata">

**Author:** ![watice](https://avatars.discourse-cdn.com/v4/letter/w/50afbb/32.png) [@watice](https://forums.plex.tv/u/watice)\
**Post date:** [March 16, 2022, 1:54am UTC](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436/20 "2022-03-16T01:54:48Z")

</div>

Had an unfortunate reboot caused by circumstances out of my control and upon startup, getting the same error from plex. Running 1.25.6.5577 . Preferences.xml is now a completely empty file. Is this a widespread issue?

edit: resolved by moving the empty Preferences.xml file out of the default dir, running setup again using 32400/web. Thankfully this did not alter plex data for libraries at all, just the home screen.

[Next page](https://forums.plex.tv/t/linux-plex-preferences-xml-failed-to-load/780436.md?page=2)
