Linux plex server won't start after sudden power loss

server-linux

#1

After a sudden power loss my Plex server stop working. Server boots just fine but Plex services wont start. I tried "sudo service plexmediaserver start". Still not working. When I try getting on it on the web it shows "ERR_CONNECTION_REFUSED". I am on a local connection.


#2

Is the server process running or not?

Have you scrutinized the log file? What does it tell?

Nobody here is a "Hellseher."


#3

The server process is not running, but where do I go for the log file?


#4

That depends on where you asked to have them stored. We do not know any about your setup. Look in start.sh of your PMS installation or /etc/defaults/plexmediaserver or /etc/init.d/plexmediaserver for a definition.

A generic place would be ~plex/Library/Logs/

Btw, there is also a support article on that.

You should find a recent file named "Plex Media Server.log". Look at its tail. If it does not immediately give a clue to you, attach the file to your next posting. There are people here - way more knowledgeable than I am, which will spot the problem.


#5

I am running Ubuntu 16.04 w/ Plex Version 1.7.5.4035 and I also can confirm that anytime I lose power suddenly, the next time I boot up Plex is corrupt and I have to remove the "/var/lib/plexmediaserver/Library/Application Support/Plex Media Server" folder and start over. I have tried several times to fix the problem to no avail, redo is all that ever seems to work. I sure wish I knew why this happens.


#6

This is why one shoud run a server on a UPS. I recommend the APC Pro series. They are a little more expensive at arround 150€, but you can replace the Batterie inside and run your ethernet through it as well. This protects you in case of a lightning strike. If you dont know what a UPS is: It is a glorified Battery which shuts your PC down gracefully before it comes to a power loss.