LiveTV on Fire TV 1st gen and fire stick



I'm a plex pass subscriber running Server Version on FreeBSD (FreeNAS). The server has plenty of power to transcode multiple streams at a time. My tuner is an HDHR Prime with Cable Card and I'm only trying copy freely channels. I am able to play live TV from the browser, my Android phone and my Fire TV 2nd Gen. I'm not able to get Live TV working on My Fire TV 1st Gen or Fire Stick.

Sometimes I get an error that it failed and to restart the server and app. Other times it just goes back to the "watch now" screen or restarts the Plex app. When looking at the server status I see a line "Recording Live TV - Session" but I only see the "user started playing Live Session on Fire TV" When it works on my 2nd gen Fire TV.

Any thoughts?


I have a 1st gen fire tv, hdprime with cablecard and have the exact same issue watching live tv on firebox. I have no issues on my android devices


It seems the issue is not device specific as my fire stick began working and my Fire TV gen 2 stopped. My Fire TV boxes are hardwired.

I also noticed two other potentially interesting things:
* The HDHR never showed the channel being tuned in
* I cannot access the settings section on my Fire Stick


I can watch Live TV via desktop browser and Android phone. Plex keeps crashing when I try to play it on my Gen 1 Fire TV and Gen 2 stick though.


I have a first generation FireTV and a HDHomerun Prime. I have the same problem with HD channels. SD live TV works for me. If I change the streaming max to 480p, live TV works for me on HD channels.

So in my case, it appears the FireTV is unable to play live TV at a resolution greater than 480p.

720p/1080i live TV works fine on other clients for me.


Seems to be related to the version of H.264 decoding supported by the older devices. (At least for me) The Gen 2 devices support ver 5.0 and higher. The Gen 1 devices are at 4.0. Im fine on all my Gen 2 devices with 5.0 & 5.1. But my Gen 1 FireTV box @ 4.0 will not play. Waiting on the new boxes that have been rumored to upgrade across the board.


Just bump the max 264 setting in the Plex app to 5.0 or 5.1 - see if the item will play.

I play 5.1 items all the time with my Gen 1 AFTV or at least I used to until... this great new app came to town.


I tried bumping the h.264 levels up and down. No change other than 480p stopped working at 5+ which is notable because it failed in the same manor as the HD streams.


There are some server controls now - I think - be sure to explore fully all the new (and hidden cleverly) controls. There's that very mysterious 'Play Smaller Videos at Original' setting. I'm not the sharpest knife in the drawer, but who the hell comes up with this **** - and more importantly how TF does it work?


Just an update:

Live TV worked flawlessly last night on my first gen FireTV with the latest Plex client.

I'm doubtful it is fully stable but at least there is progress!