Loading metadata for ... / Finished processing ... every time I browse movies



Browsing movies via DLNA is very slow for me - no matter what the device is. When i watch the server in /activity/alerts I notice each movie get processes every time I browse to the list of movies. It's doesn't seem to cache them.

Is this normal ? Is there a setting to stop this and speed it up?

(I'm running Plex on a FreeNAS server)

thanks in advance.


I have the same issue. I have a Toshiba blu-ray player that will reset the connection every time something on the DLNA server changes, so it's causing me to never make it passed the menu. Every time I try to browse selections, it says the server has refreshed. I'm guessing this is the same thing.

Plex on WinXP


I spent almost a full day looking into this:

  • If I view the 'all movies' via chrome, it does all the processing and the cache is properly created from that point on. So I no longer get the "Loading metadata for ... / Finished processing" messages. So that was NOT the cause as I suspected.

  • However - viewing the 'all movies' via UpNP from my ASUS O!Play HDP-R1 never works - it just hangs and requires the box to be powered off.I have about 988 movies in that folder.

  • If I view by the first letter, director, country etc it always works.

  • I checked the "All Movies" folder from other client devices (chromecast, 2 x LG TVs via app and DLNA, Air Player iPhone app) and it works fine, so I suspect there is something wrong in the communication between the O!Play and Plex.

  • I re-flashed the O!Play with all sorts of home brew firmware - they all have the same problem.

  • When I view the folder via SMB from the O!Play it works okay and can show all the 988 movies.

  • I removed all the /mkv files with chapters to see if that was the problem - no luck

  • Turned off GDM and tried every other setting in Plex server - did not fix it either

  • I removed a lot of movies and left about 366 movies and it worked fine, at 500 movies it failed.
    -** I fired up a JRIVER Media Server pointing to the same movies - the OPlay had no problem reading all the movies in a single DLNA folder**

This is a real shame because it makes the O!Play unusable for Plex.
I have Plex running on a FreeNAS server, all connections are hard wired.

Is there some diagnostics I can run to help get this resolved? Sometimes the OPLAY would only show the first 256 movies. This seems to point to a limit somewhere?


I had (have) the same problem. Browsing series tooks minute to display, because for every episode it searched for metadata.
My "solution" was to set the library as home video. So there is no meta data anymore, the only way to browse fast until now.


I've got the same problem on my Ubuntu VPS, which runs a PMS with a library on Amazon Cloud Drive through acd_cli. As the library grows, Plex keeps rescanning all my media and hogging my CPU.

In my debug logs I see a lot of "[0x7f118c1fc700] DEBUG - Doing expensive tags write for 'Movie Title Here' because something changed."

Any help? Thanks!


Any solution?