LOADS of movies NOT matching

server-mac

#1

I just had to rebuild my movie collection i deleted my old locations and re-added the folder.. but now about 1000 (yes that many) movies haven't matched.

i have to manually go in and fix incorrect match them !!!!

advice?

there has to be an easier way.

every movie is file named as such: Batman(1989).mkv

 

The movie database is my primary agent HELP!!!!


#2

Okay.  Take a deep breath.  It seems like they should be matching just fine with TMDB as your primary agent.  Can you provide a log from the matching session where they're not?

~/Logs/PMS Plugin Logs/com.plexapp.agents.thetvdb.log freshly after running a scan..


#3

*breathes in

running scan, ill post log after


#4

If that doesn't resolve your issue, have you tried an auto renaming tool? All my files are first put into FileBot and renamed.. which is completely customizable.. 

for movies eg. Aliens.1986.Bluray.1080p.x264.DTS.mkv

for tv shows eg. Ancient Aliens - S01E01 - The Evidence 720p.x264.DTS.mkv

 

Media Naming Guide

 

never had a major issue..


#5

i cant find the log... is that the correct address?


#6

my files are named like that.. so why would i need to?


#7

i cant find the log... is that the correct address?

~/Library/Logs.....


#8

found it....

whats the verdict?


#9

any luck?


#10

no solves?


#11

Oh hey, sorry, so from the log I don't see any real errors and it seems to be working properly for what's there.  However, if that's the whole log, then it looks like it's doing the initial matching for your movies, but it's not continuing on to do the updating (where it actually downloads and updates the metadata).

I'm not entirely sure what may be causing this, but you can try quitting the Media Server, then deleting System.bundle and Framework.bundle and maybe The-Movie-Database.bundle from your Plug-ins directory, then starting it back up and trying again?


#12

ok did that

still no better

any other suggestions??


#13

as a last resort... how do i do a clean reinstall of plex?

my plex media server has its own icon i have to start up as well as plex... is that normal? 


#14

As a slightly less thermonuclear option, you can try just rebuilding your movies section first.  Remove the section, do a "Clean Bundles" from the main screen "My Library" -> "More" menu, and re-add it.

If you really want to, this command at the command line will do a complete uninstall (quit PMS first):

sudo rm -rf "/Applications/Plex Media Server.app" "~/Library/Application Support/Plex Media Server" "~/Library/LaunchAgents/com.plexapp.mediaserver.plist" "~/Library/Caches/PlexMediaServer" "~/Library/Preferences/com.plexapp.plexmediaserver.plist"

#15

Mine was a problem with TV show metadata not loading.

The following fixed the issue for me:

On Mac OS X plex stores several files in the User Library 

First Quit Plex Media Server (make sure no one in the house may be watching something ;) )

either use Go To Folder and put in ~/Library/Application Support/Plex Media Server/Plug-ins/  , 

or in the go menu, hold down Option, and select Library then browse to the folder

In there delete "Framework.bundle" and "System.bundle"

If the problem only seems to be affecting TV or Movies, then you could also delete the appropriate plug-in (in my case TheTVDB.bundle)

When you start-up Plex Media Server again, it will replace the ones you just deleted.

In my case, this immediately solved the problem with Meta Data not appearing (or downloading, not sure which was the issue)


#16

i just tried both the above..

including deleting movies and re-adding it...

what else could it be??


#17

i discovered the problem- i think

its the movie database.. if you compare its dates that it matches against say IMBD

it has different dates altogether (usually a year off)... or the same movie with two dates (heathers as a e.g.)


#18

Sorry, you're saying TMDB and IMDB have different dates for *thousands* of movies in your collection?

Can you give me a few examples?  I've only seen this on like two occasions ever.  For all the ones visible in your first screenshot, e.g. TMDB has matching years.


#19

ill screen shot it

but not thousands

i had roughly a 1000 that didn't match but this doesnt cover all of those

as Warm bodies i just added and it wouldnt match


#20

I've noticed this happening to me just recently....Jack Reacher got named something funky, and then Side Effects got named "The Bitter Pill." My movie agent was set to freebase (by default, I never messed with this), so I changed to TheMovieDatabase agent and now it seems to be scanning fine...