Macbook Pro 2016 CPU usage 100% temp. problem

server-mac

#1

Hi, I've recently bought a 2016 MBP 15", installed PMS and when playing a 1080p .mkv file the app use 100% of the CPU and the temp goes up to more than 90°C. The transcode setting is set to automatic. I would like to know if there is a way to maintain the best quality possible but limit the % of the cpu usage to something like 80-70% to obtain normal temperatures? The only way is lower the quality of the transcoding process?

Thanks.


#2

Check if you have thumbnails enabled in PMS Settings/Library , if so uncheck.


#3

@Gdr56 said:
Check if you have thumbnails enabled in PMS Settings/Library , if so uncheck.

I've disabled the thumbnails and now every 3 or 4 minutes the cpu goes to 100% but the temps stays under 80°, better but still a little bit high. Thanks.


#4

@james_911 said:

@Gdr56 said:
Check if you have thumbnails enabled in PMS Settings/Library , if so uncheck.

I've disabled the thumbnails and now every 3 or 4 minutes the cpu goes to 100% but the temps stays under 80°, better but still a little bit high. Thanks.

Are we looking at a large library?

Make sure your scheduled tasks are being executed at time the Macbook pro is active


#5

@Gdr56 said:
Are we looking at a large library?

Make sure your scheduled tasks are being executed at time the Macbook pro is active

Yes, the library is large; but what do you mean by scheduled tasks?

Thanks.


#6

@Gdr56 said:

Are we looking at a large library?

Make sure your scheduled tasks are being executed at time the Macbook pro is active

The schedule task now are being executed correctly but even without the thumbnail preview and the transcoding option to "high speed" the CPU pikes up to over 80°C.

There is a way to set PMS to use only 60/70% of the CPU power?

Thanks.


#7

James, just to be sure it not something else try the following.

Etrecheck, it will do a lot system check hardware and software. It's freeware and works a treat.

https://etrecheck.com/


#8

@Gdr56 said:
James, just to be sure it not something else try the folowing.

Etrecheck, it will do a lot system check hardware and software. It's freeware and works a treat.

https://etrecheck.com/

The report says "Performance: Excellent" and everything is ok. The laptop is brand new and works fine.


#9

@james_911 said:

@Gdr56 said:
James, just to be sure it not something else try the folowing.

Etrecheck, it will do a lot system check hardware and software. It's freeware and works a treat.

https://etrecheck.com/

The report says "Performance: Excellent" and everything is ok. The laptop is brand new and works fine.

Ok, that real good. Now that's out of the way, i will ask does this behavior occur when using handbrake to transcode a file from mkv to mp4?


#10

@Gdr56 said:

Ok, that real good. Now that's out of the way, i will ask does this behavior occur when using handbrake to transcode a file from mkv to mp4?

If I turn off the .mkv subtitles the pikes on the CPU disappears and the temps stay low. The problems are the built-in .srt subtitles in the .mkv file.

Is there something to solve this .srt transcoding issue??

Thanks.


#11

Thinking about this issue, your concern heat or CPU usage? Heat can be a concern so have a look at this freeware.

https://www.macupdate.com/app/mac/23049/smcfancontrol

I use it in the summer months in Australia on my iMac, works a treat. During transcoding with handbrake or running PMS if it needs to transcode.
If none of what I'm suggesting suits, what version of MacOS are you running with PMS. I personally don't see the persistent issues your suggesting. I'm on Sierra 10.12.6 with PMS 1.7.5.4035-313f93718
Possibles:
Malware or Virus
Short on Ram
High bit rate Transcoding
Subtities


#12

@james_911 said:

@Gdr56 said:

Ok, that real good. Now that’s out of the way, i will ask does this behavior occur when using handbrake to transcode a file from mkv to mp4?

If I turn off the .mkv subtitles the pikes on the CPU disappears and the temps stay low. The problems are the built-in .srt subtitles in the .mkv file.

Is there something to solve this .srt transcoding issue??

Thanks.

You can use handbrake and remove the subs from the file if not required. Are your settings like attachment?


#13

@Gdr56 said:

@james_911 said:

@Gdr56 said:

Ok, that real good. Now that’s out of the way, i will ask does this behavior occur when using handbrake to transcode a file from mkv to mp4?

If I turn off the .mkv subtitles the pikes on the CPU disappears and the temps stay low. The problems are the built-in .srt subtitles in the .mkv file.

Is there something to solve this .srt transcoding issue??

Thanks.

You can use handbrake and remove the subs from the file if not required. Are your settings like attachment?

Unfortunately I need the subs, I’ve tried removing the tracks that i don’t use with mkvtoolnix, tried the settings you suggested, tried with external .srt file; nothing works, as soon as i enable the subs the CPU goes from barely nothing to 100% and the temps from 45°C to more than 80°C. The problem is that when some subs are selected PMS redo the transcode of the file while playing it.


#14

@james_911 said:

@Gdr56 said:

@james_911 said:

@Gdr56 said:

Ok, that real good. Now that’s out of the way, i will ask does this behavior occur when using handbrake to transcode a file from mkv to mp4?

If I turn off the .mkv subtitles the pikes on the CPU disappears and the temps stay low. The problems are the built-in .srt subtitles in the .mkv file.

Is there something to solve this .srt transcoding issue??

Thanks.

You can use handbrake and remove the subs from the file if not required. Are your settings like attachment?

Unfortunately I need the subs, I’ve tried removing the tracks that i don’t use with mkvtoolnix, tried the settings you suggested, tried with external .srt file; nothing works, as soon as i enable the subs the CPU goes from barely nothing to 100% and the temps from 45°C to more than 80°C. The problem is that when some subs are selected PMS redo the transcode of the file while playing it.

Try Smc fan control then, crank up when playing those files.

Just curious to what are playing the file through, TV app or a player like Roku.


#15

@Gdr56 said:

Try Smc fan control then, crank up when playing those files.

Just curious to what are playing the file through, TV app or a player like Roku.

I'm using "Macs Fan Control"; The client is a SONY kdl-50w808c tv.

Maybe I'll try posting the question in the Android TV section to see if the issue is fixable in some way.


#16

Have you transcoded the file to Mp4 I believe that may resolve your issue.


#17

@Gdr56 said:
Have you transcoded the file to Mp4 I believe that may resolve your issue.

Transcoding a single file with the PMS function require approx 35/40 min and for that time the CPU will stay always at full 100% usage. It's not worth it, for now I'll stay with my high temps and wait for some Android TV's app update...