Media Player Error, Resetting!



Yesterday morning I was able to play music via Plex. After the circuit to all my devices was turned off and on, I have not been able to play music or video with Plex. Have used all the usual fixes, such as restarting Nvidia, NAS and router. A song will play when directly accessed on the NAS via Grove Music on a WIN 10 machine. As far as I know, I'm on the latest versions of everything.


Is this the venue for fixing things when Plex doesn't work. How do I get help?


The only media I can play in Plex is Stations and recorded shows that were created by SiliconDust DVR which was saved to a separate HD connected to Nvidia Shield via USB. All my other media is on a NAS. I can see the NAS via windows and even play music from there, I'm assuming Plex cannot see the NAS anymore. I unplugged and plugged in the NAS instead of rebooting in case that clears it up. Running out of options here.

PS, still not working after the last NAS option...


Plex is effectively useless to me now. Can anyone (Nija) walk me through troubleshooting this? I've done all the easy stuff.

BTW, when I'm looking at a video program icon where I would normally use the Play icon, it states the file is Notavailable.


I tried to create a new library for another music lib and the only things that pre-filled under folders are the two drives associated with my Nvidia Shield. It does not see any of my NAS units (MyBook Live). I can use WIN 10 to see those drives in Explorer or Chrome, so I know they can be seen on my network that way. So is this a Plex or Nvidia Shield problem, or something else?


Just saw this post.

How is the path to your NAS mapped in PMS? Did you use a drive letter, mount name, or IP address? Whatever you used, check that it hasn't changed.


I pulled
/storage/MYBOOKLIVE1/Public/Shared Music/Beck/Morning Phase/01 Beck - Cycle.flac
from my PMS library.

Haven't changed it for years, when I first started using MM to create my MM library.

If I use
\MYBOOKLIVE1\Public\Shared Music\Beck\Morning Phase\01 Beck - Cycle.flac
in File Explorer, it plays the music on my WIN 10 PC.

Curious that the device doesn't appear under the devices in the library folder when creating a new library, whereas the two attached drives for my Nvidia Shield do.


Just noticed that MYBOOKLIVE1 exists under Nvidia Shield's Storage & reset --> Network Storage. So the Shield can see it... perhaps Plex is the culprit?

EDITED: 03/21
This is the point where knowing how to check if the device is actually connected or not would have saved four days of back and forth noted below...


So the question appears to be, if my WIN10 and Nvidia Shield devices can see this NAS, why can't Plex, which is also on the Shield. Is there anything else I can send you to further your troubleshooting? You are working on this, right? You saw that I can't use Plex anymore to play any of my music of videos?


Restart PMS, wait 3 minutes without doing anything. Open up Plex Web and try to add that folder that you say can't be accessed. Then get me the entire PMS log package.


In Plex on my Nvidia Shield, I went into Settings > Advanced > Plex Media Server and turned the service off and on again.
Waited ~ 3 minutes...
Then I went to Settings > Server > Help in Plex Web App and clicked on the Download Logs button.
Probably more like ~8 Minutes...
Of course I had to look this up to be able to do it, since Plex is not a full time job for me, just a hobby...


Your PMS looks like it's starting up and running properly. Can you use the Shield as a player too and try playing back a video? Then get me the logs again (no need to restart this time). Also get me the player log. And finally provide me the XML for that video you just tried playing.


I tried to find Privacy per these instructions, but couldn’t. If logging is not set up right, I’ll need much better instructions:
Enable Network Logging
To Enable Network Logging:
Sign In: Make sure you’ve signed in with your Plex account in the app under Settings > Account
Enable Network Logging: Enable remote logging, which is found under Settings > Advanced > Privacy

I tried playing the video within Plex on the Shield.

I have attached the same log type as yesterday.

When I tried using “http://IPofAndroidDevice:32500/logging (where IPofAndroidDevice is the local IP address of your FireTV or Android TV)”, I got “Failure: 404 Not Found”

This is the contents from the “View XML” link (invisible unless in edit mode) which I also attached

<MediaContainer size="1" allowSync="1" identifier="com.plexapp.plugins.library" librarySectionID="9" librarySectionTitle="Concerts" librarySectionUUID="bcb98edc-acd4-41b4-bbe8-43dde20cf2d7" mediaTagPrefix="/system/bundle/media/flags/" mediaTagVersion="1489712116">
<Video ratingKey="25589" key="/library/metadata/25589" guid="local://25583" librarySectionID="9" librarySectionKey="/library/sections/9" type="movie" title="Scala and Kolacny Brothers Live in Bruges 00" summary="" viewOffset="717761" viewCount="1" lastViewedAt="1489591392" thumb="/library/metadata/25589/thumb/1486704269" art="/library/metadata/25589/art/1486704269" duration="3514644" addedAt="1486684468" updatedAt="1486704269" chapterSource="media">
<Media videoResolution="480" id="30804" duration="3514644" bitrate="6192" width="720" height="480" aspectRatio="1.78" audioChannels="2" audioCodec="ac3" videoCodec="mpeg2video" container="mkv" videoFrameRate="NTSC" videoProfile="main">
<Part accessible="0" exists="0" id="30929" key="/library/parts/30929/1486683275/file.mkv" duration="3514644" file="/storage/MYBOOKLIVE1/Public/Shared Videos/Concerts/Scala/Scala and Kolacny Brothers Live in Bruges 00.mkv" size="2720369340" container="mkv" videoProfile="main">
<Stream id="35977" streamType="1" codec="mpeg2video" index="0" bitrate="5877" language="English" languageCode="eng" anamorphic="1" bitDepth="8" chromaSubsampling="4:2:0" codecID="V_MPEG2" colorRange="tv" duration="3514648" frameRate="29.970" frameRateMode="cfr" height="480" level="8" pixelAspectRatio="186:157" pixelFormat="yuv420p" profile="main" refFrames="1" scanType="interlaced" width="720"/>
<Stream id="35978" streamType="2" selected="1" default="1" codec="ac3" index="1" channels="2" bitrate="192" language="English" languageCode="eng" audioChannelLayout="stereo" bitDepth="16" bitrateMode="cbr" codecID="A_AC3" dialogNorm="-31" duration="3514644" samplingRate="48000" title="Stereo"/>
<Extras size="0"></Extras>


I tried to find Privacy per these instructions, but couldn't.

I think you read the wrong part of the article. Look furhter down for the Android TV section.

Settings > Privacy Row > Network Logging > ON

Mar 21, 2017 10:36:41.648 [12525] ERROR - Error opening file '/storage/MYBOOKLIVE1/Public/Shared Videos/Concerts/Scala/Scala and Kolacny Brothers Live in Bruges 00.mkv' - 2

I keep seeing that in your log. Looks like PMS is having issues reading the file itself. Is this the only file causing issues or does this happen with lots of videos? Can you try playing something saved a different location?


I cannot play any picture, music or video from mybooklive1 (NAS). I can play videos from the HD attached to the Shield which were recorded using HDHomeRun. All drives can be seen by the Shield. When using add library in Plex, it only sees the SSD and HD attached to the Shield, it does not see the 2 NAS devices.

Gary Kinsman via iPhone


@gdkinsman said:
When using add library in Plex, it only sees the SSD and HD attached to the Shield, it does not see the 2 NAS devices.

That sounds like the problem there. Check your Shield Network settings and make sure your NAS's are still mounted properly.


As before, on the Shield I went to Settings > Device > Storage & reset > Network Storage, I saw my two NAS units plus "Sheild". The NAS units had the right IP address and I was wondering how to check them further. My first thought was that I could remove them and add them back in. So not knowing what to do, I pressed the OK button where the cursor was over MYBOOOKLIVE1. Form there I saw the options to connect, which told me it was no longer connected. I put in my ID and Password and was connected. Things are now back as they were.

Since this all came to light after all devices were turned off and on, on the 14th, I looked at the updates for the Shield and Plex around that date. There was a Plex android update on March 6th and Plex Media Server update on March 2. There was also an Nvidia Shield 5.1 upgrade on 2/17. I suppose the Shield is a more likely suspect here, but I suppose simply having everything turned off and on again may have triggered this whole affair.

What do you think caused this to occur?


I have not seen anything in the Plex Media Server of Plex client updates that could have removed the network shares. When I updated my Shield, I did not lose my network shares, so I'm not sure that was the cause either.

Rolling back the Shield update is not possible so we can't test it. This may be one of those things that will remain a mystery. At least until the next Shield update.


Perhaps this is an ongoing Shield issue: