Media Unavailable - Sync Storage Location Changed from External to Internal!

android-mobile

#1

Hi all,

I have 'around' 20 movies synced to my phones External Storage (always has been synced to this location)... however recently I got a Plex notification about remaining space on my Andorid phone saying only 5GB free but it was referring to my internal storage...

Checked Plex and found I could no longer play any movies... "Media Unavailable - The file associated with this item is not accessible by the server. Please verify that the file exists and the necessary drive is accessible"

When checking Sync settings, all movies are still listed including cover art under the "Synced Items" however the storage location is set to "Internal Storage" and it should be "External Storage".

Trying to change it back to External Storage but am told "Change sync Location - Changing the sync location will result in any currently synced items being deleted. Are you sure you want to continue?"

If I check the External storage location I can confirm the expected large storage use at the following path:
- Storage/0000-0000/Android//Data/com/plexapp.android/files/media_parts/...etc

I've tried rebooting the phone but did not help... I also updated to the latest build of Plex app (5.4.1.40), same issues...

I'm not too sure which update or action caused this issue as I have not played the video's for a month or so I believe but keen to know how to fix it without having to re-sync?


#2

Anyone know how to manually correct or update the pointer back to the SD card as the movies are still there and I don’t have decent access to my plex server at the moment to reencode and transfer but would like to have access to the movies later tonight if possible?


#3

This is happening to multiple users and has been reported a few times. I believe the team is tracking it.


#4

Thanks for the update, I tried to use one of the work arounds to try and gain access back to your data again but it unfortunately killed all my Plex sync data ;-(

Hope they managed to get this sorted and rather big bummer as I don’t have access to the content at the moment but will need to re-sync and re-encode when I back back home …


#5

Can any plex employee chime in on this? Just lost my 30GB of synced content again…on the first day of my business trip.


#6

Still not fixed in the newest version.


#7

Experiencing the same issue on a Kindle Fire several times including just now. It keeps switching to Internal Storage, even though all the synced data was on an External SD.


#8

Same issue here with Amazon Fire. I’ve never had the issue with my Moto X phone or Samsung Phone. It seems to be device specific.


#9

Same here on fire HD - switched from external to internal. This is the only reason I even have Plex pass. It’s happening so often, I’m getting worried about syncing anything new.


#10

I use this all the time and it is completely unreliable now. Always been a big fan of plex but to have such a basic but critical defect hang around this long is really poor.


#11

Same here. Totally unusable.


#12

I had this issue but when I selected storage back to external the items were still available


#13

My Kindle Fire HD8 did it AGAIN yesterday. Wiped out all my TV shows I was planning on watching on the way home on my 4 hour flight. I was basically forced to buy the $8 video package on the plane because my device was basically a brick.

A Plex Employee chiming in would be great right about now… maybe a fix or ETA on a proper patch to this issue?


#14

I posted 25gb of music to my new samsung galaxy s8 phone and it seemed to be ok. But later in the day all the content seems to be missing. The music is still there because my phone still sees the data being used. But, when I select something to play it tells me there is nothing in the folder. WTF?

By the way, I was using internal storage. I do not have an SD card installed on the phone.


#15

Just bought a Samsung Tab A 7.0 with a 200 GB SD card for our son to have movies/shows on the go. Having the same issue. I can select the external card and sync the library to it. However, the “sync to sd card” selection does not survive a device reboot, it ends of reverting to internal storage. I followed the advice of moving the Plex app to the SD card, and that seems to be working out.

As a point of comparison, Amazon Prime Video and Vudu are both working on the same device, with the app installed on internal storage and content on the external SD card.


#16

Im getting the same message on my Nvidia Shield… it worked fine for weeks, then without making any changes to anything (accept adding to my library and updating library) every video gets the message, "The file associated with this item is not accessible by the server…). BUT WHY? path is the same, connection is fine, all is up to date and been rebooted…

Plex definitely wont get my subscription money at this point…


#17

Same issue… makes plex sync worthless.


#18

Still no updates from anyone :frowning:


#19

I have had this problem for a long time on all of my Amazon fire tablets. Very frustrating, and really the only reason I pay for Plex Pass. If this doesn’t get fixed I’ll have to consider renewing it. Can someone PLEASE get this fixed. Thanks!


#20

I’m getting this on my Kindle fire tablets, driving me nuts! Every time the device is restarted, Plex decides to change the sync location to internal storage. I’ve found that switching it back to external, then clicking ‘back’ a couple of times can sometimes salvage the files. Seems like it should be a fairly simple fix!