Metadata isn't downloading (Server 503s)

server-windows

#1

I'm having issues pulling metadata from TheTVDB. There are a few shows that won't update but the primary offender is listed below.

2018-05-29 02:07:38,821 (3f4) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/login'
2018-05-29 02:07:39,931 (3f4) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/series/94571?lang=en'
2018-05-29 02:07:40,398 (3f4) : ERROR (networking:219) - Error opening URL 'https://tvdb2.plex.tv/series/94571?lang=en'
2018-05-29 02:07:40,400 (3f4) : INFO (logkit:16) - HTTPError 503:
2018-05-29 02:07:40,400 (3f4) : INFO (logkit:16) - Bad series data, no update for TVDB id: 94571 (lang: en)
2018-05-29 02:07:40,486 (3f4) : DEBUG (networking:161) - Fetching 'http://127.0.0.1:32400/services/tmdb?uri=%2Ffind%2F94571%3Fexternal_source%3Dtvdb_id' from the HTTP cache
2018-05-29 02:07:40,655 (3f4) : DEBUG (networking:161) - Fetching 'http://127.0.0.1:32400/services/tmdb?uri=%2Ftv%2F18347%2Frecommendations' from the HTTP cache
2018-05-29 02:07:40,792 (3f4) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/series/94571/actors'
2018-05-29 02:07:41,279 (3f4) : ERROR (networking:219) - Error opening URL 'https://tvdb2.plex.tv/series/94571/actors'
2018-05-29 02:07:41,279 (3f4) : INFO (logkit:16) - HTTPError 503:
2018-05-29 02:07:41,279 (3f4) : INFO (logkit:16) - Bad actor data, no update for TVDB id: 94571
2018-05-29 02:07:41,282 (3f4) : DEBUG (preferences:258) - Loaded preferences from DefaultPrefs.json
2018-05-29 02:07:41,283 (3f4) : DEBUG (preferences:178) - Loaded the user preferences for com.plexapp.agents.thetvdb
2018-05-29 02:07:41,328 (3f4) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/series/94571/episodes?page=1'
2018-05-29 02:07:41,806 (3f4) : ERROR (networking:219) - Error opening URL 'https://tvdb2.plex.tv/series/94571/episodes?page=1'
2018-05-29 02:07:41,806 (3f4) : INFO (logkit:16) - HTTPError 503:
2018-05-29 02:07:41,811 (3f4) : INFO (logkit:16) - Show ordering is: aired
2018-05-29 02:07:41,812 (3f4) : DEBUG (threadkit:234) - Starting a parallel task set named UpdateEpisodes with 0 tasks
2018-05-29 02:07:41,812 (3f4) : DEBUG (threadkit:244) - Parallel task set UpdateEpisodes ended
2018-05-29 02:07:41,858 (3f4) : DEBUG (networking:166) - Requesting 'https://tvdb2.plex.tv/series/94571/images?lang=en'
2018-05-29 02:07:42,346 (3f4) : ERROR (networking:219) - Error opening URL 'https://tvdb2.plex.tv/series/94571/images?lang=en'
2018-05-29 02:07:42,348 (3f4) : INFO (logkit:16) - HTTPError 503:
2018-05-29 02:07:42,348 (3f4) : INFO (logkit:16) - Bad image type data for TVDB id: 94571
2018-05-29 02:07:42,352 (3f4) : DEBUG (threadkit:234) - Starting a parallel task set named DownloadImages with 0 tasks
2018-05-29 02:07:42,355 (3f4) : DEBUG (threadkit:244) - Parallel task set DownloadImages ended
2018-05-29 02:07:44,558 (3f4) : DEBUG (model:229) - Serializing to C:\Users\Administrator\AppData\Local\Plex Media Server\Metadata\TV Shows\d\f88f786d17bcc260e8f40d950bfb0cd88e35c5a.bundle\Contents\com.plexapp.agents.thetvdb\Info.xml
2018-05-29 02:07:44,568 (3f4) : DEBUG (runtime:88) - Sending packed state data (107 bytes)
2018-05-29 02:07:44,569 (3f4) : DEBUG (runtime:924) - Response: [200] str, 16 bytes

The 503s lead me to believe that it's a them issue and not a Plex issue, but I figured I'd throw this out there to see if anyone else is having the same issue or has a fix.

Issue has persisted across server restarts.


#2

Yes, there are other users reporting similar issues. A quick check reveals that this is at the side of TheTVDB.
Plex is only putting a Cloudflare cache inbetween TheTVDB website and the plex server. But here the source is failing, so there is nothing that Cloudflare can buffer.


#3

I'm having this issue - it's been flaky for quite a while now. My naming convention has worked for over 200 episodes of the same show - now you can Plex Dance etc etc and it won't even pickup a match for one episode. For a few weeks now I will get metadata matches coming in randomly several minutes after a library scan - no rhyme or reason to this as far as I can see. Anyway, my logs show the same 503 error.


#4

Also seeing the same issue on my Plex setup. It's a shame since I just did a fresh installation and spent hours having my server re-load all of the metadata just for my shows to not properly match back up. :p


#5

Having the same issue. 503 errors when trying to access in my browser:

https://tvdb2.plex.tv/ => "503 Service Unavailable
No server is available to handle this request.
https://api.thetvdb.com/ => 503 Service Unavailable
No server is available to handle this request.

Unable to fetch metadata on new episodes added into established libraries.

Looking forward to a fix. Perhaps there could be a way to rely on TMDb prioritized over the TVDB? Really not digging the site redesign over at the TVDB, and it seems as if these issues have surfaced after their total overhaul of their site.


#6

I'm seriously hoping that this gets fixed too. I just set up a new home server and having dozens of TV series not have metadata, with a couple of the ones that did receive it having the wrong metadata attached due to incorrect matches that I can't fix now, is incredibly obnoxious.


#7

You can always switch your library agent to The Movie Database setting.


#8

The problem with switching to The Movie Database for TV shows, is the episode numbers do not always match-up, and The Movie Database does not contain specials. So there will be a lot of missing data, and some mis-mapped data.

The sad part is plex seems to have forgotten information it had previously looked up. For example all my Doctor Who (2005) episodes no longer have names. Even though they previously had names, and of course I have the episode name as part of the filename too...


#9

Well then wait for TheTVDB to sort out there API issues that are causing the problems for Plex pulling metadata. At least that is what I understand is the issue from some other forum threads where another user posted that another product they used for pulling metadata was also having issues. A quick search of the Movie Database shows it does have Doctor Who (2005) and it does have a Specials season like TheTVDB and the episode names seem to match for the first few episodes at least.

I personally have not found a single difference in what The Movie Database offers from what TheTVDB does, at least as far as missing TV Shows. So I made the switch. I also prefer that The Movie Database actually lists some series that are remakes as a separate series. For example, Will & Grace that was originally aired in 1998 with a remake in 2017 is shown as two separate series. The Admin at TheTVDB refuse to show the series as 2 separate series despite the fact the broadcast company specifically has the two shows as 2 separate series. I personally don’t record Will & Grace but I also don’t want some third party making a decision the exact opposite of the company that is actually producing the show.


#10

Typically I see the mismatches between the TheTVDB, and TheMovieDatabase for older TV Shows, like some of the seasons of Family Ties.

All the episode names are back again... Hmmm...


#11

Just wanted to +1.

Using Windows 10, started not getting images/posters from TVDB a few days ago. I thought it was on my side at first, or obscure shows, but even with popular stuff it only gets the episode info and series synopsis. I don't see any HTTPErrors in the log, but I do see things like Plug-in limit of 10 exceeded.

Updated my server, did the Plex Dance, refreshed metadata at different times of the day, but no luck, so I came here and I see that other users have had similar issues, and it seems they do.

If a dev wants logs, let me know, I'm happy to provide them.


#12

@johnm_ColaSC said:
The Admin at TheTVDB refuse to show the series as 2 separate series despite the fact the broadcast company specifically has the two shows as 2 separate series. I personally don't record Will & Grace but I also don't want some third party making a decision the exact opposite of the company that is actually producing the show.

I know exactly what you mean. I had it out with TVDB over the fact that despite the DragonBall series having no 'seasons", they insist on given them they own numbering convention rather than what the actual makers use.
So once I get to episode 15, I could no longer get any correct meta data because they call it season 2 episode 1.
Utter bull crap that they tell you that if you can prove legitimately that is how the episodes are numbered then they will number them as such. Apparently a numbering list from the production company themselves was not good enough. Complete joke!!!


#13

BTW. It looks like TheTVDB believes they have this problem resolved:

https://gitlab.thetvdb.com/site/thetvdb_api/issues/35

So either we are seeing or different problem, or they probably need an updated information for the bug report...

I only assumed this was the reason we weren't seeing posters for seasons anymore, because of this bug. But it could be a completely separate issue. Today the posters are back. It seems that was resolved along with the episode names...

The things I did that might have had an effect, is I made sure the ordering was set to DVD Ordering, instead of library fault. I had switch to TheMovieDatabase and done a full metadata refresh, and then switched back to TheTVDB and did the metadata refresh again.


#14

I'm having a similar issue - search takes a while, finally finds the show metadata, but no posters. I've gone round and round with many different fixes, with no luck. Link above doesn't seem to work for me; tried to register and it failed... what did they say?

EDIT: Since I run plex on a NAS (Readynas 102), I could not update easily to latest version. Instead I grabbed the DEB file and extracted thetvdb bundle file to replace the one on the NAS. Seems to be working now.