Movie file will not show in Plex Server

server-mac

#1

I recently loaded a movie file (The Hill) to my Plex Server and it will not show up in the library. I can see it in the file directory using Finder. I am attaching the finder info for the file.
I have tried to remove it and reload it with the same result.

I am running web version 3.47.1 and Server version 1.13.2.5142.
The movie will not show up the the Media Player either. But when I try to play it using VLC it plays perfectly, so obviously the file exists and is not corrupted.
Any ideas? Any help is appreciated.


#2

https://support.plex.tv/articles/200381023-naming-movie-files/


#3

I have more than a 1,000 movies in my library and this is the only one I have ever had a problem with. I am following the recommended file setups as you can see from the attachment.
So that’s the reason I’m confused.


#4

Try The Hill (1965), as required.


#5

I did this but still the same result. See attached. Screenshot of Library (area of H for Hill. and of T for The Hill) and files where the file resides.



Again Thanks for your help.
bsk


#6

2 things to check…

  1. filter by duplicates or look for items with a blue square with a number in the top-left corner of the poster indicating there’s multiple versions of that movie – if Plex interpreted the name to be something else it could show but get mismatched/merged with an existing (different) movie
  2. sort by date added to see if it is mismatched among the last added movies (showing under a wrong name).

#7

∆∆∆ this.

To resolve such a mismatch, you’ll need to perform the Plex Dance:


#8

I tried both suggestions (from tom80H) - there were no duplicates and no mismatch.
And also OttoKerner’s suggestion by doing the Plex Dance.
Still the same result.


#9

@bkjeell said:
I tried both suggestions (from tom80H) - there were no duplicates and no mismatch.
And also OttoKerner’s suggestion by doing the Plex Dance.
Still the same result.

I had this issue a while ago and resolved it by using a folder Naming the same as movie file minus ext then using the Plex Dance.

Move the files out of view from Plex
Update the library
Empty trash or Clean Bundles?
Clean bundles or Empty Trash?
Move the correctly named files back
Update the library

#10

I did all of the suggested options but without result.
Now the mystery continues…
I did load another movie today with the same result. So what I did try was to create a new library with a different name and moved both movies to it and suddenly they appeared there.
So the question is, is there a maximum number of files (movies) you can have in a library? If not, I am totally confused why they did not show up in the original (first Movie library)?


#11

@bkjeell said:
I did all of the suggested options but without result.
Now the mystery continues…
I did load another movie today with the same result. So what I did try was to create a new library with a different name and moved both movies to it and suddenly they appeared there.
So the question is, is there a maximum number of files (movies) you can have in a library? If not, I am totally confused why they did not show up in the original (first Movie library)?

I believe there is no maximum, it looks like there was a issue with link to the storage folder. Have you tried a Optimise Database or re-link your files to that library.

Optimize database is found in the hidden Ellipsis above your Libraries.


#12

check your database for damage:

  1. activate debug logging (not ‘verbose’!)
  2. quit Plex Server
  3. wait 1 minute
  4. start Plex Server
  5. wait 5 minutes
  6. fetch log files and attach them here

Or inspect them yourself. Take a look at the Plex Media Server.log file and seek for messages about database corrupt or malformed.
If you find these, you may have to repair your database.
https://support.plex.tv/hc/en-us/articles/201100678-Repair-a-Corrupt-Database


#13

tried to do this, but the log file will not load . I’m getting a message to that extent.
perhaps I should just go on with 2 movie libraries for time being and then uninstall Plex and start from scratch again at a later time?


#14

@bkjeell said:
tried to do this, but the log file will not load . I’m getting a message to that extent.

Can you elaborate on this a bit?
How are you trying to fetch the logs? There are 2 methods you can use.
https://support.plex.tv/articles/200250417-plex-media-server-log-files/


#15

I tried both ways. Dragging and by selecting it. The load bar progressed to the end and then the message “the file failed to upload” popped up. Tried to move it directly from the Download folder and from the screen after I copied it there.


#16

So you already have the log files but you cannot attach the zip archive here in the forum?
Take a look at the size.
If it is over 20MB, unzip it and pick out only the file Plex Media Server.log
Then attach only this file.


#17

The file (Plex Media Server.log) is 285KB and will not load.


#18

Then open it yourself with a text editor and search for the terms corrupt and malformed.


#19

Sorry Guys, Now I’m starting to freak out :frowning:
Did the search for Corrupt and malformed) and nothing showed up.

But the new, worse, problem: Now I can’t play anything on any of my Macs. I get the below messages.
I know that the drive is attached to the dedicated macMini server and I can access them all using VLC, so the files (movies) are not corrupted.
My problem is that Im leaving for Europe for 3 months the after tomorrow and I want to be able to access PLEX from there remotely!
Can anyone help me, Please?


#20

Also the message. The network iOS fine both the LAN and WAN is OK