Movie posters won't load when running Plex server on Nighthawk X10 router



Hi guys,

No movie posters will load when running Plex server on the Nighthawk, yet other metadata will.

I have recently setup the Plex Media Server on my Netgear Nighthawk X10 router. Plex is running on a USB drive plugged into one of the ports on the router as described in the Netgear instructions. The router has the latest firmware: V1.0.3.6 and the Plex server says it is up to date: Dec 13, 2017. I have a 100mb/40mb fibre connection so it shouldn’t be an issue with speed.

I have a very old Drobo NAS on my network (no security credentials required) and it is a network share which works fine. This is connected in the router firmware successfully and then pointed to for movies in Plex. Over 1000 video files are on the NAS and they play correctly to any device on my network such as: Sony and Samsung smart TVs, MacBooks and iOS devices.

The metadata for the movies seems to load up correctly and I get IMDB ratings, descriptions and even photos of the cast loading. Unfortunately, the movie posters do not load, so are just a blank box. I have tried several different things found on the Plex forums (nothing worked), but most don’t specifically relate to Plex running on a Nighthawk (Netgear forums and support are useless); it seams it could be a problem with Symlinks?

Other random video files on there sometimes get a thumbnail generated out of the video itself, yet no real movies will pull posters via the agent setups. I have turned on all agents but this didn’t make any difference, nor did refreshing the metadata for the whole library or individually on a movie itself.

Some posts talk about turning off Firewall etc, yet as Plex is configured directly on the router I don’t think there is anything I am aware of which could be blocking the connections. Possibly a port which needs to be forwarded manually?

Any advice would be appreciated!




bump, anyone have any ideas?


Is your USB formatted FAT32, may want to format using ntfs. Atleast I’m about to try this.


@brownsugar70 said:
Is your USB formatted FAT32, may want to format using ntfs. Atleast I’m about to try this.

Thanks so much, that fixed it for me!! Much appreciated!


Well embarassingly enough, I’m still stuck. I did format my flash drive to NTFS, but it just wouldn’t recognize it. Went back to FAT32 and still have the poster issue.


I’m having the exact same issue. When I edit an item, the poster and background options shows all the posters available to download but when I select one, nothing happens.
Then I tried uploading the poster or background from an URL and it did worked. It is not a full solution, but I least I get the poster on the new movies I add.
Already tried the “plex dance”, restarting the plex media server, factory reseting the router, nothing happens.
Everything worked perfectly for months, I don’t know if it’s a router firmware issue or a plex one.

R9000 firmware: V1.0.3.10
Plex Version: Feb 16, 2018
HDD using NTFS filesystem