Movies Stuttering on Roku 3



I've found a number of movies that previously played perfectly and now have VIDEO stuttering - like a couple frames are dropped in between each frame it plays. Audio is just fine. RE-analyze doesn't resolve it. Removing the movie and re-adding it doesn't either. Not sure when this cropped up. But I'm attempting to watch movies that previously played fine and now stutter.

No problem via the web interface, iPads or Android devices.

What logs/information/Roku 3 app version information can I provide to get assistance? Thanks!


I noticed this too recently. If you switch it from Automatic or mkv to hls then it seems fine. I think either roku app update did it/roku firmware/or plex server version.


Hackztor - Thanks for your reply. I’m not sure what you mean and which setting I need to change - and whether that’s on the Roku configuration or the Plex Server. Can you share additional detail? I’m not finding such a setting on either the Roku app or the PMS.


Its on the roku plex app in the settings. Video>Transcode Format, change from automatic to hls.


Thanks for the assist, hackztor. I tried that. But no dice. It was already set to HLS.

Tried all 3 settings, Automatic (Recommended), MKV, and HLS - and no change in behavior. Now I’ll sit and wait to see if anyone from Plex can chime in. Really bummed video keeps regressing every few builds - especially when there are now such extensive delays between releases.


Looks like I need to find another player. No help from Plex team?


Starting about two weeks ago, I am having the same issue with my roku 3. It seems to occur with .mkv files and not mp4. The problem does not occur on my Roku Ultra.


update: Set the transcoding to HLS, and it corrected the problem.


Nope. The HLS setting doesn’t fix this. No any of the settings here.

Thanks for the tip, but this doesn’t fix it. Maybe the Plex Employee might eventually respond on the thread and/or resolve this clear regression from earlier builds.


Nope. The HLS setting doesn’t fix this. Not any of the settings here change or improve the issue.

Thanks for the tip, but this doesn’t fix it. Maybe the Plex Employee might eventually respond on the thread and/or resolve this clear regression from earlier builds.


@dugn can you provide a sample of source of the media that is skipping. We are not able to reproduce this issue, but we are happy to investigate if we are able to reproduce it. Feel free to PM me a link to the source or sample.


This is a long-shot…but I was also having similar issues with these types of files on my 4k Vizio. Eventually, I found that the TVs onboard processing was creating the strange behavior. After I set the TV to game-mode (which deactivates most video processing), the issue disappeared. Try setting your TV to game-mode or its equivalent and see what happens.


Thanks @ljunkie - I’m uploading the file and will PM you a link once it’s uploaded.

Thanks @DFury . No joy on that nice tip. My TV is old school, nothing-special Plasma with no such TV-based processing features. But good idea.

REMINDER: This only happens on some movies (usually MKV), it’s a regression from previous builds where this was not a problem. And the issue only exhibits itself on the Roku playback device - not on iPad, android tablets, web interface or PC.


Along the same lines as this thread I have noticed that playing movies on the roku 3 MKV files with H264 video files and DTS 5.1 tracks direct stream the audio but transcode H264 to H264 which eventually makes things stutter. Why is H264 being transcoded at all? The roku 3 plays H264 natively. If I convert the container to M4V they play direct stream. Seems like a plex issue to me.


Agreed. This is a regression from earlier versions. Not sure what’s changed but this wasn’t previously broken.


Any update on this thread, @ljunkie ?


@dugn identified the issue. The AC3 audio stream is using Header stripping (compression) which is not compatible on the Roku. The PMS does not provide this detail, so there is no way to key off of that to force a transcode and convert the audio. The current workaround is to disable direct play when you encounter the stutter, or use mkvmerge to remove the header compression.


Its the Plex App for Roku. Forget all the rest of the thread comments, they are all bandaids possible fixes. My testing using the Roku media player work perfectly with the same backend plex 1.4.3 server running on a NAS.



They just updated the plex server to support header compression (which I believe the roku developer said was the issue).


I just logged in because I have been seeing this same issue for a couple of months, and wanted to see if it had been reported yet. said:
They just updated the plex server to support header compression (which I believe the roku developer said was the issue).

“Just updated” as in which version? Has this been released yet? I have the latest Plex Pass version ( and I am still seeing the problem. I tried changing the transcode setting to HLS, as recommended, and it didn’t make any difference for me. I can confirm that disabling Direct Play is a viable workaround.

I can also confirm that removing header compression fixes the problem. It seems as though releases of mkvmerge between 4.1.0 and 6.0.0 had header compression enabled by default, but that it has been disabled by default in more recent versions. This would explain why only a smattering of files in my library exhibit the problem. Since it’s disabled by default in recent releases, removing compression is as easy as:

mkvmerge input.mkv -o output.mkv

This command takes just seconds on a full size movie on my system, and even if / when this is fixed, it’s probably a good thing to remove header compression since it can cause playback problems on other devices as well.

  • danBhentschel