# Multiple repeated errors in the console

**URL:** <https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190>\
**Category:** Plex Media Server\
**Tags:** server-linux\
**Created:** [January 6, 2026, 1:28am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190 "2026-01-06T01:28:21Z")\
**Posts on this page:** 17\
**Page:** 1

<div class="post-metadata">

**Author:** ![MattDale](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@MattDale](https://forums.plex.tv/u/MattDale)\
**Post date:** [January 6, 2026, 1:28am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/1 "2026-01-06T01:28:21Z")

</div>

Server Version#: 1.42.2.10156  
Player Version#: N/A

I’m not sure how long these have been occurring as I don’t monitor the logs but when trying to uncover some downloading issues I have come across some troubling errors and while I’ve found threads with the same log entries, none of the solutions work for me.

> ERROR - [Notify] Failed to add watch for “/mnt/media/video/films” (28: No space left on device)

A line like this for every media directory when there is plenty of space on all devices. They’re on a NAS.

Host is Ubuntu 24.05. Not using docker. Total number of directories are less than 4000 so definitely not an inotify problem.

> ERROR - [Req#7d4a] Unknown metadata type: folder

Loads of these. I think maybe benign but it shouldn’t be spamming the logs

> [Req#7ce6/Transcode/f905e98d-e9e4-4c89-91a7-e2cc89782500/4e56b718-84ca-4a16-82dc-f08cdcfe5bb7] [eac3\_eae @ 0x7ac223e5b4c0] EAE timeout! EAE not running, or wrong folder? Could not read ‘/tmp/pms-43a06417-9cc9-4612-b108-140e90bf44ce/EasyAudioEncoder/Convert to WAV (to 8ch or less)/f905e98d-e9e4-4c89-91a7-e2cc89782500\_2726350-0-145.wav’  
> ERROR - [Req#7df0/Transcode/f905e98d-e9e4-4c89-91a7-e2cc89782500/4e56b718-84ca-4a16-82dc-f08cdcfe5bb7] [eac3\_eae @ 0x7ac223e5b4c0] error reading output: -5 (I/O error)  
> ERROR - [Req#7df1/Transcode/f905e98d-e9e4-4c89-91a7-e2cc89782500/4e56b718-84ca-4a16-82dc-f08cdcfe5bb7] Error while decoding stream #0:1: I/O error

Again being spammed by this. No transcoding is happening. I’ve run the DBRepair.sh and have deleted the EAE codec but neither made a difference.

I’m at a bit of a loose end to where to go. While I haven’t noticed any specific issues it can’t be good to have your log files spammed.

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [January 6, 2026, 1:43am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/2 "2026-01-06T01:43:04Z")

</div>

See if this applies ?

> [@Linux Tips](https://forums.plex.tv/t/linux-tips/276247/9):
>
> Increase the number of directories Linux can monitor (inotify) for PMS The default size of the Linux inotify table is 8192 directories (\*1). When PMS is configured to update automatically when media is added, with properly organized media, especially music, this table rapidly fills and exceeds the default allocation requiring you to increase it. The solution to this is straight forward. Increasing the table size is easy. The first step is to determine how many directories to allocat…

I will also ask if the transcoder temp directory is on a network share ?

---

<div class="post-metadata">

**Author:** ![MattDale](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@MattDale](https://forums.plex.tv/u/MattDale)\
**Post date:** [January 6, 2026, 1:46am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/3 "2026-01-06T01:46:37Z")

</div>

It does not apply. I have less than 4000 directories to monitor and with the latest kernel on ubuntu it has 64K default.

The transcoder temp directory is /dev/shm so not on a share

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [January 6, 2026, 1:48am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/4 "2026-01-06T01:48:28Z")

</div>

> [@MattDale](#):
>
> I have less than 4000 directories to monitor

But what is the complete size on the drive? That table is no just for plex media.

---

<div class="post-metadata">

**Author:** ![MattDale](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@MattDale](https://forums.plex.tv/u/MattDale)\
**Post date:** [January 6, 2026, 1:56am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/5 "2026-01-06T01:56:09Z")

</div>

On that share it is only media. On the whole system the count of directories is 272841 however I don’t expect they all need monitored. Is there a command to check this?

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [January 6, 2026, 2:01am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/6 "2026-01-06T02:01:48Z")

</div>

> [@MattDale](#):
>
> I don’t expect they all need monitored.

the inotify table is a OS feature, not something in plex. Its an OS feature that provides notifications to apps that are watching specific directories. However the table is part of the OS kernel.

See [Synology FAQ - Questions, Answers, and How-To's - #22 by ChuckPa](https://forums.plex.tv/t/synology-faq-questions-answers-and-how-tos/490215/22)

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [January 6, 2026, 2:03am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/7 "2026-01-06T02:03:05Z")

</div>

Server DEBUG logs please which capture this happening?

Best logs are those which capture server startup and an attempted transcode which fails.

---

<div class="post-metadata">

**Author:** ![MattDale](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@MattDale](https://forums.plex.tv/u/MattDale)\
**Post date:** [January 6, 2026, 2:13am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/8 "2026-01-06T02:13:37Z")

</div>

[Plex Media Server.log](https://forums.plex.tv/uploads/short-url/rPHKZBhKL23aHlTmqHbxsgXH3tN.log) (1.6 MB)

This is my latest log with all the mentioned errors

---

<div class="post-metadata">

**Author:** ![MattDale](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@MattDale](https://forums.plex.tv/u/MattDale)\
**Post date:** [January 6, 2026, 2:19am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/9 "2026-01-06T02:19:16Z")

</div>

Would the inotify table need to be increased on the NAS or it only the host OS that matters for this?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [January 6, 2026, 3:06am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/10 "2026-01-06T03:06:04Z")

</div>

Thanks.

This confirms the table is full

```auto
Jan 06, 2026 00:56:19.226 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films" (28: No space left on device)
Jan 06, 2026 00:56:19.230 [127145376467768] WARN - JobManager: Could not find job for handle 2720335
Jan 06, 2026 00:56:20.054 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/1917 (2019)" (28: No space left on device)
Jan 06, 2026 00:56:20.081 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/A Scanner Darkly (2006)" (28: No space left on device)
Jan 06, 2026 00:56:20.082 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/Airplane! (1980)" (28: No space left on device)
Jan 06, 2026 00:56:20.083 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/Alita - Battle Angel (2019)" (28: No space left on device)
Jan 06, 2026 00:56:20.089 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/Almost Human (2019)" (28: No space left on device)
Jan 06, 2026 00:56:20.104 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/Almost Human (2019)/Subs" (28: No space left on device)
Jan 06, 2026 00:56:20.105 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/An Inspector Calls (2015)" (28: No space left on device)
Jan 06, 2026 00:56:20.106 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/Animal Farm (1999)" (28: No space left on device)
Jan 06, 2026 00:56:20.107 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/Apex (2021)" (28: No space left on device)
Jan 06, 2026 00:56:20.108 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/Automata (2014)" (28: No space left on device)
Jan 06, 2026 00:56:20.109 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/BIOS (2021)" (28: No space left on device)
Jan 06, 2026 00:56:20.110 [127145329314616] ERROR - [Notify] Failed to add watch for "/mnt/media/video/films/Battlefield 2025 (2020)" (28: No space left on device)

```

You say 4000 directories, and Ubuntu has a 64K default.

The errors indicate one of those values is incorrect.

Confirm the inotify table size please

```auto
sudo sysctl -a | grep max_user_watches

```

Might you have an error in the list of directories you’ve added to your libraries ?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [January 6, 2026, 4:54am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/11 "2026-01-06T04:54:46Z")

</div>

> [@MattDale](#):
>
> Would the inotify table need to be increased on the NAS or it only the host OS that matters for this?

The inotify table is populated on the host which runs PMS.

PMS uses the kernel’s filesystem notification mechanism to detect changes  
This is how “Automatically Update my library when changes are detected” works.

For details on inotify, type: `man inotify`  
The built in electronic help pages will tell you all about it.

---

<div class="post-metadata">

**Author:** ![MattDale](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@MattDale](https://forums.plex.tv/u/MattDale)\
**Post date:** [January 6, 2026, 10:50am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/12 "2026-01-06T10:50:46Z")

</div>

> fs.epoll.max\_user\_watches = 7237431  
> fs.inotify.max\_user\_watches = 65536

I ran

> find /mnt/media/ -type d | wc -l

Which results in 3851

---

<div class="post-metadata">

**Author:** ![MattDale](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@MattDale](https://forums.plex.tv/u/MattDale)\
**Post date:** [January 6, 2026, 11:42am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/13 "2026-01-06T11:42:16Z")

</div>

It looks like this was in fact the solution. I increased that setting to 128K and then restarted PMS and it appears to have stopped that error. There are others now but the server is now functional.

This error still remains

> Unknown metadata type: folder

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [January 6, 2026, 12:04pm UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/14 "2026-01-06T12:04:13Z")

</div>

> [@MattDale](#):
>
> Unknown metadata type: folder

you can safely ignore that, its a bit of debug info that the devs have left in the logs, doesnt really mean there is an error.

---

<div class="post-metadata">

**Author:** ![MattDale](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@MattDale](https://forums.plex.tv/u/MattDale)\
**Post date:** [January 6, 2026, 12:59pm UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/15 "2026-01-06T12:59:09Z")

</div>

For anyone else coming to this, I found the following very useful

> **[GitHub - mikesart/inotify-info: Linux inotify info reporting app](https://github.com/mikesart/inotify-info)**
>
> Linux inotify info reporting app

It revealed that the maximum watches had in fact been breached and the culprit in this case was Jellyfin rather than Plex although of course it could affect any other processes too

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [January 7, 2026, 3:30am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/16 "2026-01-07T03:30:07Z")

</div>

To add,

This will happen when multiple apps (servers) set inotify watches.  
The table is in the kernel.  
Apps do mot share slots. Each app has their own entry.

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [April 7, 2026, 3:30am UTC](https://forums.plex.tv/t/multiple-repeated-errors-in-the-console/935190/17 "2026-04-07T03:30:13Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
