Music Stuttering/Stalling Playback at Start of Track

android-mobile

#1

Plex for Android ~~v.5.6.1.505~~ v.5.7.2.302; Motorola Droid Turbo (XT1254), Android v.6.0.1; System v24.81.5.quark_verizon; Build MCG24.251-5

When I play music or audiobooks, the sound often skips, stutters or stalls entirely at the beginning of a track. It happens both when I'm selecting a new track as well as when it automatically plays the next track in the queue. It's been happening for a long time now---in fact, for as long as as I've been using Plex for Android.

Is there going to be a fix for this? Please tell me I'm not the only one experiencing this issue.


#2

Okay, so...
It happens when I'm on wifi; when I'm on data; and both when I have or have not synced a local copy to my phone.
I still need to confirm whether playing said files directly from the local library (rather than through the server library) also stutters or stalls.

But this issue happens a lot. A WHOLE lot.


#3

It happens to me from time to time. I restart Plex and it usually fixes it. If not, I reboot the NAS.


#4

I rebooted my server and nope, still happens. A lot.


#5

@chyron8472 said:
I still need to confirm whether playing said files directly from the local library (rather than through the server library) also stutters or stalls.

Doesn't seem to happen (or doesn't happen nearly as much) when using device's locally synced library. Does still happen if using server library regardless of if synced locally (and yes, "prefer local content" is checked in settings.)


#6

I am currently testing this. Started listening to Ender's Game audiobook but am not trying to fix it when it skips. It's been skipping and jerking for many minutes straight now, all the way through the prologue and into other chapters. As I look down at my phone, it says it's in Chapter 4, but not enough time has passed to have listened to the whole of chapters 1, 2 or 3.

...Okay, I let it go into Chapter 5, and after a while I pressed "Rewind 10 seconds" and it fixed. Pressing Prev Track or Rewind a few times sometimes fixes the problem.

See attached: Android Plex app log; Plex Media Server system log during time of test.


#7

Just saw your post. Do you have any other Android devices that you can test? Just want to check if this might be specific to your Droid. I'm not able to reproduce any audio glitches on my devices. I'll provide an update after I check over your logs.

BTW - Nice choice of book. One of my favorites.


#8

Hmm.... I still have my old Droid Razr M. I will try it on that and get back to you.


#9

Droid Razr M (XT907); Android v.4.4.4; Plex for Android 5.7.2.302

No problems at all. I tried several different books; I tried accessing a track through different methods; I used my then current version of Plex for Android; I updated the app to 5.7.2.302; I tried to get it to skip, but nope. The Razr M works fine.

But then... the Razr M is running Pac Man Rom based on 4.4.4 KitKat , not VZW stock 6.0.1 Marshmallow like my Droid Turbo is. My wife's Droid Turbo is still running Lollipop, and I've had issues on hers as well. My mother-in-law has a Moto Z Play with Marshmallow. Maybe I''ll try testing it on hers when I see her next.

Droid Turbo is system v24.81.5.quark_verizon; build number MCG24.251-5, by the way.


#10

Tested on my mother in law's Moto Z Play running Android 7.0 Nougat. No problems.


#11

Things are pointing to your Turbo. I looked over your logs and I don't see anything there to indicate a problem. It could be a slow caching issue. Can you try syncing a track to your Turbo and see if you get the stutter from that? Since it would be local, it would bypass any caching issues.


#12

If I sync to my Turbo, the problem goes away. how do I fix the caching problem?

EDIT: I uninstalled/reinstalled the app. Now the problem doesn't seem to be happening as often (ie. not all the time when starting to play a non-synced music/book track as it did previously) but it still happens.

How do I fix it?


#13

I don't know what the fix would be. The caching mechanism is automatic. I'll ask around but not sure if this can be fixed.


#14

I find this stuttering occurs at the start of every music track when using the wired network to my windows PC.
The same network includes Amazon Fire TV box (also wired) which does not stutter on the same tracks.
Music is all flac encoded.
Music is on an an expansion box to a QNAP i3 server.


#15

Exactly the same as user above. From wired network desktop using external USB drive as source. VERY annoying


#16

How the hell is “I don’t know” the accepted answer for this?

I find it difficult to believe that this is a caching issue, because even if a sync were performed and the file is actually on the device, the cache IS still used to hold all, or parts of, the file during playback.

Consider the following events in my logs

Apr 16, 2018 09:17:49.946 [12028] DEBUG - Completed: [A.B.C.D:port] 200 GET <<== denotes the approximate end of playback for the prev-track

Apr 16, 2018 09:17:56.759 [12032] DEBUG - Failed to stream media, client probably disconnected after 131072 bytes: 10054 - An existing connection was forcibly closed by the remote host <<=== notice the ~7 seconds of time that has passed before an error is reported saying that an EXISTING client connection that was expected to be there, is now gone. This implies that the client side of the connection was closed prematurely and it took a few seconds for everyone to figure out what was going on.

Apr 16, 2018 09:17:59.962 [24472] DEBUG - Client [2c6dbd1170e3a052-com-plexapp-android] reporting timeline state playing <<=== another ~3 seconds later playback finally resumes after another round of authentication and a new connection can be established.

I was not experiencing this issue previously when I had:

  • Win10 PMS install
  • apache2 proxy used to handle domain specific web request forwarding

I am currently experiencing this issue after:

  • upgrading to nginx for proxy forwarding (still have Win10 PMS install)
  • enabling SSL in nginx and via plex

I have a strong suspicion that this issue relates more to SSL connection handling than it does anything else. I will be trying to tweak various nginx settings in the upcoming day or two – if I can identify the issue and resolve it, I will report back here. If any Plex staff wants access to relevant log information let me know.

PS: tweaking nginx settings because no authentication is required between the nginx host and the PMS host via plex settings.