Music Sync, Wrong Length?

ios

#1

When I sync a song to my device running iOS 10.0.2 it says the song is much shorter than the it actually is. The song is 4 minutes long but the app only says 1 minute long. After a minute though, it continues to play the song.

I am syncing FLAC to my iPhone and wondering if there is something wrong I am doing.


#2

I have seen the same thing in the past. With the latest versions, I think sync will convert FLAC to AAC instead of MP3. I deleted all of my content, then re-synced, and it shows the proper time on the IOS app. I have it set to 320kbps.

I have seen this on the Plex/Web interface as well, along with songs that quit playing early and move to the next item. All of my music in Plex is FLAC format, so I just figure something in the conversion is haywire.


#3

I have done that several times now. Still nothing. I guess maybe the conversion is wonky for music now.


#4

Happening to me too, iOS 10.1.1. Syncing FLAC with “highest” audio quality. When viewing / playing synced tracks on the “iPhone” location, almost every synced track displays a smaller length (of time) than they actually are, and will play longer than the length displayed. See pic.


#5

are we posting in correct forum? dont see any response from developers.

same problem here. Syncing to ios10.2 running Plex App 4.6.1 from Plex Server 1.3.3.31.48 running on Windows 10 Home.

Original files are FLAC. Sync quality set to highest. Sync copies of song show wrong track length (much shorter than what should be). Playing sync copy of song, whole song plays. When time reaches "end of song" it just keep playing till real end. Annoying part (beside incorrectly shown time) cannot skip to part of song that beyond incorrect "end of song" time


#6

Tried sync with lowest quality. Same result, indicated sync copy track length is too short (plays ok though ... just cant skip to points beyond wrongly indicated track length). I only tried this with FLAC.

Then tried sync WAV file. Resulted sync copy correctly shows track length. So seems FLAC problem only (used EAC to generate FLAC from my CDs).

Note: syncing WAV files takes much longer than FLAC. Seems like transcoding part takes long (though CPU usage is only 15% ... i7-6700 with 32GB RAM) ... takes several MINUTES to transcode one WAV file :/


#7

Ask this in Windows Server section as it looks like Server side problem. Not iOS app.

https://forums.plex.tv/discussion/251928/sync-flac-to-tablets-gives-incorrect-track-lenth#latest


#8

i posted this in different forum and its been confirmed as bug for PMS
1.3.3.31.48 running on Windows 10

@MovieFan.Plex said:
I'm able to reproduce the issue. I will go ahead and file the bug. Thanks for the report.


#9

I still gpt the problem witb a sych a few days ago. This was after the Android 7.0 upgrade. Was the bug fixed or is thia somwthing new with the Android upgrade?


#10

Same here just had to do a full fresh sync as it was stuck again and on various albums the tracks are all about 1min instead of 3-4mins.

Attached the xml of one of the effected tracks, which shows on my iPad as 00:53 when its really 3:21.

This was synced with PMS (Windows) Version 1.5.5.3634 to an iPad running 4.11


#11

I'm an android user, the problem is still isn't fixed yet, it seems it's a server side problem
running latest version of the server on windows 10
i synced the albums from pc and selected 320kbps, then every FLAC file converted to 320kbps shows wrong duration


#12

Still an issue for me. Wrong times show up in both my Plex Server and my phone. Any ETA on a fix?


#13

+1 -- Still not resolved. Same issue here.


#14

Not fixed. Please fix the issue.


#15

Not fixed. Please fix the issue.


#16

Also experiencing the same problem, please fix.


#17

Still experiencing the problem - either with iOS or Android app PMS version 1.10.1.4561. Please fix this