My Music/TV Shows/Movies Don't Have Posters

server-mac

#1

Help Us Help You
I'd like to use this topic to gather valuable information from you to help us improve the scanners so as to get your media into the library. This topic is NOT for you if you have your media in the library, but aren't getting any metadata (e.g. posters, art) for it.



Background information:



Plex Media Scanner log: ~/Library/Logs/Plex Media Scanner.log

Plex Media Server log: ~/Library/Logs/Plex Media Server.log

Location for crash reports: ~/Library/Logs/CrashReporter/

IMDB agent log: ~/Library/Logs/PMS Plugin Logs/com.plexapp.agents.imdb.log

The TVDB agent log: ~/Library/Logs/PMS Plugin Logs/com.plexapp.agents.thetvdb.log

Last.FM agent log: ~/Library/Logs/PMS Plugin Logs/com.plexapp.agents.lastfm.log



If you're getting a grey poster, and Fix Incorrect Match isn't showing any matches, please do the following:



[list=1]

[]Chose "Fix Incorrect Match" and wait until you get the blank results.

[
]Look in the Plex Media Server Log for a line like this:

[/list]



<br />
Issuing search query: http://localhost:32400/system/agents/search?mediaType=8&id=88411&identifier=com.plexapp.agents.lastfm&duration=203000&filename=%252FVolumes%252FDrobo%252FScanner%252FCommitments%252FThe%2520Commitments%252F06%2520I%2520Can't%2520Stand%2520The%2520Rain%252Emp3&lang=en&openSubtitlesHash=6f3d4a79a958925a&plexHash=a83e794088a62d4ced8c3b24d8085bdf16a03aaa&album=The%20Commitments&artist=The%20Commitments&index=6&name=I%20Can't%20Stand%20The%20Rain<br />






Paste this entire line in a reply to this topic, it has EVERYTHING we need to reproduce the problem. This line is really easy to find in the Console app:


http://img.skitch.com/20100906-e82uuwtq57ahj5w32t32gdddq9.jpg





Also, paste in the lines from the relevant log-files as well (for a Fix Match, the Plex Media Server.log lines and the ones from the tv/movie agent).


#2

Great info elan!



I'm going to post some additional logs, there's a bug that the tv scanner seems to be displaying. The media analysis doesn't seem to be completing and some shows need to be prompted to download meta data by initiating a "fix incorrect match" after installing the new bundle.



I'll have logs up in a second.


#3

I was having a problem with the media center not scanning new content (not even gray boxes). Restarting the media center seems to have fixed my problem. Not only the new content was scanned, but metadata appeared in my old content. Maybe this will be helpful for people that have media that shows up, but no poster or metadata.


#4

Elan, I am using the TVDB workaround but still see gray boxes on some shows that do actually show on TVDB directly. I also find that with the workaround I have to manually refresh each show to get it to pull, just an FYI. I will post logs shortly. My Twitter is same handle Wildcat_1


#5

Just to reiterate, we are just looking for the specific lines mentioned in the first post. Also, we only want these for problems of turning a gray port in a poster. Otherwise, let's not clutter up this thread with other issues :)


#6

Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=20&identifier=com.plexapp.agents.thetvdb&duration=2782000&filename=%252FVolumes%252FLacieusb%252FTV%2520Shows%252FIdentity%2520S1%252FIdentity%25201x06%2520Tomorrow%2520Comes%2520Early%252Emkv&lang=en&openSubtitlesHash=b9fdb9cdb4e6cac2&plexHash=c5b03117caca703dc673efc4db5b49e6e4ebcd69&episode=6&season=1&show=Identity

Sep 06, 2010 09:11:07 [0xa0120500] DEBUG - Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=20&identifier=com.plexapp.agents.thetvdb&duration=2782000&filename=%252FVolumes%252FLacieusb%252FTV%2520Shows%252FIdentity%2520S1%252FIdentity%25201x06%2520Tomorrow%2520Comes%2520Early%252Emkv&lang=en&openSubtitlesHash=b9fdb9cdb4e6cac2&plexHash=c5b03117caca703dc673efc4db5b49e6e4ebcd69&episode=6&season=1&show=Identity

Sep 06, 2010 09:12:57 [0xb0dcf000] ERROR - Error issuing curl_easy_perform(handle): 22

Sep 06, 2010 09:12:57 [0xb0dcf000] WARN - Error issuing request to: http://localhost:55512/system/appstore/history/none (22)

Sep 06, 2010 09:13:06 [0xb0dcf000] ERROR - Error issuing curl_easy_perform(handle): 22

Sep 06, 2010 09:13:06 [0xb0dcf000] WARN - Error issuing request to: http://localhost:55512/system/appstore/history/none (22)

Sep 06, 2010 09:13:29 [0xb0dcf000] ERROR - Error issuing curl_easy_perform(handle): 22

Sep 06, 2010 09:13:29 [0xb0dcf000] WARN - Error issuing request to: http://localhost:55512/system/appstore/history/none (22)





Hope this is correct as you need it. I've tried all your suggestions ( a bit nooby in this area) but still all my TV Series remain as grey boxes with a Plex arrow on them. Strangely the first time I installed it all work perfectly but now only Movies have all the Metadata correctly displayed. I had to reinstall it (I used AppZapper to completely remove it) as I tried a different skin and couldn't work out how to get the default one back so did a clean reinstall.


#7

Elan, here is one from me, is this what you were looking for ? Still have a gray box. I assume per the first post this was what you were looking for, if not please let me know.



Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=4453&identifier=com.plexapp.agents.thetvdb&duration=2816000&filename=%252FVolumes%252FMedia%2520Storage%252FTV%2520Library%252FJamies'%2520Kitchen%2520Australia%252FS1E10%252Eavi&lang=en&openSubtitlesHash=0ce8ad2fa883bc14&plexHash=c083045fef3a04a3b728edcfd706364e619d4b1b&episode=10&season=1&show=Jamies'%20Kitchen%20Australia



another:



Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=4267&identifier=com.plexapp.agents.thetvdb&duration=-1&filename=%252FVolumes%252FMedia%2520Storage%252FTV%2520Library%252FJamie%2520Oliver%2520Pukka%2520Tukka%252FVIDEO_TS%252FVTS_01_0%252EIFO&lang=en&openSubtitlesHash=73d416303cd1a878&plexHash=7040594b58cbc303b76d87cee802105531b55e03&episode=1&season=1&show=Jamie%20Oliver%20Pukka%20Tukka








[quote name='elan' date='06 September 2010 - 01:27 AM' timestamp='1283736472' post='102062']


Just to reiterate, we are just looking for the specific lines mentioned in the first post. Also, we only want these for problems of turning a gray port in a poster. Otherwise, let's not clutter up this thread with other issues :)

[/quote]


#8

Just getting the Grey Plex symbol poster for TV Shows. Tried to shift click and force refresh but no luck.. here is the console log you asked for.. hop it helps you.



Sep 06, 2010 11:04:57 [0xa0a82500] DEBUG - Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=1405&identifier=com.plexapp.agents.thetvdb&duration=1328000&filename=%252FVolumes%252Fqmultimedia%252FNAS%2520TV%2520Shows%252F30%2520Rock%252FSeason%25204%252F30%2520Rock%2520S04E22%252Eavi&lang=en&openSubtitlesHash=4ac1f8d60957a35d&plexHash=9d40fb6d583cad7586179b39e19b6e10ceb9ecb7&episode=22&season=4&show=30%20Rock

Sep 06, 2010 11:04:57 [0xb1085000]


#9

Sep 05, 2010 22:20:54 [0xa0048500] DEBUG - Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=243&identifier=com.plexapp.agents.thetvdb〈=en&show=Planet%20Earth





Sep 05, 2010 22:20:47 [0xa0048500] DEBUG - Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=243&identifier=com.plexapp.agents.thetvdb&duration=3068000&filename=%252FVolumes%252FDrobo%252FShared%252FTV%2520Shows%252FPlanet%2520Earth%252FSeason%25201%252FPlanet%2520Earth%2520-%2520S01E11%252Emkv〈=en&openSubtitlesHash=4ade43ec581922fe&plexHash=a4464e79c5a8641f93ef6eb3904d1f317cbc2230&episode=11&season=1&show=Planet%20Earth





Keep up the good work.


#10

Metadata worked fine for Movies, but nothing for TV shows. Forced refreshes do nothing.



Sep 06, 2010 00:37:39 [0xa0679500] DEBUG - Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=615&identifier=com.plexapp.agents.thetvdb&duration=2538000&filename=%252FVolumes%252FArtemis%252FShared%252FTV%2520Shows%252FWhite%2520Collar%252FWhite%252ECollar%252ES02E08%252ECompany%252EMan%252EHDTV%252EXviD-FQM%252Eavi&lang=en&openSubtitlesHash=12f6bf32826a3afb&plexHash=4a6da78fd2ff26950df52a53c97366b6ee364f05&episode=8&season=2&show=White%20Collar


#11

Hey Elan & Crew,



Plex/Nine worked great for me for the first day. Then TheTVDB went down, which is cool because I know you guys are working on it. IMDB has stopped working for me as well though, here's my log:



Sep 06, 2010 02:58:45 [0xa0359500] DEBUG - Issuing search query: http://localhost:32400/system/agents/search?mediaType=1&id=857&identifier=com.plexapp.agents.imdb&duration=6168000&filename=%252FVolumes%252FBruce%252FMovies%252FFootloose%252Eavi&lang=en&openSubtitlesHash=8b0362761647e2a2&plexHash=f00ddb65352af8beeaf4831852c32a4eb13149a7&name=Footloose<br />






Are there others experiencing IMDB issues as well or am I the only one?



Thanks Guys!


#12

<br />
Issuing search query: http://localhost:32400/system/agents/search?mediaType=1&id=4157&identifier=com.plexapp.agents.imdb&duration=4649000&filename=%252FVolumes%252FMedia%252FVideos%252FMovies%252FThe%2520Tracey%2520Fragments%2520(2007)%252Emkv&lang=en&openSubtitlesHash=eb45c6b0e71fe8c7&plexHash=02fe7d089e2268c10cf14446f69af98b626114d0&name=The%20Tracey%20Fragments&year=2007<br />






Edit: I don't know if you changed anything but now I am seeing a poster for this in the media manager.


#13

Sep 06, 2010 09:18:30 [0xa0192500] DEBUG - Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=1303&identifier=com.plexapp.agents.thetvdb&duration=2545000&filename=%252Fmnt%252Fhomenas%252Fmedia%252FVideo%252FOliver%2520TV%252FLilla%2520Spoket%2520Laban%252FLaban%2520S01E01%252Emkv&lang=en&openSubtitlesHash=3e65330580b51b29&plexHash=c2443b8e21c52b6e3912a9b518b86bfcd3c9b4e5&episode=1&season=1&show=Lilla%20Spoket%20Laban





Please see post: http://forums.plexapp.com/index.php?/topic/17043-artwork-missing-from-updated-tvdb-entry/


#14

Fix incorrect match not working in tv series...



here's the log.. keep it up guys, great new version!



Sep 06, 2010 08:03:26 [0xa0315500] DEBUG - [com.plexapp.system] Sending command over HTTP: /system/agents?mediaType=2

Sep 06, 2010 08:03:26 [0xa0315500] DEBUG - [com.plexapp.system] HTTP reply status 200, with 358 bytes of content.

Sep 06, 2010 08:03:26 [0xa0315500] DEBUG - [com.plexapp.system] Completed command /system/agents?mediaType=2 in 0.002031 seconds.

Sep 06, 2010 08:03:28 [0xa0315500] DEBUG - Most recent grandchild was episode 16

Sep 06, 2010 08:03:28 [0xa0315500] DEBUG - Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=1943&identifier=com.plexapp.agents.thetvdb&lang=en&show=Brothers%20and%20Sisters

Sep 06, 2010 08:03:28 [0xb07b9000] DEBUG - Request: GET /system/agents/search?mediaType=2&id=1943&identifier=com.plexapp.agents.thetvdb&lang=en&show=Brothers%20and%20Sisters [::1]

Sep 06, 2010 08:03:28 [0xb07b9000] DEBUG - * mediaType => 2

Sep 06, 2010 08:03:28 [0xb07b9000] DEBUG - * id => 1943

Sep 06, 2010 08:03:28 [0xb07b9000] DEBUG - * identifier => com.plexapp.agents.thetvdb

Sep 06, 2010 08:03:28 [0xb07b9000] DEBUG - * lang => en

Sep 06, 2010 08:03:28 [0xb07b9000] DEBUG - * show => Brothers and Sisters

Sep 06, 2010 08:03:28 [0xb07b9000] DEBUG - [com.plexapp.system] Sending command over HTTP: /system/agents/search?mediaType=2&id=1943&identifier=com.plexapp.agents.thetvdb&lang=en&show=Brothers%20and%20Sisters

Sep 06, 2010 08:03:28 [0xb0ed5000] DEBUG - Request: GET /:/plugins [::ffff:127.0.0.1]

Sep 06, 2010 08:03:28 [0xb0ed5000] DEBUG - It took 0.000108 sec to serialize a list with 18 elements.

Sep 06, 2010 08:03:28 [0xb0ed5000] DEBUG - Request: GET /:/plugins/com.plexapp.agents.thetvdb/messaging/function/X0FnZW50S2l0OlNlYXJjaA_/Y2VyZWFsMQoxCmxpc3QKMApyMAo/Y2VyZWFsMQoyCmRpY3QKZGljdAozCnMyCmVuczQKbGFuZ3M3ClRWX1Nob3dzMTAKbWVkaWFfdHlwZXIxCnM2Cmt3YXJnczIKczQKMTk0M3MyCmlkczIwCkJyb3RoZXJzIGFuZCBTaXN0ZXJzczQKc2hvd3IwCg__ [::ffff:127.0.0.1]

Sep 06, 2010 08:03:28 [0xb0ed5000] DEBUG - Plug-in com.plexapp.agents.thetvdb has been used 1420 times.

Sep 06, 2010 08:03:28 [0xb0ed5000] DEBUG - [com.plexapp.agents.thetvdb] Sending command over HTTP: /:/plugins/com.plexapp.agents.thetvdb/messaging/function/X0FnZW50S2l0OlNlYXJjaA_/Y2VyZWFsMQoxCmxpc3QKMApyMAo/Y2VyZWFsMQoyCmRpY3QKZGljdAozCnMyCmVuczQKbGFuZ3M3ClRWX1Nob3dzMTAKbWVkaWFfdHlwZXIxCnM2Cmt3YXJnczIKczQKMTk0M3MyCmlkczIwCkJyb3RoZXJzIGFuZCBTaXN0ZXJzczQKc2hvd3IwCg_

Sep 06, 2010 08:03:28 [0xb0ed5000] DEBUG - [com.plexapp.agents.thetvdb] HTTP reply status 200, with 320 bytes of content.

Sep 06, 2010 08:03:28 [0xb0ed5000] DEBUG - [com.plexapp.agents.thetvdb] Completed command GET /:/plugins/com.plexapp.agents.thetvdb/messaging/function/X0FnZW50S2l0OlNlYXJjaA
/Y2VyZWFsMQoxCmxpc3QKMApyMAo/Y2VyZWFsMQoyCmRpY3QKZGljdAozCnMyCmVuczQKbGFuZ3M3ClRWX1Nob3dzMTAKbWVkaWFfdHlwZXIxCnM2Cmt3YXJnczIKczQKMTk0M3MyCmlkczIwCkJyb3RoZXJzIGFuZCBTaXN0ZXJzczQKc2hvd3IwCg__ in 0.002160 seconds.

Sep 06, 2010 08:03:28 [0xb07b9000] DEBUG - [com.plexapp.system] HTTP reply status 200, with 130 bytes of content.

Sep 06, 2010 08:03:28 [0xb07b9000] DEBUG - [com.plexapp.system] Completed command GET /system/agents/search?mediaType=2&id=1943&identifier=com.plexapp.agents.thetvdb&lang=en&show=Brothers%20and%20Sisters in 0.007759 seconds.

Sep 06, 2010 08:03:28 [0xa0315500] WARN - No matches for search.


#15

I have some poker TV shows that I watch. First when I got Plex nine, it found all of them (I have 7 different TV shows in my library). For some reason I decided to redo my entire library, and now it only finds two of them. Or actually, 2 of them it finds with poster/fanart and metadata. One it finds with metadata but not any images. The remaining 4 all have grey plex icons, no year, no nothing. This is for one of them:





Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=5&identifier=com.plexapp.agents.thetvdb&duration=2782000&filename=%252FUsers%252Fbootliner%252FDownloads%252FPokerserier%252FNorth%2520American%2520Poker%2520Tour%252FNorth%252EAmerican%252EPoker%252ETour%252Es01e06%252EHR%252EHDTV%252EXviD-AT%252Eavi&lang=en&openSubtitlesHash=26f6f0ddadb50ac7&plexHash=73842bfbd75c8006fe93febc534d3606ef171f6b&episode=6&season=1&show=North%20American%20Poker%20Tour


#16

Sep 06, 2010 11:08:35 [0xa0370500] DEBUG - Issuing search query: http ://localhost:32400/system/agents/search?mediaType=2&id=148&identifier=com.plexapp.agents.thetvdb&lang=en&show=Dexter







Had to put a space btw http so that ie shows the whole thing instead of link


#17

[quote name='elan' date='06 September 2010 - 01:36 AM' timestamp='1283733396' post='102029']


This topic is NOT for you if you have your media in the library, but aren't getting any metadata (e.g. posters, art) for it.

[/quote]




I guess it doesn't matter anymore, but isn't the subject of this thread labelled "My Music/TV Shows/Movies Don't Have Posters"…?! :blink:



Never mind, just sayin‘…


#18

I'm ready for a complete re-install if you think it would help, but here's an "Issuing search query" from mine:



Sep 06, 2010 11:13:56 [0xa0b0c500] DEBUG - Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=542&identifier=com.plexapp.agents.thetvdb&lang=en&show=Chuck



Thanks in advance for any help, and MANY MANY thanks for your hard dedication to this amazing product!!



All the best,

Mark


#19

Getting no metadata or art/poster for The Pacific



DEBUG - Issuing search query: http://localhost:32400/system/agents/search?mediaType=2&id=632&identifier=com.plexapp.agents.thetvdb&lang=en&show=The%20Pacific



Update: works fine after PMS restart and plugins update, great work


#20

Sep 06, 2010 19:04:46 [0xa0370500] DEBUG - Issuing search query: http ://localhost:32400/system/agents/search?mediaType=1&id=269&identifier=com.plexapp.agents.imdb&duration=7283000&filename=%252FVolumes%252FDrobo%252FMovies%252FAmerican%2520Beauty%2520(1999)%252Emkv&lang=en&openSubtitlesHash=2e8cc59ed2e2505b&plexHash=5009950c19610e0ea3efb157fb426b2d513fc50b&name=American%20Beauty&year=1999





Sep 06, 2010 19:09:01 [0xa0370500] DEBUG - Issuing search query: http ://localhost:32400/system/agents/search?mediaType=1&id=270&identifier=com.plexapp.agents.imdb&duration=7133000&filename=%252FVolumes%252FDrobo%252FMovies%252FAmerican%2520History%2520X%2520(1998)%252Emkv&lang=en&openSubtitlesHash=f636b320f7845058&plexHash=925d23b72a42e9829933ed9b6a94a1717b7b143e&name=American%20History%20X&year=1998



Here are two more movies with no poster.



Please let me know if i am posting the wrong thing here.