New Chromecast App

chromecast

#1

Mentioned over in http://forums.plex.tv/discussion/216688/plex-for-chromecast#latest but it's a big one, so I wanted to also mention in here.

We've reworked and rewritten the Chromecast app to use the same underlying technology as the Web application. There are some look and feel changes in this first release, and some better device support - but it's also setting the foundations for support of newer Plex features.

I realise it's been very quiet from us devs in here for a long while, but if you have any feedback or issues with the new receiver then please let us know! If it's something that likely requires an answer/investigation, a new thread works best. Thanks :smile:


#2

By “Chromecast app”, do you mean the PleX for mobile (Android/iOS) app?


#3

@meingraham said:
By “Chromecast app”, do you mean the PleX for mobile (Android/iOS) app?

It means the app that the Chromecast runs when you cast to it from the web, Android or iOS. It is so different that I initially thought I had accidentally casted the Chrome tab instead of the native player. In particular it’s much slower to show metadata and thumbnail images on my Chromecast v2 than the previous web app was, I’ll have to dig out a Chromecast v1 to see if there are any issues with running it on that.


#4

OK - Bug reports.

  1. The previous app didn’t worry about figuring out sound until a video was casted. This meant that if my amplifier was not on at the point that the Plex web app was cast - that was fine, as long as I turned it on before trying to cast something with 5ch sound. The new app appears to negotiate what sound profiles are supported by the equipment as soon as it loads, and even if I turn the amplifier on before casting something with 5ch sound - it is transcoded to 2ch. Disconnecting from the Chromecast and recasting once the amplifier is turned on - brings back 5ch sound.

  2. I casted Harry Potter and it was all fine - according to Tautilus it was Direct Play. I then selected an SRT subtitle stream and it became Direct Stream because it was transcoding the container from MP4 to MKV and the subtitles from SRT to ASS. That was fine, that’s not hurting the CPU. I then skipped to about 45 minutes in to the video and suddenly Video, Audio and Subtitles were all Transcoding - (Subtitles changed to BURN) so clearly, it doesn’t like seeking through the video while subtitles are on.

I quit the app and recasted - and haven’t been able to replicate number 2 yet, but if I do - I’ll get some logs for you.


#5

This new app is giving me problems. It’s causing my video to buffer, when it’s only transcoding 6ch AAC to 2ch AAC. I played this exact video yesterday when the app didn’t show up and it played fine. I even checked Tautulli history to make sure. It’s transcoding only audio, using the same container, etc. The only difference is this app being used. Any chance functionality will be created to switch back/between them?


#6

Congrats on the release! Would it be possible to be a bit more specific regarding this point:
Update subtitle support: which formats are supported (or converted)? does this include both embedded subs and sidecar subs?


#7

Thanks for the feedback! If you get more details @asjmcguireplex and @dudeman27 could you please create new posts, ideally with sample videos so we can check? https://support.plex.tv/articles/201035968-generating-sample-files-from-media/

As for subtitles - we now support changing the subtitle size from the controller - support is out for web but not mobile yet. We render as softsubs without a transcoded burning in when we can. It should work with embedded or sidecar text based subtitles.


#8

Thanks @“Dom C” when I get a moment I’ll have another look - my subtitle issue may have been caused by first selecting VOBSUB which of course caused the subtitles to be burned in to the video, and then realising the mistake and selecting SRT. I’ll have a play around when I have more time and see if that combination of events is what caused the transcode behaviour.


#9

@“Dom C” Sure. The problem has since gotten worse. Once it buffers, it will do so indefinitely (I waited 10 minutes and it didn’t resume playing). The video has to be restarted, and it starts playing fine again. Here’s a screenshot of the stream details from Tautulli. Please let us switch back.

I’ll send over a sample file in a new post.


#10

The new gui is incredibly ugly and feels more like a downgrade than an update. Talk about taking steps back.


#11

Oh hmmm @“Dom C” just a quick FYI - according to the Plex Server activity page, while I’m casting to the Chromecast, as you know from my earlier video - the Activity page says Chrome not Chromecast. https://i.imgur.com/6mS5G7h.png


#12

does this mean i’ll be able to directplay 4k HVEC to my chromecast ultra without having to fiddle with an xml profile or whatever i did to get that working?


#13

I am afraid I have to agree on the new look as being awful. The Chromecast UI was the best of all big screen platforms. The Music screen is terrible now only since it used to be so rad! I loved the background of the artist! It was unique and made me work on finding kick ass backgrounds. Now there is no reason. I get that the idea was likely to streamline performance, which I can stand behind, but it is very unattractive.

What’s sad is I had posted only about a month ago that I loved the Chromecast platform so much, and now it is awful.

Can you at least bring back the Background Artwork for TVs, Movies and Now Playing on Music? Please? The glass UI thing, I get, you have kinda went that way with everything, but removing the artwork that we all work so hard on is terrible!


#14

I am sorry to be so rude…I know someone worked hard on this, but it is just a large change backward in functionality. I have been asking for the Year tag to be visible, and a lot of folks seemed to chime in on that, but instead, we now no longer know what the band looks like, what show might be about, the actors who might be in it, etc.

I am just so disappointed…I have so much time, blood, sweat, tears and money sunk into Plex (8 Plex Pass subscriptions, a dedicated NAS, dedicated server, 5 8TB hard drives and back ups as well, and new network gear all for what was hands down the best experience…but a HUGE change on the primary platform is just rubbing me the wrong way.

I also understand this is one opinion…


#15

@asjmcguireplex said:
Oh hmmm @“Dom C” just a quick FYI - according to the Plex Server activity page, while I’m casting to the Chromecast, as you know from my earlier video - the Activity page says Chrome not Chromecast. https://i.imgur.com/6mS5G7h.png

I can confirm this. This is also true translated into PlexPy as well.


#16

Hi @“Dom C”
BTW if you click on the info link to find out more about Plex for Chromecast. You get a 404
https://support.plex.tv/hc/en-us/sections/200286998


#17

I don’t mind the new UI much except for the background images. Please, please remove glass/blur effect and let as view the artwork as is!

On the positive side, I can now playback mkv files with SRT subtitles without transcoding in direct stream. That’s a great improvement! Unfortunately, transcoding still starts when attempting to play mkv’s with ASS subtitles.

Is improved support for mkv chapters also a new thing? I don’t remember seeing Chapters options when casting from iOS/Android. I can forgive pretty much any UI problems for an ability to finally being able to skip OP/ED like on a desktop media player.

The problem with casting 4k HEVC being randomly interrupted after a few seconds still persists after the update. But since it was caused by a server update, I guess the fix should be done on server side as well.


#18

I actually like the new cc from ios. Finally I can see the information I need quickly and clearly.
Switching from one show to another is really snappy to update the show info.


#19

I am no longer able to cast from my phone. I have updated, and restarted the server, restarted my phone, restarted the chromecast but it always comes back and says Sorry! Something went wrong. I also tried various playback settings from the phone but it always comes back and says Sorry. I looked for an app update but I am on the current version. I am able to cast from my browser but that is less than ideal.


#20

@jeffb24 said:
I am no longer able to cast from my phone. I have updated, and restarted the server, restarted my phone, restarted the chromecast but it always comes back and says Sorry! Something went wrong. I also tried various playback settings from the phone but it always comes back and says Sorry. I looked for an app update but I am on the current version. I am able to cast from my browser but that is less than ideal.

I’m having the exact same issue since this update. Tried all the troubleshooting steps you have as well.