New Chromecast App

chromecast

#13

I am afraid I have to agree on the new look as being awful. The Chromecast UI was the best of all big screen platforms. The Music screen is terrible now only since it used to be so rad! I loved the background of the artist! It was unique and made me work on finding kick ass backgrounds. Now there is no reason. I get that the idea was likely to streamline performance, which I can stand behind, but it is very unattractive.

What’s sad is I had posted only about a month ago that I loved the Chromecast platform so much, and now it is awful.

Can you at least bring back the Background Artwork for TVs, Movies and Now Playing on Music? Please? The glass UI thing, I get, you have kinda went that way with everything, but removing the artwork that we all work so hard on is terrible!


#14

I am sorry to be so rude…I know someone worked hard on this, but it is just a large change backward in functionality. I have been asking for the Year tag to be visible, and a lot of folks seemed to chime in on that, but instead, we now no longer know what the band looks like, what show might be about, the actors who might be in it, etc.

I am just so disappointed…I have so much time, blood, sweat, tears and money sunk into Plex (8 Plex Pass subscriptions, a dedicated NAS, dedicated server, 5 8TB hard drives and back ups as well, and new network gear all for what was hands down the best experience…but a HUGE change on the primary platform is just rubbing me the wrong way.

I also understand this is one opinion…


#15

@asjmcguireplex said:
Oh hmmm @“Dom C” just a quick FYI - according to the Plex Server activity page, while I’m casting to the Chromecast, as you know from my earlier video - the Activity page says Chrome not Chromecast. https://i.imgur.com/6mS5G7h.png

I can confirm this. This is also true translated into PlexPy as well.


#16

Hi @“Dom C”
BTW if you click on the info link to find out more about Plex for Chromecast. You get a 404
https://support.plex.tv/hc/en-us/sections/200286998


#17

I don’t mind the new UI much except for the background images. Please, please remove glass/blur effect and let as view the artwork as is!

On the positive side, I can now playback mkv files with SRT subtitles without transcoding in direct stream. That’s a great improvement! Unfortunately, transcoding still starts when attempting to play mkv’s with ASS subtitles.

Is improved support for mkv chapters also a new thing? I don’t remember seeing Chapters options when casting from iOS/Android. I can forgive pretty much any UI problems for an ability to finally being able to skip OP/ED like on a desktop media player.

The problem with casting 4k HEVC being randomly interrupted after a few seconds still persists after the update. But since it was caused by a server update, I guess the fix should be done on server side as well.


#18

I actually like the new cc from ios. Finally I can see the information I need quickly and clearly.
Switching from one show to another is really snappy to update the show info.


#19

I am no longer able to cast from my phone. I have updated, and restarted the server, restarted my phone, restarted the chromecast but it always comes back and says Sorry! Something went wrong. I also tried various playback settings from the phone but it always comes back and says Sorry. I looked for an app update but I am on the current version. I am able to cast from my browser but that is less than ideal.


#20

@jeffb24 said:
I am no longer able to cast from my phone. I have updated, and restarted the server, restarted my phone, restarted the chromecast but it always comes back and says Sorry! Something went wrong. I also tried various playback settings from the phone but it always comes back and says Sorry. I looked for an app update but I am on the current version. I am able to cast from my browser but that is less than ideal.

I’m having the exact same issue since this update. Tried all the troubleshooting steps you have as well.


#21

@jeffb24 said:
I am no longer able to cast from my phone. I have updated, and restarted the server, restarted my phone, restarted the chromecast but it always comes back and says Sorry! Something went wrong. I also tried various playback settings from the phone but it always comes back and says Sorry. I looked for an app update but I am on the current version. I am able to cast from my browser but that is less than ideal.

I’m having the same problem. Works fine from browser. Also is slow to connect, and doesn’t show the episode details before trying to play it.


#22

The new PLEX for Chromecast is not working. I can connect to my chromecast through the PLEX app (on phone and tablet) however, nothing plays. I only get a message saying “Sorry! Something went wrong.” This happens on my first gen and second gen Chromecasts. All I see on my TV when I’m connected through the PLEX app is a grey background, PLEX logo in the upper left, and info on the bottom left. Before this update everything worked great now I can’t watch anything on Chromecast… please help.


#23

@jeffb24 said:
I am no longer able to cast from my phone. I have updated, and restarted the server, restarted my phone, restarted the chromecast but it always comes back and says Sorry! Something went wrong. I also tried various playback settings from the phone but it always comes back and says Sorry. I looked for an app update but I am on the current version. I am able to cast from my browser but that is less than ideal.

I get the same error. And have done all the troubleshooting you have.
If i try to stream from my friends server tho, it works like a charm.


#24

A while back, something like this happened before. Try toggling the Secured Connections on and off (opposite of what you have). I think that had something to do with it. I’ll search back and see if I can find the exact post.


#25

@“Kyle Verry” said:
A while back, something like this happened before. Try toggling the Secured Connections on and off (opposite of what you have). I think that had something to do with it. I’ll search back and see if I can find the exact post.

Yes! Thank you Kyle, this was the solution to the issue of not being able to cast and getting the error “Sorry! Something went wrong.”

I went to my server’s settings page then clicked on Network and changed the “Security Connections” option from Prefered to Disabled, then saved the settings. Then, I switch the setting back to Prefered and saved the settings again. After that everything worked just fine. Thanks again for the tip! :smile:


#26

@Jynx2120 said:

@“Kyle Verry” said:
A while back, something like this happened before. Try toggling the Secured Connections on and off (opposite of what you have). I think that had something to do with it. I’ll search back and see if I can find the exact post.

Yes! Thank you Kyle, this was the solution to the issue of not being able to cast and getting the error “Sorry! Something went wrong.”

I went to my server’s settings page then clicked on Network and changed the “Security Connections” option from Prefered to Disabled, then saved the settings. Then, I switch the setting back to Prefered and saved the settings again. After that everything worked just fine. Thanks again for the tip! :smile:

Nevermind… Once the setting is back to Prefered it stops working again. :confused:


#27

@Jynx2120 said:

@Jynx2120 said:

@“Kyle Verry” said:
A while back, something like this happened before. Try toggling the Secured Connections on and off (opposite of what you have). I think that had something to do with it. I’ll search back and see if I can find the exact post.

Yes! Thank you Kyle, this was the solution to the issue of not being able to cast and getting the error “Sorry! Something went wrong.”

I went to my server’s settings page then clicked on Network and changed the “Security Connections” option from Prefered to Disabled, then saved the settings. Then, I switch the setting back to Prefered and saved the settings again. After that everything worked just fine. Thanks again for the tip! :smile:

Nevermind… Once the setting is back to Prefered it stops working again. :confused:

I’m sorry it didn’t stick. Keep it on Disabled and test it? Not ideal, but see if that’s the trouble?


#28

Thanks for the feedback. Sounds like we have an issue with iOS around security connections then? We’ll take a look.


#29

Same issue on Android with latest Plex server and Android app versions. Chromecast Ultra.

With setting to Server --> Network --> Secure connections = Preferred, receive ‘Sorry, something went wrong’ message. This worked fine previously.

Secure connections = Disabled plays as expected.


#30

@“Dom C” said:
Thanks for the feedback. Sounds like we have an issue with iOS around security connections then? We’ll take a look.

Not just iOS, it was my working for me on Android either, but disabling secure connecting allows it to work as well.


#31

Thanks! Updated our issue with that info. Hopefully get this sorted soon.

What is the network setup here? Is PMS and your iOS/Android device on the same network at the time?


#32

@“Dom C” said:
Thanks! Updated our issue with that info. Hopefully get this sorted soon.

What is the network setup here? Is PMS and your iOS/Android device on the same network at the time?

Dom, I’m having the same issue here as of last night. My PMS, 2 chromecasts (gen 1 and 2) and two android devices are on the same network. Thanks for looking into this issue!