New Fire TV App (9/6/2017) - Nothing will Play



I see tons of complaints about usability, performance, looks, ect… and I agree with all the feedback I’ve seen.
That said, is anyone else having problems getting the new app to work at all?

After the surprise update, I could no longer play anything. It started with the update and only applies to the FireTV. All other Android and iOS devices have no issue.

I tried uninstalling (clear data, clear cache) and re-installed. The same error message persists.
“Playback has stopped because the connection to the Plex Media Server has been lost. Please ensure the server is available and retry.”

If I cancel out and go take a look at the server, it looks fine (as pictured).

And as stated before, every other device aside from the FireTV has no problem with playback.
I recently bought a NAS device with Plex support and purchased the Lifetime PlexPass because it was such a good setup, but now… it’s completely useless.

Any ideas as to what I could troubleshoot?


My Mycloudex2ultra NAS plex experience was a disaster! No possibility of trans-coding (for me/subtitles!). I switched back to a server pronto! Should never have been sold as a "plex server"... period. God awful. Update is terrible as well. Seems that Plex has been making several stupid moves like these in recent years. Used to be so good.......


The problem has nothing to do with the NAS itself though in my case, only problem is with the latest FireTV app update.

As an aside, my Netgear ReadyNas has been a pretty good solution. A number of their devices have the power to perform at least "light trans-coding". Most material I have can be played direct. When I sync to a device for offline though, the NAS can handle trans-coding the material to a "mobile version". Pretty happy with it for my purposes. I don't need an i7 for trans-coding 4k material in "real-time" or anything crazy though.