New roku update forces a transcode on srt embedded subtitles.

roku

#1

Most of my media has srt subtitles embedded in the mkv and I always have them on but after this update they are triggering a video transcode. But if I choose an external srt subtitle it will direct stream fine. This is annoying since it was working just fine before. Hopefully this is a glitch that can be fixed.


#2

This is a known issue since the beta. What is regrettable though is the fact that they pushed this broken player to the stable version without fixing its bugs at all. This is really bad practice .


#3

I have some external (UTF-8) srt files and some internal (UTF-8) embedded sub title tracks (MKV) and they all Direct Play on my Roku 3 without issue.

For what it’s worth.


#4

Yes. I am definitely experiencing it as well


#5

Is there any update on this? Kind of frustrating.


#6

How could you stand roku’s softsubs? they were so misalligned, mis timed. and looked horrible… Once I discovered how to get them to work and tried them I instantly switched back, I’ll take the transcode quality hit. -_-


#7

I think this is solved on the latest Plex Pass version. It stopped transcoding the video necessarily at least for me.


#8

Well this is weird. For me it transcodes video with external subs but only if played after the post play coundown. If I stop and start the playback again manually the video isn’t transcoded and the subs aren’t burned-in.


#9

Most of these subtitle quirks have been fixed in our latest Plex Pass for Roku update. These changes will be included in our next official release. A little back story on this is is that we had to rewrite our video player using RSG (Roku Scene Graph), as Roku deprecated the video players we were using. This new player (RSG) did not support the method we used to convert incompatible subtitles on the fly, therefore they had to be burned in if selected. We have a new method now that required some help from the server. Everything should be as smooth as before as long as you are using Plex Media Server v1.11.1+ and Plex for Roku v5.1.3+.


#10

I’m running Plex for Roku v 5.2 and Plex Media Server v1.12.3.4973. I have had “Burn Subtitles” set to “Always” since I started using Roku a couple of months ago since that’s the only way to view subs. Other than the unacceptable Roku caption mode. After reading the above comment I thought I could change the “Burn Subtitles” back to “Automatic” and give my system a break from having to always transcode. However, it did not work. No subs in automatic. My subs are external .srt files. Back to always burning. So what am I missing?


#11

External srt files isn’t a guarantee that the format is UTF-8 (will Direct Play on most everything). Sometimes the format of the srt is ASS/PGS/Other image based sub format (will Require Transcoding - on many devices - like my Roku 3, for instance).

As part of the traditional and rigorous ‘pre-vetting’ process - that ALL material passes through - Video Streams are scrutinized to ensure Direct Play, as are Audio Streams. Subtitle tracks and/or any accompanying srt files are converted to UTF-8. In most cases this results in Direct Play, but hiccups in Roku Firmware/Roku Plex App misfires, sometimes Force Direct Play has to be employed - not often these days, but it does happen.

In the past I could almost always blame errant transcodes on subtitles, but now, since the UTF-8 conversions, subtitles are never a problem and those mysterious transcodes seem to happen for reasons I can’t identify - or predict.

Basically, if you insist on using image based sub formats - don’t be too surprised if they have to transcode. If transcoding isn’t an option - better start converting I guess. I do all mine with Xmedia Recode - it’s just too easy - ‘Subrip’ is Xmedia Recode’s UTF-8 format - just so you know - I didn’t - but found out.

Converting sub tracks/files is fast and easy:
https://www.xmedia-recode.de/en/download.html


#12

I confirmed my .srt subtitles are UTF-8 with Subtitle Edit. I then played a video with the confirmed UTF-8 sub. I tried all three modes available for “Burn Subtitles” on the Roku. Subtitles were not displayed with Automatic and Only Image Formats selected. They only displayed when Always was selected.

Ijunkie indicated that Plex Pass for Roku should be smooth as silk. Did he mean as long as you have “Always” selected for Burn Subtitles?


#13

@hamhock44 do you have the Roku Caption mode set to on? We cannot bypass that is our video player now, as Roku needs that enabled to render the subtitles. By choosing always burn in, the Plex Media Server will burn those subtitles into the video feed, and that does not require the captions mode to be on as the Roku isn’t required to render them.

The OPs issue in this thread was that embedded SRT subtitles would cause a forced transcode (burn-in). We no longer require that.


#14

Yes I have tried the Roku Cation mode. Reminds me of being in a public waiting area watching TV with the volume off. I might be able to live with that if you could set it to only display with external subs and not during live TV also. Constantly having to switch on and off is not idea.

But I think I understand what you are saying now. Plex is not responsible for how Roku displays subtitles. All Plex can do is burn them to the video. I have three Ultras and a stick. Maybe we should start pinging Roku to make some changes or at least give us the ability to makes some adjustments to when and how their ugly subtitles are displayed. Thanks for explaining this to me.


#15

I might be able to live with that if you could set it to only display with external subs and not during live TV also. Constantly having to switch on and off is not idea.

Yeah, it’s a little cumbersome. You may already know, but you can press the * button during playback to switch the Roku captions mode. That may make it a little quicker to enable/disable Roku captions mode. Just note, that setting is global for the entire Roku, which is something Roku requires. Meaning, if you enable/disable Roku captions from anywhere (roku settings, other channels, our channel) it’s changed globally on the Roku.


#16

Yes I know about the * button during playback. Still seems stupid to have to change it. Is Roku the only player on the planet that has implemented subtitles as part of their global captions? I know Fire TV stick and every other device I’m using or have tried knew how to handle subtitles the proper way. Roku needs to wake up. That is the only complaint I have with it.