# Newer PMS versions not adding content

**URL:** <https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632>\
**Category:** Plex Media Server\
**Tags:** server-docker, server-unraid, library-management\
**Created:** [May 13, 2022, 10:04am UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632 "2022-05-13T10:04:13Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![nuuki1](https://avatars.discourse-cdn.com/v4/letter/n/e36b37/32.png) [@nuuki1](https://forums.plex.tv/u/nuuki1)\
**Post date:** [May 13, 2022, 10:04am UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/1 "2022-05-13T10:04:13Z")

</div>

A few weeks ago I noticed that new content wasn’t being added in any of my libraries. I’ve run Plex for many years without issue - previously on a Windows Server but for the last year on Unraid, using the official docker container.

With the flexibility in being able to switch container versions easily, I tried reverting to an older build, and that worked fine. Working through the versions from there I found that the last working version for me was 1.25.8.5663 - when I upgrade to 1.25.9.5721 or later the problem appears.

I’ve checked naming contentions, tried the [Plex dance](https://forums.plex.tv/t/the-plex-dance/197064) and optimized the database, so not sure what else to try.

Any ideas?

---

<div class="post-metadata">

**Author:** ![FordGuy61](https://avatars.discourse-cdn.com/v4/letter/f/22d042/32.png) [@FordGuy61](https://forums.plex.tv/u/FordGuy61)\
**Post date:** [May 13, 2022, 4:04pm UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/2 "2022-05-13T16:04:35Z")

</div>

Check for a corrupt database. Depending on the level of corruption, Plex may recognize some or none of your new content. Pull the [server log](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) files, Settings → Troubleshooting, and look in the Plex Media Server.log file (and .1.log, etc). Look for SQLITE errors that mention database corruption, a malformed database, etc.

Example:  
`Aug 09, 2019 10:03:44.386 [0x700002c15000] Error — SQLITE3:(nil), 11, database corruption at line 79051 of [bf8c1b2b7a]`

The Plex Movie and Plex TV Series agents/scanners are more strict than the legacy agents when it comes to naming & organization. Some structures that worked with the legacy agents no longer work with the new agents. This is especially true for TV shows. For example, sXXeYY will work, where formats such as 00x01 or [0x01] will cause problems. See the [Your Media](https://support.plex.tv/articles/categories/your-media/) section of the [Plex Docs](https://support.plex.tv/articles/) for naming & organization guidelines.

> **[Why is some of my content not found? | Plex Support](https://support.plex.tv/articles/201543057-why-is-some-of-my-content-not-found/)**
>
> Naming and Organization The biggest reason by far for items to not be found during a library scan is due...

> **[Repair a Corrupted Database | Plex Support](https://support.plex.tv/articles/repair-a-corrupted-database/)**
>
> Note: This article is for Plex Media Server version 1.23.2 and newer. If using an earlier version, see . Though...

---

<div class="post-metadata">

**Author:** ![nuuki1](https://avatars.discourse-cdn.com/v4/letter/n/e36b37/32.png) [@nuuki1](https://forums.plex.tv/u/nuuki1)\
**Post date:** [May 15, 2022, 2:54pm UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/3 "2022-05-15T14:54:09Z")

</div>

So in the course of following up on your points I did find a likely root cause, though not yet a full fix. Just to confirm, I did run a database check and repair, to no obvious effect - I didn’t see any SQLITE errors in the logs either (though a lot of XML errors…).

However looking at the logs in more details, I did see some permission related errors.

Looking at the files, I’m seeing some discrepencies in file ownership and permissions - never noticed before and its not been an issue up to now, but presumably its related to that somehow. The slight complexity is that the Plex server is running as a container on Unraid, whereas the media is on a separate Synology NAS, being shared as an NFS share. I went in and used the “squash” option to map all client connections to admin, which I felt sure would resolve this, but it didn’t.

I then went into the Synology console and chown / chmod’d the specific show to 666 just to be sure. However when I did that a whole season disappeared, and no reference to it in the logs. I tried the [Plex dance](https://forums.plex.tv/t/the-plex-dance/197064), as well as adding the TVDB ID to the show name, but no luck. Interestingly I saw a couple of movies with the same permission errors, and manually setting their permissions _did_ cause them to show up.

So I’m confident its permission related, but I don’t yet have it fully nailed.

I see the docker container has a “first run” variable to set media permissions. Is there a way to run this after first run? Failing that I can script it easily enough, but a supported method is always preferable.

If you think there’a anything else I can try let me know, though in the meantime I’ll keep experimenting…

---

<div class="post-metadata">

**Author:** ![nuuki1](https://avatars.discourse-cdn.com/v4/letter/n/e36b37/32.png) [@nuuki1](https://forums.plex.tv/u/nuuki1)\
**Post date:** [May 15, 2022, 3:17pm UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/4 "2022-05-15T15:17:47Z")

</div>

@FordGuy61

Just found this new error in relation to the show that won’t add back in:

`ERROR - Got exception from request handler: sqlite3_statement_backend::loadRS: malformed MATCH expression: <show expression>`

Not seen it previously, but explain why ficing permissions didn’t sort this one thing out?

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [May 15, 2022, 4:09pm UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/5 "2022-05-15T16:09:30Z")

</div>

how are your files structured/named?

---

<div class="post-metadata">

**Author:** ![FordGuy61](https://avatars.discourse-cdn.com/v4/letter/f/22d042/32.png) [@FordGuy61](https://forums.plex.tv/u/FordGuy61)\
**Post date:** [May 15, 2022, 5:03pm UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/6 "2022-05-15T17:03:19Z")

</div>

Good that your database is not corrupt.

I run Plex on Ubuntu. I’ve never run it on truenas or in docker, so can’t help with that part.

I also have media on a Synology NAS, and getting permissions working took a bit.

Squashing all users to admin should be OK. Also set security to `sys` if you’re not using kerberos. It is right under the setting where you squash to admin in Syno NFS permissions.

You may want to try setting permissions to 755 after mounting the NFS shares. It is recommended in [Linux Tips - Mounting NFS network shares for Plex use](https://forums.plex.tv/t/linux-tips/276247/5). I’m not sure how you do that when running Plex in a docker container.

FWIW, I took a slightly different route. I set the Synology to NFSv3 instead of NFSv4, then matched the user id & group between Ubuntu and Synology for plex:plex. I then make sure plex:plex on Synology has at least read-only permissions to the media files.

> [@nuuki1](#):
>
> ERROR - Got exception from request handler: sqlite3\_statement\_backend::loadRS: malformed MATCH expression:

I’ve never seen that message before. I searched the forum and found one hit. That system had run out of space on the drive holding the database. However, there was also a SQLITE error message saying “out of space.”

---

<div class="post-metadata">

**Author:** ![nuuki1](https://avatars.discourse-cdn.com/v4/letter/n/e36b37/32.png) [@nuuki1](https://forums.plex.tv/u/nuuki1)\
**Post date:** [May 15, 2022, 5:43pm UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/7 "2022-05-15T17:43:13Z")

</div>

Thanks for the follow-up. I’ll follow-up on the permissions points, but I just wanted to add that your point about the database made me realise I hadn’t re-checked for SQLITE errors after I spotted that request handler error. Having not had any previously it didn’t occur to me to check again.

Anyway had a look and I do indeed have some from around the same time. Not related to space that I can tell, but may offer some useful info. So here are all the messages from that point:

```auto
May 15, 2022 16:09:35.037 [0x146408efcb38] ERROR - SQLITE3:0x80000001, 1, statement aborts at 11: [select distinct metadata_items.id from metadata_items join fts4_metadata_titles_icu on metadata_items.id=fts4_metadata_titles_icu.rowid join metadata_item_accounts on metadata_item_a
May 15, 2022 16:09:35.037 [0x1464090e9b38] ERROR - SQLITE3:0x80000001, 1, statement aborts at 25: [select distinct metadata_items.id from metadata_items join fts4_metadata_titles_icu on metadata_items.id=fts4_metadata_titles_icu.rowid join metadata_item_accounts on metadata_item_a
May 15, 2022 16:09:35.042 [0x1464090e9b38] ERROR - Got exception from request handler: sqlite3_statement_backend::loadRS: malformed MATCH expression: [Lego* Masters* (N*]
May 15, 2022 16:09:35.042 [0x146408efcb38] ERROR - Got exception from request handler: sqlite3_statement_backend::loadRS: malformed MATCH expression: [Lego* Masters* (N*]

```

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [May 15, 2022, 6:12pm UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/8 "2022-05-15T18:12:08Z")

</div>

@nuuki1 you could also upload your plex [server logs](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) and see if we catch something you missed.

---

<div class="post-metadata">

**Author:** ![nuuki1](https://avatars.discourse-cdn.com/v4/letter/n/e36b37/32.png) [@nuuki1](https://forums.plex.tv/u/nuuki1)\
**Post date:** [May 15, 2022, 7:43pm UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/9 "2022-05-15T19:43:56Z")

</div>

@dbirch I was about to upload the [Server Logs,](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) as those contain a whole bunch of XML errors that may be relevant, but here’s the whole lot.

I just tried moving a show out, scanning to remove it, then adding it back in. As predicted it didn’t show up, despite the permissions being fine (666 for files and 777 for folders).

Anyway I’ve not had a lot of experience checking logs but if you guys have any insights I’m happy to try anything…

[Plex Media Server Logs\_2022-05-15\_20-33-53.zip](https://forums.plex.tv/uploads/short-url/zHojSh0mATVzsCU9ciknnduEkxm.zip) (4.1 MB)  
s

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [May 15, 2022, 10:05pm UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/10 "2022-05-15T22:05:02Z")

</div>

You have something weird going on with your server config. Did you manually define the public port on your docker? It almost looks like you have a webserver and plex sharing the same port.

---

<div class="post-metadata">

**Author:** ![nuuki1](https://avatars.discourse-cdn.com/v4/letter/n/e36b37/32.png) [@nuuki1](https://forums.plex.tv/u/nuuki1)\
**Post date:** [May 16, 2022, 8:24am UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/11 "2022-05-16T08:24:41Z")

</div>

Thanks for the feedback @dbirch. Are you saying that because of the XML errors being reported - you think that’s Plex responding to unexpected (non Plex) connections?

I’m not seeing anything crazy in the Docker run command, but here it is in full:

```auto
docker run -d --name='Plex-Media-Server' \
	--net='host' \
	-e TZ="Europe/London" \
	-e HOST_OS="Unraid" \
	-e 'PLEX_CLAIM'='SECRET' \
	-e 'PLEX_UID'='99' \
	-e 'PLEX_GID'='100' \
	-e 'VERSION'='latest' \
	-v '/tmp':'/transcode':'rw' \
	-v '/mnt/remotes/NAS_Videos/':'/data/video':'rw,slave' \ 
	-v '/mnt/remotes/NAS_Audio/':'/data/audio':'rw,slave' \
	-v '/mnt/remotes/NAS_Backups/Unraid/Plex':'/backups':'rw,slave' \
	-v '/mnt/user/appdata/Plex-Media-Server':'/config':'rw' \
	'plexinc/pms-docker:plexpass'

```

I’m using a community template in Unraid, though I’m clear on what everything’s doing, with the possible exeption of the `VERSION` variable. I could always remove that, though that doesn’t seem like a likely culprit for bigger issues.

I could do some network troubleshooting to investigate your broader point, if we’re confident that nothing that Plex clients are doing should be resulting in those types of errors.

I’m not sure that accounts for the content issues I was seeing, but I’m generally a fan of fixing problems I cn see, in case its having some knock on effects.

---

<div class="post-metadata">

**Author:** ![nuuki1](https://avatars.discourse-cdn.com/v4/letter/n/e36b37/32.png) [@nuuki1](https://forums.plex.tv/u/nuuki1)\
**Post date:** [May 16, 2022, 9:05am UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/12 "2022-05-16T09:05:35Z")

</div>

Doing some quick research it looks like those errors aren’t a problem. Each large block of XML errors ends with this one:

`ERROR - SSDP: Error parsing device schema for http://0.0.0.0:80/upnp/BasicDevice.xml`

They seem to relate to device discoverability - its a pain in terms of filling logs so I will try to resolve it, but it doesn’t _sound_ like its a problem.

@dbirch - does that account for your comments, or were you seeing other things you thought were a problem?

> [@SSDP: Error parsing device schema for http://x.x.x.x:9080](https://forums.plex.tv/t/ssdp-error-parsing-device-schema-for-http-x-x-x-x-9080/302731):
>
> Server Version#: 1.13.6.5339 Player Version#: 7.4.0.6242 My server is reporting the error multiple times each second, the IP it shows is only for a [Fire TV 4K dongle](https://www.amazon.com/all-new-amazon-fire-tv-4k-uhd-streaming-media-player/dp/B01N32NCPM/ref=sr_1_2?ie=UTF8&qid=1535641734&sr=8-2&keywords=fire+tv), it’s not happening with any other device. I don’t have the TV on currently that it is attached to and it still keeps popping up this error. It doesn’t seem to be causing any noticeable problems but it is flooding my error logs when I’m trying to resolve another issue. Aug 30, 2018 11:10:27.517 [0x700008f91000] ERROR - XML: Enti…

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [August 14, 2022, 9:06am UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/13 "2022-08-14T09:06:19Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
