# Newer PMS versions not adding content

**URL:** <https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632>\
**Category:** Plex Media Server\
**Tags:** server-docker, server-unraid, library-management\
**Created:** [May 13, 2022, 10:04am UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632 "2022-05-13T10:04:13Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![nuuki1](https://avatars.discourse-cdn.com/v4/letter/n/e36b37/32.png) [@nuuki1](https://forums.plex.tv/u/nuuki1)\
**Post date:** [May 15, 2022, 2:54pm UTC](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632/3 "2022-05-15T14:54:09Z")

</div>

So in the course of following up on your points I did find a likely root cause, though not yet a full fix. Just to confirm, I did run a database check and repair, to no obvious effect - I didn’t see any SQLITE errors in the logs either (though a lot of XML errors…).

However looking at the logs in more details, I did see some permission related errors.

Looking at the files, I’m seeing some discrepencies in file ownership and permissions - never noticed before and its not been an issue up to now, but presumably its related to that somehow. The slight complexity is that the Plex server is running as a container on Unraid, whereas the media is on a separate Synology NAS, being shared as an NFS share. I went in and used the “squash” option to map all client connections to admin, which I felt sure would resolve this, but it didn’t.

I then went into the Synology console and chown / chmod’d the specific show to 666 just to be sure. However when I did that a whole season disappeared, and no reference to it in the logs. I tried the [Plex dance](https://forums.plex.tv/t/the-plex-dance/197064), as well as adding the TVDB ID to the show name, but no luck. Interestingly I saw a couple of movies with the same permission errors, and manually setting their permissions _did_ cause them to show up.

So I’m confident its permission related, but I don’t yet have it fully nailed.

I see the docker container has a “first run” variable to set media permissions. Is there a way to run this after first run? Failing that I can script it easily enough, but a supported method is always preferable.

If you think there’a anything else I can try let me know, though in the meantime I’ll keep experimenting…

---

_[View the full topic](https://forums.plex.tv/t/newer-pms-versions-not-adding-content/792632)._
