No 5.1 thru optical/toslink cable

android-tv
fire-tv

#1

Hi, I don't have 5.1 audio at all in my Sony Android TV running Plex thru an optical cable to my receiver, all is updated to the latest version.

Netflix and other apps works perfectly in 5.1

What can be?


#2

There is a problem with generation two models and they no longer are playing 5.1 thru HDMI or TOS link. We are hoping someone will fix it.


#3

Are you kidding me?

I brought a tv in 2016 that can't play 5.1 audio in plex due a bug?

Who can fix it?

It's a joke mate...

But If I use the android tv video player, I can see the movie via Plex server in 5.1...


#4

Same issue here. Any update?


#5

Right now there is no fix for the native Plex on Fire TV generation 2 models. Plex seem to be ignoring the issue and my only recommendation would be to pick up a used Gen 1 box , it continues to handle 5.1 on Plex with no problems at all.


#6

Recently got a new Sony KD65XE9005 and can confirm that 5.1 AC3 or DTS audio over optical is still not working for Plex. The TV is running the latest Android TV version 7. Any update on this from Plex devs?

All other apps (Netflix) are sending a 5.1 signal to my soundbar including HDMI sources.

I also noticed that Plex is transcoding everything, why?
Check debug log below

Sep 24, 2017 16:51:39.294 [0x7f7d773fd700] DEBUG - MDE: Frozen (2013): Direct Play is disabled
Sep 24, 2017 16:51:39.294 [0x7f7d773fd700] DEBUG - MDE: Frozen (2013): media must be transcoded in order to use the hls protocol
Sep 24, 2017 16:51:39.294 [0x7f7d773fd700] DEBUG - MDE: Frozen (2013): selected audio stream is not the first audio stream and direct play stream selection is not enabled
Sep 24, 2017 16:51:39.294 [0x7f7d773fd700] DEBUG - MDE: Frozen (2013): no direct play video profile exists for http/mkv/h264
Sep 24, 2017 16:51:39.294 [0x7f7d773fd700] DEBUG - MDE: Frozen (2013): no direct play video profile exists for http/mkv/h264/dca
Sep 24, 2017 16:51:39.294 [0x7f7d773fd700] DEBUG - MDE: Frozen (2013): no direct play video profile exists for http/mkv/h264/dca
Sep 24, 2017 16:51:39.295 [0x7f7d773fd700] DEBUG - MDE: Frozen (2013): no direct play video profile exists for http/mkv/h264/ac3
Sep 24, 2017 16:51:39.295 [0x7f7d773fd700] DEBUG - MDE: Frozen (2013): Direct Streaming is disabled, so video stream will be transcoded
Sep 24, 2017 16:51:39.295 [0x7f7d773fd700] DEBUG - MDE: Frozen (2013): no remuxable profile found, so video stream will be transcoded
Sep 24, 2017 16:51:39.295 [0x7f7d773fd700] DEBUG - Scaled up video bitrate to 15805Kbps based on 1.500000x fudge factor.
Sep 24, 2017 16:51:39.295 [0x7f7d773fd700] DEBUG - MDE: Frozen (2013): Audio Direct Streaming is disabled, so video's audio stream will be transcoded
Sep 24, 2017 16:51:39.295 [0x7f7d773fd700] DEBUG - MDE: Frozen (2013): selected media 0 / 63248