No audio with AC3 5.1 on Premiere+



Using plex 4.4.1 on a new Roku Premiere+.

Connected to a Pioneer VSX-43 reciever via HDMI.
Plex media server is up to date (

All stereo streams work fine, but any videos with AC3 5.1 have no audio. If I manually set the roku to stereo only, it plays audio, but this just isn't acceptable.

I swapped out for a Roku 3 with the same verison of Plex, and everything plays fine on 'Auto' for audio, and it sounds great.

Plex for Ps4 works fine as well.


i just noticed this same issue on all of my devices. if i try to stream any media with AC3 5.1 it just sits there loading and then times out after a little while.


Spunky, a lot of us are having this exact issue. Roku released 7.6 on 4/11 so download it and give it a try! I haven't been home yet to check it out, but do report back!


i have confirmed this is an issue with the udpate, if you rollback to it resolves the issue. :)


I've been struggling with the same issue. Only Roku plex client have no audio but other cients (i.e. Web, iOS etc.) all works fine. Zac, any idea how I could get an older version of PMS and rollback? Thanks in advance.


Can you guys confirm that the files with no audio are, in fact, AC3...and not EAC3? As noted in my other thread, my Ultra wasn't abiding by my universal Roku setting to support only AC3/DTS. It was still trying to stream EAC3, which caused no audio.


Same Problem here, No sound with 5.1 AC3


Updating to Roku 7.6 seems to have fixed my Plex AC3 issues--now I just have the random split second sound delays.


Indeed, the update to 7.6 has fixed the issue.


I've noticed the same issue with random sound delays (just drops out momentarily), and on a few occasions I've lost sound entirely. Only a restart of the Roku returns sound.


I have Roku 7.6 and still all AC3 have no sound. 5.1 or stereo.


I found I had to go into the Roku audio settings and set everything to stereo. It now works.


Same issue. Roku 3 played AC3 5.1 without issue. Now the premier I just got won't play those streams.


I have same issue contacted Roku support and they said issue is with plex.



"Hello. My Name is 'Joe Namath'.
.....How can I help you, today?"
(Indian accent so deep, Indians need subs)
(the post-it note in that ash tray reads: 'Blame Plex')


Ok, if this is the same issue as mine, this should be taken care of ASAP, not in months....

I own 5 Roku 3, Apple TV, NUC, etc...
I bought a new 4K TV (Sony xbr65x900e) so even with Android TV on it, I wanted to keep using Roku, so I got a Roku Premiere Plus (because I wanted HDR with Netflix)

I also have as receiver an Onkyo TX-NR838. It does 4K and HDCP 2.2 on one port but not HDR. Just FYI.

And... to my big surprise, only in Plex app on the new Roku, AC3 doesn't work...
-Roku - receiver - TV
-Roku - TV - receiver (ARC)

My TV (when connecting the second way) mentions audio not supported (which doesn't make sense...)

I connected the Roku 3 BOTH THE EXACT SAME WAY (same inputs) as tried with Premiere Plus and NO PROBLEM with AC3 (Direct play, which is the point here).
So this is not about a setting from TV or receiver...

I tried just in case to change Roku display to 1080, 4K no HRD and 4K HDR 60fps.... doesn't make a difference.

In the Roku Premiere Plus audio and HDMI settings, only setting that works is stereo (which is just because it works around the fact that AC3 coming out of Plex/Roku Premiere Plus isn't right...

It is no acceptable to downgrade audio to stereo IMO...

***DTS passthrough fine, this is just about AC3 5.1... It must be the way it's output.. something must not follow standards or something...)

I cannot confirm but I'm presuming Ultra has the same issue.
This needs to be addressed ASAP IMO...

Please let me know if you need me to do specific tests, provide logs, etc.. I would be happy to, but this needs to be fixed if this is a general issue (and if it's just me, well, please help lol)

***If really needed, I could even install/setup Emby to test in Roku Premiere Plus, if it works, NOW IT'S 100% a Plex issue...
Let me know please how to proceed...


This is still a problem. No audio on AC3 5.1 tracks. All other audio is fine.

Roku Premiere+ (4630X) version 7.7.0
Plex server version
Plex client 5.0 version 1

Anyone know how to fix this, or do I need to wait for Plex to correct?


Yes, I’m still having this problem, and have been for MONTHS. I’m tired of having to reboot my Roku multiple times a day!


I’m also seeing this problem happen again after several months of it working. Rebooting the Roku Premiere has not yet fixed it. I noticed it after updating Plex Media Server to, though I don’t know that the two events are related.


This seems to be fixed now after installing