No Dolby Digital Playback

samsung-smart-hub

#1

Hello together,

I am running the latest version of Plex Media Server on a Synology NAS and have several Clients in use.
One of the clients is running on a Samsung HU7590. When I watch a movie which has a DTS 5.1 audio track the playback is perfect and my Denon AVR switches to DTS input. But when playback movies having a Dolby Digital AC3 5.1 audio track my Denon stays in MC Stereo so the TV respectively the Plex app seems to output PCM. Even if I change the audio track from German to English DD True HD 7.1 it stays in German PCM. It is also only possible to change between the audio tracks when the movie is not played back, changing the audio track during playback does not work.

I tried to change the configuration of the audio output mode but that did not have any effects.

Has anybody an idea what is going wrong?


#2

It's a bug in 2.009 with automatic output switching combined with a glitch in the firmware.
You can however fix it manually:

  • Start a movie and during playback press the Tools button
  • Select the Audio menu, this will open the TV's own menu
  • Find the output settings and set it to whatever is available.

Note : The TV will stay in this mode, so you may need to change it again if the output format is DTS again.

I will try to fix it in the next version.


#3

Hi Orca,

Thanks for your Response. I will try it.
Do you already know whena new version will be available?
I also have some better Translations for German language. Are you interested in them or how to proceed with them?

Regards,

Marcel


#4

Here is how to add/fix any translations
https://forums.plex.tv/discussion/195179/translations-and-how-to-add-your-own-language/p1


#5

Hi Orca
I had the same issue and change the audio menu is working. But i can't watch many movies in original version, only in french (i'm French). For some movies, the subtitle is always in english (even if i choose french subtitle). For other, the movie is always in french, even i a choose the english audio track.
I think it's come from the TV but i'm not sure. Can you confirm it ? It's a Samsung UE65JS9500.

Thanks


#6

If you select the audio and subtitles before you start playback (on the Preplay screen) it should pick the correct settings.
However changing the audio track during playback is also affected by the bug, and might fail.

The problem could be that the TV is not able to update the server (firewall on the server maybe?)
You can check this by opening Plex web to check the settings for subtitles and audio.
Now open the same movie on the TV and switch something, after a browser refresh it should show the changes on Plex web.
If that doesn't work check the server 's firewall settings and such.


#7

@Epok75 said:
Hi Orca
I had the same issue and change the audio menu is working. But i can't watch many movies in original version, only in french (i'm French). For some movies, the subtitle is always in english (even if i choose french subtitle). For other, the movie is always in french, even i a choose the english audio track.
I think it's come from the TV but i'm not sure. Can you confirm it ? It's a Samsung UE65JS9500.

Thanks

Got the same problem, except opposite.
have a french tv show with English subs as 3rd. option.
No matter what language i select in "preplay" screen, it is Always the first or second language.
Selecting langue via "Options" (B) sometimes fix it, but it also hangs the app if i have to select several times.