No picture when files are EAC3 5.1, Android TV



When a file is in the format EAC3 5.1, the image on the video is completely black. I still hear the sound and my amplifier switches to Dolby Digital, but as said, the picture is just black.
When I take a real bluray movie via plex, the amplifier will not switch to Dolby Digital, but at least I will get a picture?

I have tried to run via Chrome on the TV and via the app. But nothing helps.

The only way to look at an episode is to lower the quality of both audio and video to almost the lowest.
I have an internet connection of 100 mbit / s up and down, so I don't think my connection is the problem.

Please help me somebody.


Please provide media info on the files.
it is trying to direct playing the video?

What device are you trying to play it on?


For example, WEBRip.DDP5.1, AVC
Sorry for the quality on the picture, im at work so I can’t printscreen.
The device is from my computer to my Philips TV, Philips 65pus8601. It has the latest Android update.


@BigWheel said:

it is trying to direct playing the video?

What do you mean with direct play the video?
I’m kinda new with plex, sorry.



Direct play means play the file as is.

if whatever player/device you are using cannot play a file the server will transcode it. such as what happens when you lowered the quality. Transcoding is on the fly converting the either video, audio stream or both to be compatible with whatever you are playing it on. or for quality/bitrate reasons

Do you have passthough enabled? the app is dependent on the device telling it properly what it can play. or if it can even passthough a format

If you are using the Android TV app you can open settings and turn on Display information overlay and if transcoding or direct play it will say on top left when controls are brought up


It says Direct Play when I start the video.
Passthrough is on Auto.
So you mean my TV can’t read the file, that’s the problem? So I need to lower the quality?
Or is it anything more I can do?


I just checked how far down I had to go in quality. I have to go down to 8 mbps for the image to work and then Dolby Digital will disappear and become PCM instead.

I guess there is nothing I can do about this?


try turning off DD+ in your tv’s own settings. if i am understanding. or lower quality


It works, but not as good as I want it to work, lol. But now I know at least what the problem is. My TV does not work with some audio files.
Thanks so much for your help.

One last question though, is there anything I can buy so I can play all kinds of audio formats?
DD Plus, DTS HD-MA etc etc …
Nvidia Shield for example?


Nvidia shield will passthrough most formats to your receiver. I have one.