No Playback on iOS Plex App

ios

#1

Hello guys,

Just paid £5 to unlock the Plex app on my iPhone 7 Plus to watch my media on my phone. When I try to play back certain shows it doesn't play them but instead displays the Artwork for said TV show or Movie. The format is I am trying to play is MKV. Please can someone help me as I don't know why this is causing a problem, I've used other Media Servers in the past that were able to play all of my content just fine through the mobile app.


#2

Can anyone help me with this?


#3

If you are running iOS 11, it will only work as you describe with the latest release of plex for iOS.


#4

I'm having the same issue , Plex iOS app version 4.15 on iPhone 7+ running iOS 10.3.3. Worked just fine maybe 2 months ago (older Plex App and iOS versions) but now I get sound but otherwise no video playback just the static "Poster" when playing directly on my phone.


#5

There are three other threads now near the top of this iOS forum in addition to this one describing nearly the same issue. Not iOS 11 (at least in my case) . I see this issue with mkv and mp4 files, basically my entire library. Plex in Firefox on my iMac works just fine, as does the Plex app on multiple Roku's on multiple TV's , all videos and audio work there. Only on my iPhone with the latest Plex app do I get audio only no video. All connecting to the same server.

https://forums.plex.tv/discussion/282441/as-a-follow-up-to-my-previous-question-audio-no-video-on-ios-devices#latest
https://forums.plex.tv/discussion/282422/mkv-and-avi-files-only-play-sound-on-my-iphone#latest
https://forums.plex.tv/discussion/282418/audio-plays-just-fine-but-when-movie-loads-the-video-is-just-the-movie-poster-and-doesn-t-change#latest


#6

FYI I just downloaded the new Plex iOS app version 4.16 and video works again! Tested several mkv and mp4 files and they all worked. Thanks for the update and fix for the playback!


#7

Working for me as well on iOS 11.