no sound with aac 7.1

roku

#1

i just got a roku tv, in my use since getting it ive found that any video with aac-lc 7.1 audio does not have any sound on the plex app. 5.1 aac and stereo formats are fine though. this is just using the tv for audio, no avr or speakers/soundbar of any kind connected to the tv. the files work fine in the plex web app as well as via other media players on pc. is there anything i can do to rectify this?


#2

The wisest thing you can do is visit the Roku Settings (Roku Home/Settings/Audio) and select ‘Stereo Only’.
Make sure the Plex Roku app settings allow:
Direct Play - Auto
Direct Stream - Enabled

That will force Plex to transcode all that multi-channel stuff you can’t use to AAC 2.0.
Audio only transcodes are easy and having audio tracks you can hear are really nice.

There are some mitigating circumstances where this plan may go awry, but if you check this thread:


We were just talking about it and what you may do about it.

AAC-LC 7.1?
Really?

Hopefully Plex knows what to do with that mess, but if not Xmedia Recode does - convert it to AAC-LC 2.0:
http://www.xmedia-recode.de/en/download.html
Copy Video
Convert Audio
Over in moments.

This may result (likely) in dialog that’s hard to hear. Sometimes you can fix that with XR by ‘Normalizing’ the AAC-LC 2.0 audio track to 89db, but there are some caveats to that plan as well. I have been involved in a long bloody battle with DTS for some time now and came up with a plan that is working, for the moment…

I use XR to convert DTS to AC3 5.1 and changed my Roku Audio settings for DD to Auto. My particular TV (with 2 external speakers), for some reason can deal with AC3 5.1 and the results so far are positive. I do normalize those audio streams to 84db and I can hear the dialog for the most part.

It is a fiddle, but what are ya gonna do?


#3

thanks, already had the tv and plex set that way, so seems plex isnt transcoding the audio, i guess ill be doing it myself for the applicable files then


#4

I’m having the same issue with a just purchased TCL 55S403 at Costco. If I try to play a movie that is 2160p and has 7.1 sound there is no audio. 5.1 audio in 720 or 1080 work fine. I have direct play disabled in plex. Using server 1.7.5.4035. I’ve tried multiple settings and I’m beginning to wonder if its the TV or the Roku firmware… Sad this is a really nice TV at a decent price point.


#5

Have you tried the Plex Pass preview channel? There is a 7.1 audio related fix in that channel that (still) hasn’t made its way over to the official channel.


#6

@DFury said:
Have you tried the Plex Pass preview channel? There is a 7.1 audio related fix in that channel that (still) hasn’t made its way over to the official channel.

just tried the plex pass preview channel, 7.1 audio works fine with that.
didn’t even know there was a separate plex pass preview version so thank you very much :slight_smile:


#7

Hmm, I still can’t hear any sound. I am using the plex preview channel already. I have an LG OLED TV.


#8

Mid-April 2018 and plex Android Player STILL doesn’t passthrough or play AAC 5.1 through S/PDIF - instead every update I see DVB fixes.

Focus on the mail features people keep bitching about - SO glad that I DIDNT get plex pass - not worth it for software that effectively has died unless you want new bug ridden features.

Think it’s time to say “tsek” to plex and move on to a server that DESERVES my money