No video output when transcoding TrueHD/DTS audio with audio passthrough enabled.



Please move this if needed. I thought I'd start with the PMS > Docker section as this problem started happening when I upgraded to 1.5.x.

PMS Server 1.5.5 using the official docker image.
Client is Nvidia Shield. Running latest version of client (no beta)

I've been able to narrow this down to the 'Audio Passthrough' setting on the client. With audio passthrough enabled and I attempt to transcode a remux with TrueHD or DTS audio the screen is black with no video output. The audio looks to passthrough to my AVR just fine and plays as it should, but no video output. If I disable 'Audio Passthrough' I get both video and audio, however the audio is PCM. Direct Play works perfrectly fine with 'Audio Passthrough' enabled, I get video and TrueHD/DTS passed through to my AVR. Once I try to transcode with audio passthrough enabled is when I run into problems.

This previously worked on 1.4.4 and I've been able to test this same file on the previous version and it works just fine.

Need some help guys.


I more than happy to provide whatever logs someone needs. I'd like to use my surround sound again. I don't see any EAE errors like the others have reported.


I'm getting a similar issue (UK-based here). Pretty poor show that there were no responses to your post, the "support" here - if it can be called that - is atrocious. I also got no responses to my first post here.

I'm using Nvidia Shield Pro 2017 and HD Homerun Connect with a good external aerial Signal strength 100%, Quality 86%, the other thing was also 100% - symbol strength or something). Everything works fine with Live Channels, HD Homerun app, Kodi.

I just bought a Plex Pass for a month but the whole experience with Plex is leaving me very cold indeed - in fact IMO it's total rubbish. Just fighting with the Live Channels was painful, even those that tune take longer than any other app. So many channels with weak signal that have progs appear at the front of the On Now section.

Then I tried recording. The channels that do record have a period of frozen video at the start. Others have a black screen, just audio same as the OP.

After the recording problems I deleted the test recordings and found that the files were deleted but the listing for them stayed in the Plex Recordings, so I restarted the Plex app to see if they went away on restart and... the whole Live TV/DVR section has disappeared!

I'm very unimpressed with this. The HD Homerun DVR feature at $35 USD a year looks a better option - I don't need to watch stuff on the go, I just want to replace Virgin Tivo and keep the wife onside.