Not able to open movies but can open other libraries on nvidia shield

server-nvidia-shield

#1

I just got my nvidia shield and had a transcode error that i never had before. It seems to be the subtitles that messed it up. But now on the shield i cant access my movie library but i can access all others. The error is fail to connect or lost connection to server.


#2

You just got it? Are you using it as just a client, or are you using it as your Plex Server as well? Do you have the most recent versions of both client and server? Go to the Google Play store on a computer and force the latest updates to the Shield TV - most of the time a brand new Shield doesn't update automatically for some reason, and forcing the update from a web browser always does the trick.


#3

As a client not a server on the Shield. Yes, plex server is up to date, ill have to check and try the client on the shield. Plex is installed on ubuntu 16.04. I get home at 1 today, ill have a follow up then when i try the force update.


#4

The force update did not work. The strange thing is that it works on my phone still. I can access all my movies.


#5

Close the Plex server application, wait one minute, restart it, then wait two minutes and restart the Shield TV. Try to play something on the Shield TV Plex app. When the problem happens, go to the Plex server settings -> help, click download logs, then upload them here along with the name of the file you tried to play.


#6

[
{
"type": "info",
"host": "localhost:32400",
"userAgent": "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.90 Safari/537.36",
"browser": {
"id": "chrome",
"name": "Chrome",
"version": "60.0",
"webkit": true,
"platform": "Linux",
"platformID": "linux",
"platformVersion": "0",
"platformModifierKey": "ctrl"
},
"version": "3.9.1",
"primaryServerUrl": "http://127.0.0.1:32400/",
"primaryServerAuthToken": true,
"username": "REMOVED",
"cloudUrl": [
{
"scheme": "https",
"address": "plex.tv",
"uri": "https://plex.tv",
"testState": "connected",
"isBundled": false,
"isFallback": false,
"relay": false,
"isPossiblyCrossNetworkProtected": false,
"isUntested": false,
"isPending": false,
"isConnected": true,
"isUnauthorized": false,
"isUnavailable": false,
"isFailed": false,
"isAborted": false,
"isLoopback": false,
"isPrivate": false,
"isHttps": true,
"isSecure": true,
"isPlexDirect": false,
"currentTest": null,
"sources": [
{
"id": "internal"
}
]
}
],
"cloudAccessToken": true
},
{
"type": "log:message",
"level": 4,
"message": "[MDE] Subtitle codec: idx",
"time": "2017-08-12T04:23:28.916Z"
},
{
"type": "log:message",
"level": 4,
"message": "[MDE] Burn level: always",
"time": "2017-08-12T04:23:28.917Z"
},
{
"type": "log:message",
"level": 1,
"message": "[MDE] Direct play failed; asked to always burn subtitles",
"time": "2017-08-12T04:23:28.917Z"
},
{
"type": "log:message",
"level": 4,
"message": "[MDE] Analyzing playability",
"time": "2017-08-12T04:23:28.917Z"
},
{
"type": "log:message",
"level": 2,
"message": "canPlay: true",
"time": "2017-08-12T04:23:28.917Z"
},
{
"type": "log:message",
"level": 2,
"message": "canDirectPlay: false",
"time": "2017-08-12T04:23:28.917Z"
},
{
"type": "log:message",
"level": 2,
"message": "canDirectStreamVideo: false",
"time": "2017-08-12T04:23:28.917Z"
},
{
"type": "log:message",
"level": 2,
"message": "canDirectStreamAudio: false",
"time": "2017-08-12T04:23:28.917Z"
},
{
"type": "log:message",
"level": 2,
"message": "useSoftSubtitles: false",
"time": "2017-08-12T04:23:28.917Z"
},
{
"type": "log:message",
"level": 2,
"message": "bitrate: 10376",
"time": "2017-08-12T04:23:28.917Z"
},
{
"type": "log:message",
"level": 2,
"message": "videoResolution: 1080",
"time": "2017-08-12T04:23:28.917Z"
},
{
"type": "log:message",
"level": 4,
"message": "[Commands] Executing persistPlayQueue",
"time": "2017-08-12T04:23:30.065Z"
},
{
"type": "log:message",
"level": 4,
"message": "[Companion Timeline] registering player. Type video",
"time": "2017-08-12T04:23:30.066Z"
},
{
"type": "log:message",
"level": 2,
"message": "[MDE] Augmented profile: {
\"directPlay\": {
\"mp4\": {
\"mimeType\": \"video/mp4; codecs=\\"avc1.42E01E\\"\",
\"video\": {
\"codecs\": {
\"h264\": {}
},
\"maxWidth\": 1920,
\"maxHeight\": 1280,
\"maxFrameRate\": 60
},
\"audio\": {
\"codecs\": {
\"aac\": {},
\"ac3\": {}
}
}
},
\"mkv\": {
\"mimeType\": \"video/webm\",
\"video\": {
\"codecs\": {
\"vp8\": {}
},
\"maxWidth\": 1920,
\"maxHeight\": 1280,
\"maxFrameRate\": 60
},
\"audio\": {
\"codecs\": {
\"vorbis\": {}
}
}
},
\"ogg\": {
\"mimeType\": \"video/ogg\",
\"video\": {
\"maxWidth\": 1920,
\"maxHeight\": 1280,
\"maxFrameRate\": 60
}
},
\"mpegts\": {
\"protocol\": \"hls\",
\"video\": {
\"maxWidth\": 1920,
\"maxHeight\": 1280,
\"maxFrameRate\": 60
}
},
\"flv\": {
\"video\": {
\"maxWidth\": 1920,
\"maxHeight\": 1280,
\"maxFrameRate\": 60
}
}
},
\"directStream\": {
\"video\": {
\"codecs\": {
\"h264\": {}
},
\"maxWidth\": 1920,
\"maxHeight\": 1280,
\"maxBitDepth\": 8
},
\"audio\": {
\"codecs\": {
\"aac\": {}
},
\"maxBitrate\": 192,
\"maxChannels\": 2
}
}
}",
"time": "2017-08-12T04:23:30.068Z"
},


#7

Also, this is what i get when trying the movie library on the shield and android tv.

But everything works on the phone and via the web. And accessing tv on shield and tv is fine and works perfect


#8

https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files


#9

do you need all of them?


#10

here are some logs


#11

Zip up all the logs and attach them.


#12

all zipped


#13

Please turn off verbose logging and then repeat the steps I outlined above. The logs get filled up too quickly with unnecessary information.


#14

verbose off logs, Thank you for all your help


#15

The logs are still showing verbose logging. After you disable verbose logging you have to restart your Plex Server and repeat the steps I posted here: https://forums.plex.tv/discussion/comment/1495891/#Comment_1495891.


#16

ok, the log file is smaller hope it worked


#17

First thing - your file naming is terrible. You need to fix that pronto. You can use Filebot to rename all of your media so that it follows the Plex naming convention. My signature contains a link to the naming convention.

Are you positive you disabled verbose logging? Your log is still full of verbose logging. Open a web browser, go to your Plex page, click on the settings icon, switch to the server tab, and under general options remove the checkbox next to Enable Plex Media Server verbose logging. Then, click the save button. Restart the Plex server and reaccomplish the steps I posted earlier.


#18

ops, turned it off under web not server. Yeah, I have been meaning to fix the names, I'll do that this weekend.


#19

What's the name of the file you tried to play?


#20

Its the whole movie library that will not show up on the Shield and android tv. But all is good on my phome and via the web.