Not Working

sonos

#6

I am having the same issue. I can get the song to the queue but then it can't play and can't connect to plex.


#7

Same issue over here. I can queue the song, but it won't play. The songs are playing correctly through the Plex webinterface, so it's not the song that is making trouble :)


#8

Exactly the same here, seems fine via web interface, looks fine in sonos, but all songs fail with the warning:

_"Unable to play '<>' - Unable to connect to Plex." _


#9

btw, delighted this connection now seems close, been waiting for a way around Sonos ancient file number limit....


#10

Same same. I can browse my library, queue up songs, and then... no dice. One after another, through the whole album or playlist, I get a repeated message that it can't connect to the Plex server. The same songs play fine, from the same location, over DLNA.

If it matters, I'm set up with Plex server on a PC, but files hosted on a NAS that is mapped as a drive.


#11

@aseradyn said:
Same same. I can browse my library, queue up songs, and then... no dice. One after another, through the whole album or playlist, I get a repeated message that it can't connect to the Plex server. The same songs play fine, from the same location, over DLNA.

If it matters, I'm set up with Plex server on a PC, but files hosted on a NAS that is mapped as a drive.

Same setup here and the same experience. No actual playback.


#12

Same problem. Can browse, but when it plays either I get no audio at all and it just keeps "chugging along" without any sound or I get the "can't connect to server" message.

Now, Plex or Sonos problem?

EDIT: Should add the whole Plex stuff is on a QNAP, no problem using the Sonos controller to play music via the network share.


#13

Same. Connects to sonos, browse library but cannot play. I'll be excited when it does work.


#14

Same problem. Again, great to get this in the features. Hope it works soon. will monitor to see if anyone actually gets it working and how!


#15

Yet again Plex, you make me do more troubleshooting, I'm beginning to find out my life is based around troubleshooting... similar situation for me, i can navigate the library and it comes up as a device on my server but no playback :( but we are on day one... i will try and see if i can find a work around, but the Plex/Sonos guys must have got it working otherwise they wouldn't have posted that lovely email update.


#16

I quickly set this up this morning and had no issues getting playback to work, but my music collection and Plex server are on the same OpenMediaVault box.


#17

Hi, I had the same problem of 'can't connect to server'. Switched the remote access to use a Manual specific port, added the port forward in my router and everything started working. I am on my home network. Maybe this will help people get connected.

Love Plex and love Sonos. So happy :-)


#18

my music server and plex are on the same Drobo


#19

thesigg, your solution worked for me. Thank you.


#20

@thesigg said:
Hi, I had the same problem of 'can't connect to server'. Switched the remote access to use a Manual specific port, added
the port forward in my router and everything started working. I am on my home network. Maybe this will help people get
connected.

as thesigg said, i have a manual port set in remote access of the plex settings, then set up port forwarding on my router (as well as mac-serversing the relevant IP no.)

And it now works!

I use a virgin media hub 3.0 and this page helped me with setting that up

http://community.virginmedia.com/t5/Forum-Archive/Plex-issues/td-p/2843392

thanks to all!

Love Plex and love Sonos. So happy :-)


#21

@thesigg said:
Hi, I had the same problem of 'can't connect to server'. Switched the remote access to use a Manual specific port, added the port forward in my router and everything started working. I am on my home network. Maybe this will help people get connected.

Love Plex and love Sonos. So happy :-)

Already use the 'Remote Access' setup, family can stream movies, series and music from my Plex without any issues....


#22

I, too, was already set up with manual port, with ports forwarded on the router, and can stream from Plex to off-site locations (work, etc).

I ran today's update for Plex server, and checked for updates to the Sonos app and speakers - no improvement.


#23

Have the same problem.. I can search and select songs but they won't actually play unfortunately. Hopefully they can get it working soon, seems like a cool feature.


#24

My brother shared a music library with me, and I can play music on my Sonos system from his Plex server three states away without any trouble. So, there's something specific to my server/network.

Just for giggles, I took a look at the Plex Media Server.log, even though I have only the fuzziest idea what it's doing. When I connect through the Plex app on Android, I can see a bazillion transactions where it's downloading the mp3 in pieces. But when I try to play a song through Sonos, I get none of that.

Here's the log from when I hit play in Sonos until it is disconnected again because it went inactive:

! Jul 21, 2016 21:48:05.273 [29888] DEBUG - NetworkServiceBrowser: PLAYER arrived: 192.168.254.1
! Jul 21, 2016 21:48:08.076 [24692] DEBUG - Request: [::ffff:198.58.98.77:61402] GET /library/sections?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Client-Identifier=5C-AA-FD-C0-2B-F2:G&X-Plex-Device-Name=Sonos (6 live) TLS
! Jul 21, 2016 21:48:08.076 [24692] VERBOSE - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
! Jul 21, 2016 21:48:08.076 [24692] VERBOSE - * X-Plex-Client-Identifier => 5C-AA-FD-C0-2B-F2:G
! Jul 21, 2016 21:48:08.076 [24692] VERBOSE - * X-Plex-Device-Name => Sonos
! Jul 21, 2016 21:48:08.077 [24692] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
! Jul 21, 2016 21:48:08.077 [24692] DEBUG - Auth: authenticated user 1 as aseradyn
! Jul 21, 2016 21:48:08.077 [24692] DEBUG - Auth: Came in with a super-token, authorization succeeded.
! Jul 21, 2016 21:48:08.079 [24692] DEBUG - It took 0.0 sec to serialize a list with 8 elements.
! Jul 21, 2016 21:48:08.079 [31344] DEBUG - Request: [::ffff:198.58.98.77:61406] GET /library/sections?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Client-Identifier=5C-AA-FD-C0-2B-F2:G&X-Plex-Device-Name=Sonos (6 live) TLS
! Jul 21, 2016 21:48:08.079 [31344] VERBOSE - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
! Jul 21, 2016 21:48:08.079 [31344] VERBOSE - * X-Plex-Client-Identifier => 5C-AA-FD-C0-2B-F2:G
! Jul 21, 2016 21:48:08.079 [31344] VERBOSE - * X-Plex-Device-Name => Sonos
! Jul 21, 2016 21:48:08.080 [30920] DEBUG - Completed: [::ffff:198.58.98.77:61402] 200 GET /library/sections (6 live) TLS 4ms 4207 bytes
! Jul 21, 2016 21:48:08.080 [31344] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
! Jul 21, 2016 21:48:08.080 [31344] DEBUG - Auth: authenticated user 1 as aseradyn
! Jul 21, 2016 21:48:08.080 [31344] DEBUG - Auth: Came in with a super-token, authorization succeeded.
! Jul 21, 2016 21:48:08.082 [31344] DEBUG - It took 0.0 sec to serialize a list with 8 elements.
! Jul 21, 2016 21:48:08.083 [30920] DEBUG - Completed: [::ffff:198.58.98.77:61406] 200 GET /library/sections (6 live) TLS 3ms 4207 bytes
! Jul 21, 2016 21:48:08.120 [30860] DEBUG - Request: [::ffff:198.58.109.216:22180] GET /library/sections?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Client-Identifier=5C-AA-FD-C0-2B-F2:G&X-Plex-Device-Name=Sonos (6 live) TLS
! Jul 21, 2016 21:48:08.120 [30860] VERBOSE - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
! Jul 21, 2016 21:48:08.120 [30860] VERBOSE - * X-Plex-Client-Identifier => 5C-AA-FD-C0-2B-F2:G
! Jul 21, 2016 21:48:08.120 [30860] VERBOSE - * X-Plex-Device-Name => Sonos
! Jul 21, 2016 21:48:08.121 [30860] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
! Jul 21, 2016 21:48:08.121 [30860] DEBUG - Auth: authenticated user 1 as aseradyn
! Jul 21, 2016 21:48:08.121 [30860] DEBUG - Auth: Came in with a super-token, authorization succeeded.
! Jul 21, 2016 21:48:08.123 [30860] DEBUG - It took 0.0 sec to serialize a list with 8 elements.
! Jul 21, 2016 21:48:08.124 [33604] DEBUG - Completed: [::ffff:198.58.109.216:22180] 200 GET /library/sections (6 live) TLS 4ms 4207 bytes
! Jul 21, 2016 21:48:08.272 [24692] DEBUG - Request: [::ffff:198.58.98.77:61408] GET /library/sections?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Client-Identifier=5C-AA-FD-C0-2B-F2:G&X-Plex-Device-Name=Sonos (4 live) TLS
! Jul 21, 2016 21:48:08.272 [24692] VERBOSE - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
! Jul 21, 2016 21:48:08.273 [24692] VERBOSE - * X-Plex-Client-Identifier => 5C-AA-FD-C0-2B-F2:G
! Jul 21, 2016 21:48:08.273 [24692] VERBOSE - * X-Plex-Device-Name => Sonos
! Jul 21, 2016 21:48:08.273 [24692] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
! Jul 21, 2016 21:48:08.273 [24692] DEBUG - Auth: authenticated user 1 as aseradyn
! Jul 21, 2016 21:48:08.273 [24692] DEBUG - Auth: Came in with a super-token, authorization succeeded.
! Jul 21, 2016 21:48:08.273 [24692] DEBUG - It took 0.0 sec to serialize a list with 8 elements.
! Jul 21, 2016 21:48:08.273 [33604] DEBUG - Completed: [::ffff:198.58.98.77:61408] 200 GET /library/sections (4 live) TLS 4ms 4207 bytes
! Jul 21, 2016 21:48:08.343 [31344] DEBUG - Request: [::ffff:198.58.98.77:61410] GET /library/sections?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Client-Identifier=5C-AA-FD-C0-2B-F2:G&X-Plex-Device-Name=Sonos (6 live) TLS
! Jul 21, 2016 21:48:08.343 [31344] VERBOSE - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
! Jul 21, 2016 21:48:08.343 [31344] VERBOSE - * X-Plex-Client-Identifier => 5C-AA-FD-C0-2B-F2:G
! Jul 21, 2016 21:48:08.343 [31344] VERBOSE - * X-Plex-Device-Name => Sonos
! Jul 21, 2016 21:48:08.343 [31344] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
! Jul 21, 2016 21:48:08.343 [31344] DEBUG - Auth: authenticated user 1 as aseradyn
! Jul 21, 2016 21:48:08.343 [31344] DEBUG - Auth: Came in with a super-token, authorization succeeded.
! Jul 21, 2016 21:48:08.343 [31344] DEBUG - It took 0.0 sec to serialize a list with 8 elements.
! Jul 21, 2016 21:48:08.363 [30920] DEBUG - Completed: [::ffff:198.58.98.77:61410] 200 GET /library/sections (7 live) TLS 28ms 4207 bytes
! Jul 21, 2016 21:48:08.603 [30860] DEBUG - Request: [::ffff:198.58.98.77:61418] GET /library/metadata/17236?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Client-Identifier=5C-AA-FD-C0-2B-F2:G&X-Plex-Device-Name=Sonos (7 live) TLS
! Jul 21, 2016 21:48:08.603 [30860] VERBOSE - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
! Jul 21, 2016 21:48:08.603 [30860] VERBOSE - * X-Plex-Client-Identifier => 5C-AA-FD-C0-2B-F2:G
! Jul 21, 2016 21:48:08.603 [30860] VERBOSE - * X-Plex-Device-Name => Sonos
! Jul 21, 2016 21:48:08.603 [30860] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
! Jul 21, 2016 21:48:08.603 [30860] DEBUG - Auth: authenticated user 1 as aseradyn
! Jul 21, 2016 21:48:08.603 [30860] DEBUG - Auth: Came in with a super-token, authorization succeeded.
! Jul 21, 2016 21:48:08.619 [24692] DEBUG - Request: [::ffff:198.58.98.77:61420] GET /library/metadata/17236?includeRelated=1&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Client-Identifier=5C-AA-FD-C0-2B-F2:G&X-Plex-Device-Name=Sonos (6 live) TLS
! Jul 21, 2016 21:48:08.620 [24692] VERBOSE - * includeRelated => 1
! Jul 21, 2016 21:48:08.620 [24692] VERBOSE - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
! Jul 21, 2016 21:48:08.620 [24692] VERBOSE - * X-Plex-Client-Identifier => 5C-AA-FD-C0-2B-F2:G
! Jul 21, 2016 21:48:08.620 [24692] VERBOSE - * X-Plex-Device-Name => Sonos
! Jul 21, 2016 21:48:08.621 [24692] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
! Jul 21, 2016 21:48:08.621 [24692] DEBUG - Auth: authenticated user 1 as aseradyn
! Jul 21, 2016 21:48:08.621 [24692] DEBUG - Auth: Came in with a super-token, authorization succeeded.
! Jul 21, 2016 21:48:08.622 [30860] DEBUG - We're going to try to auto-select an audio stream for account 1.
! Jul 21, 2016 21:48:08.622 [30860] DEBUG - Selecting best audio stream for part ID 23179 (autoselect: 0 language: en)
! Jul 21, 2016 21:48:08.623 [30860] DEBUG - Audio Stream: 36507, Subtitle Stream: -1
! Jul 21, 2016 21:48:08.623 [30860] DEBUG - It took 0.0 sec to serialize a list with 1 elements.
! Jul 21, 2016 21:48:08.625 [30920] DEBUG - Completed: [::ffff:198.58.98.77:61418] 200 GET /library/metadata/17236 (6 live) TLS 12ms 2077 bytes
! Jul 21, 2016 21:48:08.628 [24692] DEBUG - We're going to try to auto-select an audio stream for account 1.
! Jul 21, 2016 21:48:08.629 [24692] DEBUG - Selecting best audio stream for part ID 23179 (autoselect: 0 language: en)
! Jul 21, 2016 21:48:08.629 [24692] DEBUG - Audio Stream: 36507, Subtitle Stream: -1
! Jul 21, 2016 21:48:08.629 [24692] DEBUG - It took 0.0 sec to serialize a list with 1 elements.
! Jul 21, 2016 21:48:08.631 [30920] DEBUG - Completed: [::ffff:198.58.98.77:61420] 200 GET /library/metadata/17236?includeRelated=1 (6 live) TLS 12ms 2191 bytes
! Jul 21, 2016 21:48:08.643 [31344] DEBUG - Request: [::ffff:198.58.98.77:61424] GET /library/metadata/17236?includeRelated=1&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Client-Identifier=5C-AA-FD-C0-2B-F2:G&X-Plex-Device-Name=Sonos (6 live) TLS
! Jul 21, 2016 21:48:08.643 [31344] VERBOSE - * includeRelated => 1
! Jul 21, 2016 21:48:08.643 [31344] VERBOSE - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
! Jul 21, 2016 21:48:08.643 [31344] VERBOSE - * X-Plex-Client-Identifier => 5C-AA-FD-C0-2B-F2:G
! Jul 21, 2016 21:48:08.643 [31344] VERBOSE - * X-Plex-Device-Name => Sonos
! Jul 21, 2016 21:48:08.659 [31344] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
! Jul 21, 2016 21:48:08.659 [31344] DEBUG - Auth: authenticated user 1 as aseradyn
! Jul 21, 2016 21:48:08.660 [31344] DEBUG - Auth: Came in with a super-token, authorization succeeded.
! Jul 21, 2016 21:48:08.667 [31344] DEBUG - We're going to try to auto-select an audio stream for account 1.
! Jul 21, 2016 21:48:08.667 [31344] DEBUG - Selecting best audio stream for part ID 23179 (autoselect: 0 language: en)
! Jul 21, 2016 21:48:08.668 [31344] DEBUG - Audio Stream: 36507, Subtitle Stream: -1
! Jul 21, 2016 21:48:08.667 [30860] DEBUG - Request: [::ffff:198.58.98.77:61422] GET /library/metadata/17236?includeRelated=1&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Client-Identifier=5C-AA-FD-C0-2B-F2:G&X-Plex-Device-Name=Sonos (6 live) TLS
! Jul 21, 2016 21:48:08.668 [30860] VERBOSE - * includeRelated => 1
! Jul 21, 2016 21:48:08.668 [31344] DEBUG - It took 0.0 sec to serialize a list with 1 elements.
! Jul 21, 2016 21:48:08.668 [30860] VERBOSE - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
! Jul 21, 2016 21:48:08.669 [30860] VERBOSE - * X-Plex-Client-Identifier => 5C-AA-FD-C0-2B-F2:G
! Jul 21, 2016 21:48:08.669 [30860] VERBOSE - * X-Plex-Device-Name => Sonos
! Jul 21, 2016 21:48:08.670 [30860] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
! Jul 21, 2016 21:48:08.670 [33604] DEBUG - Completed: [::ffff:198.58.98.77:61424] 200 GET /library/metadata/17236?includeRelated=1 (6 live) TLS 12ms 2191 bytes
! Jul 21, 2016 21:48:08.670 [30860] DEBUG - Auth: authenticated user 1 as aseradyn
! Jul 21, 2016 21:48:08.670 [30860] DEBUG - Auth: Came in with a super-token, authorization succeeded.
! Jul 21, 2016 21:48:08.677 [30860] DEBUG - We're going to try to auto-select an audio stream for account 1.
! Jul 21, 2016 21:48:08.677 [30860] DEBUG - Selecting best audio stream for part ID 23179 (autoselect: 0 language: en)
! Jul 21, 2016 21:48:08.677 [30860] DEBUG - Audio Stream: 36507, Subtitle Stream: -1
! Jul 21, 2016 21:48:08.678 [30860] DEBUG - It took 0.0 sec to serialize a list with 1 elements.
! Jul 21, 2016 21:48:08.680 [30920] DEBUG - Completed: [::ffff:198.58.98.77:61422] 200 GET /library/metadata/17236?includeRelated=1 (6 live) TLS 12ms 2191 bytes
! Jul 21, 2016 21:48:08.737 [24692] DEBUG - Request: [::ffff:198.58.109.216:22184] GET /library/metadata/10626?includeRelated=1&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Client-Identifier=5C-AA-FD-C0-2B-F2:G&X-Plex-Device-Name=Sonos (4 live) TLS
! Jul 21, 2016 21:48:08.737 [24692] VERBOSE - * includeRelated => 1
! Jul 21, 2016 21:48:08.738 [24692] VERBOSE - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
! Jul 21, 2016 21:48:08.738 [24692] VERBOSE - * X-Plex-Client-Identifier => 5C-AA-FD-C0-2B-F2:G
! Jul 21, 2016 21:48:08.738 [24692] VERBOSE - * X-Plex-Device-Name => Sonos
! Jul 21, 2016 21:48:08.739 [24692] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
! Jul 21, 2016 21:48:08.739 [24692] DEBUG - Auth: authenticated user 1 as aseradyn
! Jul 21, 2016 21:48:08.739 [24692] DEBUG - Auth: Came in with a super-token, authorization succeeded.
! Jul 21, 2016 21:48:08.750 [24692] DEBUG - It took 0.0 sec to serialize a list with 1 elements.
! Jul 21, 2016 21:48:08.751 [30920] DEBUG - Completed: [::ffff:198.58.109.216:22184] 200 GET /library/metadata/10626?includeRelated=1 (4 live) TLS 14ms 1993 bytes
! Jul 21, 2016 21:51:12.204 [29888] DEBUG - NetworkServiceBrowser: PLAYER departed after not being seen for 181.981518 seconds: 192.168.254.1

It looks like it's asking for library and metadata info. Somehow, the request for the mp3 file itself seems to go astray.

I'm rather at a loss for how to fix this. For the record, here's some other things that I've checked/tried:
* Port is set manually in Plex server and forwarded through the router; Plex server reports it is fully available outside my network (and I can stream from Plex on my phone over cellular data and from my work PC)
* My uplink does not appear to be saturated when I try to play songs (just based on the Performance monitor in Win10; I can drive it much higher by running an off-site backup)
* I have plenty of download capacity, as I can stream music flawlessly to Sonos from other Plex servers
* Created a temp music library with just a couple of albums on the PC running Plex server, and it has the same problem. So, probably not the NAS
* Turned off Windows Firewall (no other firewall installed at present)
* Restarted Plex server
* Rebooted the PC running Plex server
* Rebooted the phone
* Rebooted the Sonos speakers
* Checked for updates to Plex server and Sonos (app and speakers)
* Installed the Sonos desktop client; same problem as the Android app
* Turned on support for IPv6 and DLNA server (what the hell, I'm running out of ideas, so just try everything)

Ideas? See anything obvious I've forgotten to try?


#25

Just noticed since Ive added plex and get the error, the same error is now occurring on my Spotify premium service as well.
:(