Nvidia Shield with 7.1, atmos and other HD Audio formats?

server-nvidia-shield

#1

Hi,

I bought a Samsung KS8000. Along with a Yamaha atmos receiver. I was really shocked to find that I couldn't play atmos files through PLEX, or worse...even 7.1 files. I didn't realise the limitation of the optical cable. Combine this with the Samsung DTS issue, and I've started to look at other options. Which brought me to the Shield.

I have searched the NVIDIA Shield section of these forums but only get conflicting information. I would hope just to get a simple answer...

Q: Using my local home network (with my PC acting as a server), can the NVIDIA Shield TV play atmos, 7.1 and more via plex - when directly connected to my AV Receiver (which supports all those formats) via a HDMI cable? Are there currently any bugs or issues to know about.

Thank you!


#2

Shield TV Pro (2017) --HDMI--> Denon 4300H --HDMI --> Samsung 55F7100 (1080p)

No issues playing any Dolby or DTS formats, 5.1 & 7.1, including TrueHD/Atmos and DTS-HD, -HD MA, :X (anything you would find on a DVD or Blu-ray).

PMS 1.8.0 on Windows 10 and Shield TV Pro.
Plex 6.4 client on Shield TV Pro.
Denon configured for 5.1.2.

Note that I'm running Plex Pass versions. However, I had no problems when running what are now the public versions. I've had my Shield TV for about six months. Never had issues bitstreaming audio from a movie ripped from a DVD or Blu-ray disc. I've a couple of downloaded videos with Vorbis audio. Those transcode, but the CPU hit is minimal.


#3

Yes, nVidia Shield w/ HDMI supports passthrough audio. TrueHD 7.1, Atmos, and DTS-HD MA all play properly on my nVidia Shield w/ Plex and Kodi.


#4

Yes, nVidia Shield w/ HDMI supports passthrough audio. TrueHD 7.1, Atmos, and DTS-HD MA all play properly on my nVidia Shield w/ Plex and Kodi.


#5

Thanks guys,


#6

I experienced the same as you. It wasn't the Shield, it was my receiver.

I adjusted my audio settings and set my renderer to legacy.

I also had to adjust my video setting to chroma output 4:4:4 to be able to setup my Shield settings to 4:4:4. My receiver's default setting was 4:2:2.