Osmosys DMS DLNA Profile



I'm trying to send my recordings from phone and camera via plex media server to the digicorder, not get the recordings from the digicorder on the tv because those seem to be encrypted/protected somehow, i'll need to download one and run it through some software to see if it's just a funky codec or really protected/restricted with some extra layer on top of dlna, like the hdcp or something.

But that doesn't solve the problem of streaming towards the digicorder and use it as a player. So the "playing in mediaplayer" part of my post was about content served by PMS.


My Telenet decoder seems to play several movies and shows using the generic dlna profile, but I want to add transcoding for the other formats (where for example audio is not included or the screen stays black) and to embed subtitles. Trying to write a custom profile is only resulting in error messages in Yelo.

Anyone having better luck? 


You need a decoder ring.








Something with h264 as a video codec.

◾MPEG-4 Part2

Something with mpeg4 as a video codec.


Something with mpeg1video as a video codec.


Something with mpeg4 as a video codec.


EDIT: I'm sure more stuff is supported for DirectPlay. I'm just translating what's in the list above.

I should also note that using mpegts/h264/ac3 as a transcode target is far more likely to end well than avi/whatever.


Thanks mfeingol.

I've created this XML piece below:


This maps to Yelo:

DEBUG - Mapped client to profile Yelo using header User-Agent: L21XTLNDGRD/v4.11-rc-356-g90f6124 UPnP/1.0 BH-upnpcp/2.0 DLNADOC/1.50

You'll see I've been experimenting with several TranscodeTargets. At first glance all seem to work. However, I don't think any transcoding is actually happening:

  • Same videos as when using the generic profile still don't have audio 

  • My subtitles are not shown 

  • I can remove all VideoProfile lines under TranscodeTargets and still get a video...

So I actually get the same result as the generic profile...

What am I doing wrong here?


Hey Tonysteiner,

Did you get the profile working?


No success. Still hoping someone with more skills than me wants to achieve this...


Hey Tonysteiner,

I got audio / subtitle transcoding working.

You can find my profile here : https://github.com/neher/yelotv-plex-profile/blob/master/yelotv.xml

If you find something that does not work, please let me know.

I did not test all combinations :)

Just very excited i got it working!


Hi there,

Just tried your profile. I have audio as now, but I don't get any subtitle transcoding. The files I tried are .mp4 and .srt.

Let me know if you need more information.

Many thanks!


Could it be this file is using a direct play profile?

I haven't figured out yet how to get the subtitles working with direct play profiles.

If you use a transcoding profile, the subtitles are embedded in the stream.

You can adjust the size of the subtitles with :   


100 being the default, 500 being 5 times bigger.

You can force transcoding by removing all the videoprofiles in the direct play profiles :


Don't remove the DirectPlayProfiles xml-tag.

It is mandatory.


Yep, that's it! Thanks!


There's one more thing... I can't fast forward. Any ideas? 


There's one more thing... I can't fast forward. Any ideas? 

Works great, i've been waiting for this profile.



Same problem here.. Is there a possibility to fix this with a new profile?


There's one more thing... I can't fast forward. Any ideas? 

I have the same problem too.

Only x2 is working partially.

I thought it was because my server couldn't transcode faster :)


It's definitely not a limitation of my server.

My mac mini 2011 is only using 2% cpu while transcoding a 720p tv show.

I tried a lot of x264 encoding options (https://forum.handbrake.fr/viewtopic.php?f=6&t=19426) to fix the fast forwarding problem.

But no luck so far.


Pause doesn't work either :( any ideas?


Pause, fast forward and rewind don't seem to work with transcoding.

It does work however with DirectPlay Profiles (so without transcoding).

But Direct play only support native formats of the digibox.


Did anyone make any progress?


Hi guys,

I tried copying the above profile to this folder on my Qnap NAS

But now the settopbox DB-AD210 gives a technical error message and doesn't play anything at all.
Did you make any changes to the profile?

Edit: I also have the "black" AD2100 model which does work. Also 2x FF works. Pause en rewind don't.

Here is a list of Telenet's available settop boxes http://klantenservice.telenet.be/content/installatiegidsen-en-handleidingen

PS: you can use UPnP-Inspector to browse your Digicorder.


Any progress in the last 3 years?