Panasonic VT30 DLNA Profile

server-dlna

#1

I'm planning to to a profile for the Panasonic VT30. I will post it here eventually, but out of curiosity is anyone else here with a VT30 who is interested in the profile?



About the profile now

First I tested all sorts of videos I have and made notes which work and which don't. Then I checked the xml files which plex server gives to plex clients (localhost:32400) to see the container, codec, etc.



And this just confuses me

This works just fine:

[quote]
bitrate="3000" width="1920" height="1080" aspectRatio="1.78" audioChannels="6" audioCodec="dca" videoCodec="h264" videoResolution="1080" container="mkv" videoFrameRate="24p"

[/quote]




but these seems to be supported by the TV but it crashes/freezes/whatevers


[quote]
bitrate="2500" width="1920" height="1080" aspectRatio="1.78" audioChannels="6" audioCodec="ac3" videoCodec="h264" videoResolution="1080" container="mkv" videoFrameRate="24p"

bitrate="2250" width="1920" height="1080" aspectRatio="1.78" audioChannels="6" audioCodec="dca" videoCodec="h264" videoResolution="1080" container="mkv" videoFrameRate="24p"

[/quote]




it can't be the bitrate because the first one has 3000 and works just fine

Any idea on what I could check to see where the problem is?


#2

I don't know the Panasonic at all, but there are H.264 parameters not captured by that XML that players sometimes balk at. For example, the Panasonic might have a maximum H.264 level that it supports, or a maximum number of ReFrames. It might be worth using MediaInfo to get a more complete look at the files and spot differences.


#3

Thanks, Header Stripping it was.

I used mktvtoolnix to remux first broken one with everything the same besides Header Stripping

btw. it is High@L5.1 and CABAC /2 Ref Frames





Any way to do on the fly remuxing for mkv with header stripping? I will just remux my files, but for others it might be useful to do that on the fly.



update:

I found another broken file with this xml stats:

[quote]
bitrate="2421" width="1280" height="720" aspectRatio="1.78" audioChannels="2" audioCodec="aac" videoCodec="h264" videoResolution="720" container="mp4" videoFrameRate="24p"

[/quote]




those stats look good, but it doesn't start, it is High@L4.1 and CABAC / 3 Ref Frames





another mkv has High 10@L5.0 and CABAC / 12 Ref Frames that one stutters so it's either the High 10 or the 12 ref frames or a combination of those. any chance to do on the fly conversation via profile?



anther broken one has AAC (HE-AAC /LC) other working similar files have AAC (LC) so that might be another thing to blacklist somehow...







I just tried to transcode some stuff to "" but that didn't work. I found that in logs it says it uses this command "~/Applications/Plex Media Server.app/Contents/Resources/Plex Transcoder -i http://192.168.0.100:32400/library/parts/4023/file.avi -async 1 -f mkv -vcodec libx264 -b 4000k -acodec ac3 -ar 48000 -s 640x480 -threads 0 -re -rebuf 10 - "



when I tried that with an output file it says " Requested output format 'mkv' is not a suitable output format" after googling that I found one would have to use -f matroska. I tried that it worked just fine so I changed the profile to this "" but the TV didn't understand that at all.


#4

I'd definitely be interested for the VT30 profile. I have a couple of Panasonic VT30 TVs in my house. I use a ReadyNAS. A lot of the mkv files work but some don't. Surprisingly, some downloaded TV shows like How I Met Your Mother and Modern Family don't work. I could get the details from those files if someone could tell me how to do so.



Thanks in advance for the work you're putting in for the profile. Hope to see it soon.


#5

You have a couple of VT30? Are you rich or something? :D



Get the app MediaInfo and open you video file with that app, it will show you a bunch of information.



Just give me a few of them and tell me if they are working or not.



About mkv not playing, I assume if MediaInfo says "Header Stripping" somewhere, the VT30 will not play it. If it does I'm wrong and would love to see the info for that file.

Also if a mkv is playing fine and the video codec says something else than h264 I would love to see that too.



And of course infos about all obscure formats you might have.


#6

Something we intend to do in the future is get more information about certain audio/video attributes. h264 CABAC, refFrames, and aac levels are all on that list.



Once we have that in metadata, we'll be able to enhance the DLNA profiles with more opinions about content. My suggestion for now is to limp along with what we have, and write aspirational comments in the profile concerning what we'd like to have. That will allow us to (1) focus future work in PMS to satisfy the scenario, and (2) leave breadcrumbs to update the profile when the facilities in question are available in PMS.



Does that make sense? If so, please add the profile to the "working profiles" thread when it's as good as it can possibly be, and we'll include it in the next PMS release.



(As an aside, transcoding to streamed mkv isn't going to work. The current supported transcode container formats are documented in the profile sticky thread.)


#7

Oh, well. I just tried all supported transcode targets (avi, mpegts and asf) none of them seem to be supported on the VT 30.

so at the moment there is nothing I can do to get this to work. :(

Hope the next beta will be there soon.


#8

That's unfortunate. Does the VT30 play those containers in general? What do other DLNA players do with this device? You might try mp4 as well...


#9

I tried mp4 with h264 and aac as a target now, the TV says it's not supported. But I have mp4 files with h264 and aac which work just fine with direct play. :/


#10

MP4 streamed from PMS has some interesting nuances over standard MP4, so it's not surprising that not everyone likes it.



I'm disappointed none of the other containers work, though. What does the VT30 actually play, in general?


#11

[quote name='Diskutant' timestamp='1334648930' post='256304']


You have a couple of VT30? Are you rich or something? :D



Get the app MediaInfo and open you video file with that app, it will show you a bunch of information.



Just give me a few of them and tell me if they are working or not.



About mkv not playing, I assume if MediaInfo says "Header Stripping" somewhere, the VT30 will not play it. If it does I'm wrong and would love to see the info for that file.

Also if a mkv is playing fine and the video codec says something else than h264 I would love to see that too.



And of course infos about all obscure formats you might have.

[/quote]


Hi,



I'm attaching 2 files, one named 'not working.txt' which contains the details of files that are not working on the VT30. The other named 'working.txt' which contains details of the files working on the VT30. A lot of types open, avi's, mkv's do open, but some don't work. I think mp4's don't work in general on the VT30. Hope someone gets a profile for the VT30 soon. Willing to contribute in anyway for a working profile for the VT30.


#12

I'm interested in this. I have a GT30 but I assume the supported codecs are the same.


#13

[quote name='mfeingol' timestamp='1334977764' post='257612']


What do other DLNA players do with this device?

[/quote]




This is a serviio profile for the Viera TV's. Any ideas on how to translate it to Plex's profile format? I'm confused about how to specify what will be remuxed and what will be transcoded.



http://forum.serviio.org/viewtopic.php?f=7&t=5091


#14

I have an ST30 and am interested in the profile. I will donate any media file info to help.


#15

For now I can't get any transcoding target to work. Until one/me finds a working option or Plex updates their Server to support more targets there isn't much I can do.

But still keep a list of everything working and not working so I should be able to release a first version soon after we have an option that works.


#16

[quote name='Diskutant' timestamp='1334340777' post='255329']


... out of curiosity is anyone else here with a VT30 who is interested in the profile?

[/quote]




Hello



I have a VT30 and would love a dlna profile for it. I have a very broad range of file types/formats etc that I would be able to test if that is of any help.



Thanks for your work on this!


#17

Any chance you could post what little working Panasonic-profile you have now? :)


#18

[quote name='mnister' timestamp='1335684767' post='259698']


Any chance you could post what little working Panasonic-profile you have now? :)

[/quote]




well...


[quote name='Diskutant' timestamp='1335557594' post='259454']


For now I can't get any transcoding target to work. Until one/me finds a working option or Plex updates their Server to support more targets there isn't much I can do.

[/quote]




;-)


#19

[quote name='Diskutant' timestamp='1334968355' post='257594']


Oh, well. I just tried all supported transcode targets (avi, mpegts and asf) none of them seem to be supported on the VT 30.

so at the moment there is nothing I can do to get this to work. :(

Hope the next beta will be there soon.

[/quote]


I have no Panasonic but I was bored and googled a bit and read on a German website that some guy with a VT30 could watch TS streams over DLNA flawlessly. I suppose this means MPEGTS, not sure though. Have you really tried out all possible video- & audio codec combinations with MPEGTS as the container as transcode target? This one, according to Serviio, should work:



                <TranscodeTargets><br />
                        <VideoProfile container="mpegts" codec="mpeg2video" audioCodec="ac3" /><br />
                        <PhotoProfile codec="jpeg" /><br />
                </TranscodeTargets><br />






Please post your Plex DLNA Server.log & your complete dlnaclientprofiles.xml after you’ve tried it out.


#20

Oh wow, you are right, it worked! I really thought I tried that already, maybe I had a typo or wrong audio Codec or something. Well it finally works now. :)



We still have some problems though, like HE-AAC which isn't supported, but plex makes no difference between HE-AAC and AAC



So here is the first version of my profile:



<Clients><br />
  <Client name="Panasonic TX-P55VT30"><br />
    <Identification><br />
      <Header name="User-Agent" substring="Panasonic MIL DLNA CP UPnP/1.0 DLNADOC/1.50" /><br />
    </Identification><br />
    <TranscodeTargets><br />
      <VideoProfile container="mpegts" codec="mpeg2video" audioCodec="ac3" /><br />
      <PhotoProfile codec="png" /><br />
    </TranscodeTargets><br />
    <Settings><br />
      <Setting name="OnlyPlainVideoItems" value="false" /><br />
      <Setting name="OnlyStorageFolders" value="false" /><br />
      <!--untested settings follow --><br />
      <Setting name="TimelineBufferOffset" value="40" /><br />
      <Setting name="LocalQualityCap" value="11" /><br />
      <Setting name="RemoteQualityCap" value="11" /><br />
    </Settings><br />
<br />
    <DirectPlayProfiles><br />
    <!-- mkv that won't work without transcoding: <br />
    *codec mpeg-4 visual (microsoft)    audio mp3 (the video codec should be the cause, not mp3)<br />
    *header stripped   (no option to "de-strip" them on the fly, so those files won't play at the moment)<br />
    --><br />
    <!-- HE-AAC is not supported, but I can't exclude that for now, so movies with those won't have sound--><br />
    <!--Files with more than one audio track will have only the first track when transcoded on the fly --><br />
        <VideoProfile container="mp4" codec="h264,avc" audioCodec="aac" /><br />
        <VideoProfile container="mkv" codec="h264,avc" audioCodec="aac,ac3,dca" /><br />
        <VideoProfile container="mov" codec="h264,avc" audioCodec="aac,ac3,dca" /><br />
       <!-- <VideoProfile container="wmv" codec="wmv" audioCodec="wma" />--><br />
      <PhotoProfile codec="jpeg,png,gif,bmp,tiff" /><br />
    </DirectPlayProfiles><br />
  </Client><br />
</Clients>