Philips Android TV (6500 series, 2016 model) and multi-channel audio



My set-up is:

Plex app on Android TV Philips 43PUS6551/12, connected with HDMI + optical to a home theatre system (Samsung HT-C5500)

Test files:
1) video with Dolby AC3 5.1 [ ]
2) video with AAC 5.1 [ ]

If I use the following Plex app settings:
Direct Play = Forced
Direct Stream = On
Pass through = Auto

...for file 1 (AC3) I get no video (black screen), and the audio seems pass through (since on the home theatre system the dolby options seem DISABLED, e.g. MATRIX vs PROLOG VS STEREO; is this a correct interpretation?)
...for file 2 (AAC) I get video, but the audio seems to be sent as stereo (since on the home theatre system the dolby options seem ENABLED, e.g. MATRIX vs PROLOG VS STEREO)

If I use the following Plex app settings:
Direct Play = Auto
Direct Stream = On
Pass through = Auto

...for file 1 (AC3) I do get video (without it being transcoded), but the audio is transcoded and sent as stereo
...for file 2 (AAC) I get video and audio without transcoding ("DIRECT PLAY" is shown in the overlaid information text), but the audio seems to be sent as stereo

I was expecting to be able to get video and audio without PLEX transcoding, and sending a 5.1 directly to the home cinema system. I am not too technical, can anyone help / advise on whether I'm expecting something that is not possible?



I'm also about to buy the Android TV Philips 55PUS6501 and have question about the Audio.
The TV won't be connected to any HDMI.
There will be only connected: Power, DVB-T, ethernet and Toslink SPDIF to my Sony Receiver
I'm planning to put PMS on my PC and watch tv/shows movies over ethernet via Plex for Android TV.

The Sony Receiver have support for AC3/DTS.
The movies I watch are always high quality 1080p/or higher
All movies supports AC3/DTS

The Question is Will Plex Android TV App on my Philips 55PUS6501 play Movies with AC3/DTS Sound over SPDIF Toslink connected to Sony Receiver (with also support AC3/DTS).

BTW. I'm asking as a lot of people are having issues getting 5.1 Audio and most of the use HDMI ARC but I have simple old Toslink recever + Do my TV need to support AC3/DTS or the OS in this case Android TV or Plex Player, sorry I don't get all this audio format, stuff.


Any comments/ideas on my original question? Thanks!


Exact same problem for me (55PUS6401)


Cmon Plex guys, fix this :slight_smile:


Same problem


Same issue and it’s really annoying. I received a lot of Plex for Android updates but none of them fixed the issue.


Identical issue with 43PUS6401, this is likely an issue with surround sound formats and the tv’s actual ability to play it back. Manufacturers seem to be lying about codec support to Exoplayer, or not respecting it in some way. After searching through multiple threads relating to this issue, including Nvidia Shield and other brands of TV’s this is my conclusion. I find that I simply can not play any surround sound format unless it is lucky enough to be transcoded to a non-surround sound format. Funnily, it will manage to push packets through at a transcode of 10mbps from a high bitrate X264 file, then a little better at 8mbps, then a little better at 6mpbs, but stable at 4mbps. Though this varies entirely based on the content. Though this happens only with surround sound content. Video codec is not the problem, as far as I can tell, it’s purely related to surround sound 5.1 audio codecs.

Indeed, it is capable on a hardware level, what device isn’t these days? However, the manufacturer is not so well known for making handsets, or for manipulating android as an OEM. This causes problems. People in other threads have hypothesised that this is to do with the TV disrespecting Exoplayer.. Not that the tv doesn’t support the codec.


The problem seems to be solved with the latest Philips firmware!


Omg you’re right. It works now after update :smiley:


ouch… now the audio is out of sync on all my videos when using the Plex App… incredible…


Have you tried to disable the audio passtrouth in the plex app‘s settings? This solced the sync issue for me.

After the firmware update i can use the latest plex app without the android.xml Workaround and AC3 5.1 works fine for me now. DTS 5.1 is still converted to stereo


The new version dated from today v6.13 resolves all my problems : they use a new version of the player :slight_smile:


6.13 doesn’t resolve it for me, AC3 is heavily out of sync


Aaaaand it’s broke again! :s :s :s :s