Please help!



Hello all,

I just upgraded my router and everything is working fine. Except my Sonos app playing content from my Local Plex Media server (Windows 10). This worked fine on the old router. I am able to play music from the Plex Cloud. The app plays from all other sources (Google, etc). It actually sees the content on my PMS, but once I try to play it, it attempts to play it but then just skips to the next song. But it does not play anything. It just continues to the next but then tries to play for a few seconds, then just skips to the next song. Please help!


Welcome to the party. Didn’t you hear? Plex only added that Sonos service so they could advertise it on their Plex Pass sign up page.

It has never worked and it would go against the Plex philosophy if they actually supported a feature after it was slopped together for advertising purposes.

I recommend cancelling your Plex Pass sub and move to Roon. Their developers personally engage you on the forums and are thankful for a community that helps make their product better.

BTW, Roon + Sonos is f-íng amazing. And would you believe that they actually scrape metadata, album reviews and lyrics? They also have Tidal built in with more coming. And a real discovery dashboard. And even a radio mode that keeps the music going after your queue ends.