# Plex als Service

**URL:** <https://forums.plex.tv/t/plex-als-service/824638>\
**Category:** Deutsch - German\
**Created:** [December 29, 2022, 6:44pm UTC](https://forums.plex.tv/t/plex-als-service/824638 "2022-12-29T18:44:18Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![Morpheus\_1977](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@Morpheus\_1977](https://forums.plex.tv/u/Morpheus_1977)\
**Post date:** [December 29, 2022, 6:44pm UTC](https://forums.plex.tv/t/plex-als-service/824638/1 "2022-12-29T18:44:18Z")

</div>

Hallo zusammen,

ich musste meinen Plex Server in einer VM unter Win10 neu aufsetzen. Dabei habe ich gleich die 64bit Version genommen. Nach dem installieren und einrichten wollte ich auch gleich Plex als Service einrichten. Ebenfalls hier die neue Version genommen. Bei installieren die Windows Benutzer Daten eingetragen und der grüne Haken bestättigt das diese richtig sind.  
Die Installation lief sauber durch.  
Leider startet Plex aber nicht nach einem reboot der VM. Der Plex Server ist nicht erreichbar. In den Log-Flies des PMS-Service steht das der Plex Server nicht insalliert wäre…??? Was muss ich ändern bzw. beachten?

Grüße

---

<div class="post-metadata">

**Author:** ![Morpheus\_1977](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@Morpheus\_1977](https://forums.plex.tv/u/Morpheus_1977)\
**Post date:** [December 30, 2022, 5:02pm UTC](https://forums.plex.tv/t/plex-als-service/824638/2 "2022-12-30T17:02:17Z")

</div>

Niemand eine Idee?

---

<div class="post-metadata">

**Author:** ![derskipper2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/derskipper2000/32/22059_2.png) [@derskipper2000](https://forums.plex.tv/u/derskipper2000)\
**Post date:** [January 3, 2023, 4:54pm UTC](https://forums.plex.tv/t/plex-als-service/824638/3 "2023-01-03T16:54:10Z")

</div>

> [@Plex als Service in Windows](https://forums.plex.tv/t/plex-als-service-in-windows/88826/4):
>
> Hi,&nbsp; habe nochmal eine Frage zu der neuen Reg Datei. Wie muss ich diese einbinden, wenn ich die andere bereits nutze? Kannst du mir dies als Datei zur Verfügung stellen? habe mit Reg Dateien noch nicht so viel Erfahrung.&nbsp; Wird der Dienst eigentlich protokolliert? Vielen dank. greets Tim&nbsp;

---

<div class="post-metadata">

**Author:** ![Morpheus\_1977](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@Morpheus\_1977](https://forums.plex.tv/u/Morpheus_1977)\
**Post date:** [January 3, 2023, 7:32pm UTC](https://forums.plex.tv/t/plex-als-service/824638/4 "2023-01-03T19:32:21Z")

</div>

Hab mittlerweile folgende Anleitung gefunden und bin so vorgegangen. Bisher scheint Plex als Dienst zu starten:

1. Download nssm ([https://nssm.cc/download](https://nssm.cc/download))
2. Extract to C:\nssm
3. Open admin command prompt in C:\NSSM\win64
4. Run: nssm install “Plex Media Server”
5. Set Path to: “C:\Program Files (x86)\Plex\Plex Media Server\Plex Media Server.exe”
6. The rest of the fields should update, click ok
7. From Plex tray icon, disable “Start Plex at system login” and stop the Plex process.
8. Go to Services and Start service. It should be accessible, even after reboot without login

---

<div class="post-metadata">

**Author:** ![OttoKerner](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ottokerner/32/10079_2.png) [@OttoKerner](https://forums.plex.tv/u/OttoKerner)\
**Post date:** [January 4, 2023, 8:58am UTC](https://forums.plex.tv/t/plex-als-service/824638/5 "2023-01-04T08:58:47Z")

</div>

Modifiziere die Zeile in Schritt 5 indem du  
` -noninteractive` nach der .exe anfügst.

---

<div class="post-metadata">

**Author:** ![Morpheus\_1977](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@Morpheus\_1977](https://forums.plex.tv/u/Morpheus_1977)\
**Post date:** [January 4, 2023, 4:29pm UTC](https://forums.plex.tv/t/plex-als-service/824638/6 "2023-01-04T16:29:41Z")

</div>

Was bewirkt der Zusatz?

---

<div class="post-metadata">

**Author:** ![OttoKerner](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ottokerner/32/10079_2.png) [@OttoKerner](https://forums.plex.tv/u/OttoKerner)\
**Post date:** [January 5, 2023, 9:11am UTC](https://forums.plex.tv/t/plex-als-service/824638/7 "2023-01-05T09:11:24Z")

</div>

Er unterdrückt regelmäßige Fehlermeldungen im Log, die durch das Fehlschlagen der Kommunikation mit der Tray Icon App verursacht werden. Denn die läuft ja nicht.

---

<div class="post-metadata">

**Author:** ![Morpheus\_1977](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@Morpheus\_1977](https://forums.plex.tv/u/Morpheus_1977)\
**Post date:** [January 5, 2023, 6:36pm UTC](https://forums.plex.tv/t/plex-als-service/824638/8 "2023-01-05T18:36:44Z")

</div>

Ah ok, danke. Funktioniert leider nicht. Der Dienst startet dann nicht mehr.  
Egal ob der Pfad:  
Plex Media Server.exe -noninteractive oder  
Plex Media Server.exe-noninteractive eingegeben wird

Im welchen Log finde ich den eigentlich die Fehlermeldungen für das Fehlschlagen der Kommunikation mit der Tray Icon App?

---

<div class="post-metadata">

**Author:** ![OttoKerner](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ottokerner/32/10079_2.png) [@OttoKerner](https://forums.plex.tv/u/OttoKerner)\
**Post date:** [January 5, 2023, 7:10pm UTC](https://forums.plex.tv/t/plex-als-service/824638/9 "2023-01-05T19:10:45Z")

</div>

Das geht so:  
 ![grafik](https://global.discourse-cdn.com/plex/original/4X/9/2/1/9217922f09b217e377ad0cf7c0d16281e88adf06.png)

Fehlermeldungen findest du im Hauptlog `Plex Media Server.log`

---

<div class="post-metadata">

**Author:** ![Morpheus\_1977](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@Morpheus\_1977](https://forums.plex.tv/u/Morpheus_1977)\
**Post date:** [January 5, 2023, 7:29pm UTC](https://forums.plex.tv/t/plex-als-service/824638/10 "2023-01-05T19:29:14Z")

</div>

Vielen Dank, dann hab ich es instinktiv dann doch noch richtig gemacht.  
Kann in der Plex Media Server.log aber nicht erkennen ob es funktioniert.  
Errors in dem log finde ich nur folgende:

Jan 05, 2023 22:27:36.348 [21100] ERROR - XML: Entity: line 1:  
Jan 05, 2023 22:27:36.348 [21100] ERROR - XML: parser  
Jan 05, 2023 22:27:36.348 [21100] ERROR - XML: error :  
Jan 05, 2023 22:27:36.348 [21100] ERROR - XML: Start tag expected, ‘\<’ not found  
Jan 05, 2023 22:27:36.348 [21100] ERROR - XML: status=ok  
Jan 05, 2023 22:27:36.348 [21100] ERROR - XML: ^  
Jan 05, 2023 22:27:36.348 [21100] ERROR - Error parsing content.  
Jan 05, 2023 22:27:36.348 [21100] ERROR - Error parsing XML: Error parsing file.  
Jan 05, 2023 22:27:36.348 [21100] ERROR - SSDP: Error parsing device schema for [http://192.168.x.x:9080](http://192.168.x.x:9080)

---

<div class="post-metadata">

**Author:** ![OttoKerner](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ottokerner/32/10079_2.png) [@OttoKerner](https://forums.plex.tv/u/OttoKerner)\
**Post date:** [January 5, 2023, 9:20pm UTC](https://forums.plex.tv/t/plex-als-service/824638/11 "2023-01-05T21:20:51Z")

</div>

Da musst du schon Debug Logging aktivieren.

---

<div class="post-metadata">

**Author:** ![Thialf](https://avatars.discourse-cdn.com/v4/letter/t/6a8cbe/32.png) [@Thialf](https://forums.plex.tv/u/Thialf)\
**Post date:** [January 7, 2023, 11:19am UTC](https://forums.plex.tv/t/plex-als-service/824638/12 "2023-01-07T11:19:27Z")

</div>

Ich habe das “Autostart” Problem mit Autologon Tool von Microsoft bei mir in in der Hyper-V VM gelöst. Plex läuft seit Jahren ohne Probleme auf einer Windows Server 2019 Version. Vielleicht wäre das auch noch eine Möglichkeit für dich.

Grüsse

Arp

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [April 7, 2023, 11:20am UTC](https://forums.plex.tv/t/plex-als-service/824638/13 "2023-04-07T11:20:12Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
