Plex And Amazon Firestickv2 and FireTVv2 Transcoding and AC3 issues.

android-tv
fire-tv

#1

I have two different issues, but am posting both in the same thread, since they both relate back to Amazon TV clients...

I have many Plex client devices, including ATV4 (x2), Roku Stick, Android (Nexus 7 FHD x2), iPhone, iPad, and of course Web.

I run a main Plex server on a 2012 Mac Mini w/attached USB3.0 12TB RAID 5 and 8TB RAID 0 Plex Library Drives. All Media is encoded as 1080p, h.264, AAC (Track 1), AC3 (Track 2) in mp4 containers. Some have subtitles (iTunes type files) and others don't (burned in subtitles). This is my main Plex Server, and has been working quite well with all clients, except FireTVv2 and Firestickv2. (I'll get the FireTVv2 issue in a moment...)

For the sake of backup and redundancy, I have a NETGEAR ReadyNAS 2120 40TB that I use to back up the Plex Media Library. That is it's sole purpose...to keep a backup of my Media. Because the ReadyNAS 2120 can also run apps, I have also installed and run a 2nd Plex Server from there. The ARM based ReadyNAS 2120 cannot transcode, and I knew that going in. However, it was my understanding that all of my clients are capable of natively playing MP4, 1080p, h.264, AAC, AC3 without needing to transcode. The idea with the backup was to have Plex availability in case the main Mac Mini 2012 server needed any maintenance, etc. And since the only thing the ReadyNAS 2120 was doing anyway was to backup the Media Library, I figured "what the heck", I'll just run a 2nd Server on the NAS and have a working backup Server. (Syncing the Plex Databases would be awesome, but that is another discussion...)

Well, during Mac Mini defrag maintenance over the past week, we made extensive use of the Plex Server running on the ReadyNAS 2120. Everything worked pretty well (although a bit slower GUI) on all clients except the Firestick TVv2. It would not play our files, without giving the "Server is not powerful enough..." dialog. I tried to search here for some troubleshooting tips, but could not find anything that worked.

The Firestick is about 7 feet, line-of-sight across the room from my AP, and is 5GHz Wi-Fi connection at max PHY Link. All settings on the Firestick Plex client are set to allow direct streaming...and h.264 level is set to 5.0, which is above any of my transcodes. Auto convert in the client is turned off. Quality is set to original. Firestick and AP were both rebooted many times as a troubleshooting measure. Firestick seems to have no issue streaming direct using DLNA, but will not do so from the Plex Client. I would prefer to use the native Plex Client.

Why does the ReadyNAS Plex Server/Firestick combo insist it must transcode to the Firestick, even though I have all the settings implemented for direct play? Why is the Firestick the only device having this issue, while every other client I have (Including TWO 2013 Nexus 7s running Lineage OS ROM and Plex Android client) have no issue running direct-play? In fact, all other clients work beautifully and (except for the Firestick) we were quite pleased with the performance of the backup server while the main server spent a week doing a full defrag of over 11TB of files.

Seem to me there is some issue with the Firestick Plex client, and I would really like to understand why? What is different from the Android client? Is there anyway to fix this?

2nd Issue: Can anybody verify that Plex on Amazon Fire Tv v2 cannot play AC3? I've specifically picked the 2nd AC3 track, but my receiver insists it is still only getting Stereo over HDMI 1.4 cable. I have an Apple TV v4 hooked to the same receiver and AC3 is working correctly from the Plex client on the ATV4. (My receiver is an Onkyo TX-NR809, and (as I say) works great with every other HDMI connected device.).

Appreciate any insights and troubleshooting tips you guys might have. At this point, Amazon devices are mostly useless to me for Plex until I can figure out a fix.


#2

Update: With the latest Amazon Fire stick Plex client and my Mac Mini Plex Server, the overlay is saying “Directplay was attempted but failed, falling back to transcoding”…or something to that effect. I’m convinced there is an issue with the Amazon TV Plex client that needs fixing. No reason my mp4 files should not play natively. This is only an issue on Amazon Fire Stick. (Haven’t tried the test with my FireTV v2 yet…). All other devices (including an older Roku Stick) directplay just fine. Also, the Plex client on the Firestick is VERY MUCH slower and sluggish compared to every other client device I have…pretty much painfully slow. I can’t believe anybody actually tested this latest Plex client on the Fire Stick. I guess I’ll stick with the Roku stick for travel…


#3

I have these same issues. Finally got fed up with it and went Roku. Flawless ever since.


#4

@barryguzik

2nd Issue: Can anybody verify that Plex on Amazon Fire Tv v2 cannot play AC3?

There is a firmware problem in the AFTV gen2 box which can only be fixed by Amazon. Amazon has stated a fix will be available “this year.”

Due to the firmware problem, AC3/Dolby Digital is decoded to PCM 2.0 before being sent to the TV / receiver / etc.

This affects only the AFTV gen2 boxes. Other AFTV devices should send AC3 correctly to attached device providing (a) AFTV audio settings are correct (AFTV itself, not just Plex client), and (b) attached device supports Dolby Digital and/or Dolby Digital Plus.

You should also note that no AFTV device supports any flavor of dts / dts passthrough (see Tech Specs). This is “as designed” by Amazon and unrelated to the aforementioned firmware bug.

With an AFTV g2 box, dts & dts-HD MA audio are decoded to PCM 5.1 on the AFTV, then sent to the attached device. PMS shows Direct Play.

I have the AFTVg2 box. I cannot say whether dts will be decoded on-device or transcoded by PMS using other AFTV devices.


Separate note, regarding “Direct Play was attempted…”

I also have some movies that, for some reason, give the “Direct Play was attempted…” message when streaming to my AFTV g2 from a local PMS or from Plex Cloud. They give the same message when streaming from Plex Cloud to an AFTV g3 pendant. The movies direct play when streaming to a Shield TV from local PMS or Plex Cloud.

Inspecting the output of MediaInfo or Plex XML shows no difference from movies that direct play.

The only commonality I can find among the problematic movies is that I used a nightly build of Handbrake to transcode them. However, other movies encoded with same build and at same time direct play (eg batch mode 5 movies, 3 OK, 2 not).

Short of re-transcoding the movies with the current Handbrake release I’ve not found a way to fix things.

So, to quote a former US president, “I feel your pain…” :slight_smile:

If I find an easier fix than re-transcoding I’ll update the thread.

FYI, I’m not throwing Handbrake under the bus. I knew I was using a nightly build, not the released version. Just odd that it works fine for some movies but not others.

FYI2, Sounds like we’re encoding close to the same way. I use the Apple 1080p30 preset and tweak as needed with one AAC audio track and one AC3 audio track.


#5

Thanks guys. I’m dumping Amazon stuff. Roku and ATV work fine, so I’ll stick with them. I will note this also for Family & Friends recommendations… Amazon probably doesn’t care about end-user’s personal media and so are not going to prioritize…which is no problem since it is easy and cost-effective to find alternative HW solutions that work correctly.


#6

@barryguzik said:
I guess I’ll stick with the Roku stick for travel…

Do you know if Roku stick can get through hotel landing pages? My Roku box at home is so limiting with network that I have trouble using Plex locally. The only reason I bought a Fire stick is because it seems to be the only device that let’s you get on hotel wifi.


#7

I just got mine to work! When I started the video I went to settings under the player controls and changed it from 2mbps/720p to Convert Automatically and the audio came up!


#8

So you are getting DD with Amazon fire tv with plex client? What format is your video MKV? I have same issue, works on roku and appletv but not AFTV. But on AFTV the same MKV dvd plays DD using Kodi app.