Plex App for Samsung PN64D8000 - No Content in Library



Brand new to Plex after my PS 3 suddenly stopped streaming through my PowerBook via PS 3 Media Server (: I am using Plex app on above Samsung HDTV (2011) model. When I enter Shared Content menu item to see my library, it says "No Data Available." When I go to Queue it only shows movies I have loaded from Vimeo, nothing from my Plex libraries. I searched forums for this issue and could not find the exact fix. Thanks!


Please download the manual, to get started, link below.


Thanks Orca - I'm not sure which manual to download for my display. Do you know which version since you are a developer of the app?


Thanks Orca - I'm not sure which manual to download for my display. Do you know which version since you are a developer of the app?

I just saw I forgot to upload the latest manual (although they are not very different from the last)

For 2011 it should be version 1.016 which can be found here


Thanks! The clock adjustment feature is seriously the strangest UI I have ever seen! Not sure what you were thinking there (:


Orca - I went through the entire manual as you suggested. Everything is fine until I reach page 45 - Home View. Pushing RETURN twice takes me to a pop-up window asking: "Are You Sure You Want To Exit Plex for Samsung" with a "cancel" button highlighted and a "Exit" button as the only two options. I cannot reach Home View screen as described in the manual and cannot see any of my content in Plex Media Server I have created (so far I have Home Videos folder and a Photo folder) Pushing the "Recommended" option in the side menu panel brings me to a screen "All Videos" which only shows content I sent from Vimeo Web Site to Plex. My other options besides "Recommended" in side bar menu are: "Quit" "Preferences" "Shared Content" and "Queue", the last of which do not display any content from my Plex Media Server listings.


Have you connected your server ? >


That might be the issue as I run my Cisco router through Time Warner's Aris Modem and they bridge the Aris to go through my Cisco. That means I'm in the double NAT situation since the IP addresses are different for each router. I'm trying to reconcile that today. However, doesn't the Samsung app pull from my LAN, like for all other apps in the Samsung Smart Hub menu? The Plex Media Server pulls fine from my Cisco router without conflicting with Time Warner bridge.


I may be kicking in an open door, but just checking, have you done this;

Preparations before using the app:

- Download the server software and install it.

- Create a plex account on

- Open a browser and open the webui > http://localhost:32400/web/index.html and log in on your server with the plex account.

- Create some sections and add content so we have something to look at.

- Connect the server to your account (link from previous post)  important!

From the app:

- On the main screen select preferences and press enter on the remote

- Select "System"

- Select the first option and press enter.

- Note the PIN code you get. (leave the screen open)

- Open a browser and go to and enter the PIN code.

If all went well it should show you a message on the Tv saying it's all done.

Press return a few times until you are back on main and your content should be visible.

If it doesn't work, please tell me in which step.


The only step I cannot execute is outside my LAN area connection - message below.

Signed in to Plex

You have successfully signed your server in to Plex, but we were unable to reach it from outside your network.

If you would like to enable this now, you will need to configure your router or firewall to allow Plex to contact your server. Please refer to our Connecting a Server article for more information.


Hmm, I'm no network expert. The only help I can offer is maybe this >


Well, I've tried everything and no luck. Checked with Time Warner that Arris was properly bridged and NAT enabled. Set up a static IP on my computer and then did a manual port forward on my Linksys and then tried to re-connect Plex server using manual LAN IP I set (default of 32400) and nada. I even deleted the app and reinstalled it on Samsung TV, also with same results, as described in previous email. Not sure what else to do at this point. Maybe call Time Warner tomorrow and ensure they have a single port forwarded to same static IP on my computer and Plex port so both routers are mirrored.


I wish I could help, but it seems to me this has little to do with the app and all with your network setup. :(


I have the same problem when viewing libraries on my Windows 8.1 on my Roku, and this happens even after doing Update Library AND Refresh All. I can browse to a folder, but I get an error message "no content found in library" or words to that effect. Plex simply doesn't update itself when I add files to a library on my computer. And I'm not adding 1000 new files--only one!!

I **refuse **to reboot my computer or exit Plex on Roku to workaround this horrible and obvious bug in Plex.