Plex app on LG webOS transcoding with subtitles enabled

smart-tv
lg-webos

#1

Should the Plex app on LG webOS be transcoding, with the subtitles enabled.

I’m able to do a direct stream on a Samsung 4K 2016 model with subtitles enabled.

I don’t see any setting in the LG app to not burn subtitles unless they are image format, like the Samsung app has.


#2

I’m having the same problem. I have an LG 43LJ614V TV (https://www.displayspecifications.com/en/model/3389b62). Is there anything I could do?


#3

Same problem here


#4

Same problem here (LG B6, using native Plex app on WebOS).
Any possibility to play media with subtitles without transcoding? Or play transcoded media without quality decrease?


#5

Us LG users have been neglected. It’s that simple. I think it’s becoming obvious what the issues are, so that’s good, but who knows if they will be resolved.

Makes me wonder if I should have bought a Samsung…


#6

It’s not optimal neither on the android app for sony tv.


#7

they know about the issue, and working on a solution already. there are plenty of threads about this issue.
the app will (at a later date, no ETA ofc) have a setting for subtitles. so it can tell the server to transcode or not.
currently there is no setting for it, so the server auto transcodes


#8

Bump… hoping there is some change on this at some point… I would hate to see this issue fade into the ether again…


#9

This issue is on our radar, I can’t provide an ETA when it’ll be addressed.


Disable Plex Transcoder Totally
#10

@markus101 Without wanting to sound impatient is there any particular reason why it’s taking so long? Given how often it’s mentioned on here I think subtitles not working are a particular annoyance for a number of people, especially in light of the increase in available 4K media and the difficulties faced in transcoding that in real time. It’s more frustrating that an unofficial client (Xplay) can manage to do it, as can a competing product (Emby) while there doesn’t seem to be any movement forward from Plex.


#11

I appreciate your reply markus101, but It’s extremely frustrating that this has been going on for years, and still is not a priority to the plex team.


#12

I Have the same problem here. :frowning:


#13

Xplay works perfectly and has better controls than the native Plex app to boot. LG is industry leader in OLED panels and this should be a very easy fix, guess this means that Plex development has halted for some reason.


#14

I guess so, I just switched to Xplay on my LG TV, direct plays anything.

Even with subtitles enabled.


#15

ANY UPDATES???

Now that the forums have changed, this topic has become buried once again.

Come on plex!!! Help us out here!!!


#16

Movies get played as long as the subtitles are not enabled. Once sub is enabled you need to get it disabled thru a smartphone or comp. The app on LG webOS doesn’t allow sub to be disabled as it fails to load. Can be quite troublesome to certain extend unfriendly. Hopes the improvement comes fast. The current version is really dated like in 2016. :frowning:


#17

Yet another week goes by with no fixes or news from Plex.


#18

Yeah I don’t know why the same settings for Xbox One to “Burn Subtitles - Only image formats” isn’t available here.

Would easily solve this problem.


#19

Not true. I’ve tried XPlay as well and the only difference is that the server SAYS it direct plays, but the reality is that the server is doing the transcode! The transcoding process is eating almost 100% of my CPU (same as in case of Plex app). Also I can clearly see that I’m watching a transcode as the HDR and 4K is lost.

The only way to play without transcode is to use the LG built in app, but then no subtitles are available…

Has anyone found a way to watch 4K HDR on LG OLED with subtitles??

PS: I’m using 65B7 set.


#20

You can turn the DLNA server on in the Plex server and then use the LG photo and video app. As long as you have srt subtitles it’ll direct play.