# Plex certificate issues

**URL:** <https://forums.plex.tv/t/plex-certificate-issues/938008>\
**Category:** Remote Access\
**Tags:** server-linux\
**Created:** [April 15, 2026, 8:15am UTC](https://forums.plex.tv/t/plex-certificate-issues/938008 "2026-04-15T08:15:52Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Digitalsmile](https://avatars.discourse-cdn.com/v4/letter/d/90ced4/32.png) [@Digitalsmile](https://forums.plex.tv/u/Digitalsmile)\
**Post date:** [April 15, 2026, 8:15am UTC](https://forums.plex.tv/t/plex-certificate-issues/938008/1 "2026-04-15T08:15:52Z")

</div>

Server version: 1.43.1.10611  
Running as a container on unraid.

Apparently my server has issues storing my certificate.  
Plex logs report:  
`CERT: Certificate did not exist, fetching a new one.`  
`CERT: Error acquiring new certificate: Failed to retrieve cert from ``plex.tv``: 429,`  
`CERT: Error acquiring new certificate: Failed to upload CSR: 429, <?xml version="1.0" encoding="UTF-8"?> <errors> <error code="1003" message="API rate limit exceeded" status="429"/> </errors>`

Response from mod is:  
_The current certificate is perfectly valid. Apparently, your server has issues storing it, because you have requested 5 new certificates within 24 hours. Hence the rate limiting._

I have already attempted to recreate cache by simply deleting the old folder, after which the folder was populated again on server boot. I have done this twice. Neither times any cert-v2.p12 file was created.  
So plex has accessrights to the folder in question, but the folder doesn’t contain any certificates, which would explain why my plex doesn’t see any certificates..

I assume it isn’t able to download the existing cert either because of the API rate limiting. How do I go about fetching a new certificate for my server?  
Can it be manually downloaded and moved to cache?  
Does the rate limit reset after a certain time, and is it tied to my WAN ip adr.?

Issue started after moving Plex (and DNS) to new VLAN and forgetting to target port forward to correct internal IP, plus Plex using incorrect DNS address for a while. Both of these issues are solved.

---

<div class="post-metadata">

**Author:** ![OttoKerner](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ottokerner/32/10079_2.png) [@OttoKerner](https://forums.plex.tv/u/OttoKerner)\
**Post date:** [April 15, 2026, 9:25am UTC](https://forums.plex.tv/t/plex-certificate-issues/938008/2 "2026-04-15T09:25:36Z")

</div>

> [@Digitalsmile](#):
>
> I assume it isn’t able to download the existing cert either because of the API rate limiting. How do I go about fetching a new certificate for my server?

Shut down your server for at least 24 hours, then try again.

---

<div class="post-metadata">

**Author:** ![Digitalsmile](https://avatars.discourse-cdn.com/v4/letter/d/90ced4/32.png) [@Digitalsmile](https://forums.plex.tv/u/Digitalsmile)\
**Post date:** [April 15, 2026, 9:26am UTC](https://forums.plex.tv/t/plex-certificate-issues/938008/3 "2026-04-15T09:26:17Z")

</div>

Thanks. I will reply back in (minimum) 24h with results. 🙂

---

<div class="post-metadata">

**Author:** ![Digitalsmile](https://avatars.discourse-cdn.com/v4/letter/d/90ced4/32.png) [@Digitalsmile](https://forums.plex.tv/u/Digitalsmile)\
**Post date:** [April 16, 2026, 11:23am UTC](https://forums.plex.tv/t/plex-certificate-issues/938008/4 "2026-04-16T11:23:58Z")

</div>

I turned on Plex again after ~26 hours and the certificate (cert-v2.p12 under cache) was instantly installed again. All good.

Topic can be closed. 🙂

---

<div class="post-metadata">

**Author:** ![OttoKerner](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ottokerner/32/10079_2.png) [@OttoKerner](https://forums.plex.tv/u/OttoKerner)\
**Post date:** [April 16, 2026, 11:33am UTC](https://forums.plex.tv/t/plex-certificate-issues/938008/5 "2026-04-16T11:33:50Z")

</div>


