Plex channel won't open

roku

#1

Hello

I have a Roku Express + and Plex channel installed. The channel was fine a few days ago, but since this morning there is an issue. Every time I try to enter the channel a blue screen will appear for a few seconds, then it will automatically go back to the Roku home page without opening the Plex Channel.

I have the latest version of the Plex Server on my computer (1.9.2.4285) and the Plex channel is the 5.1. I have also tried to uninstall, reboot Roku and install the channel multiple times without any change. The internet is working as I don’t have this issue with YouTube or Netflix channel.

I also play successfully a video form my library using the Plex Web app so it seems to be a problem with the app for Roku.
Could any of you please help me out? Any recommendations?


#2

I have the EXCAT same problem. I can however use “plex classic” but not the latest Plex app on Roku as of a few days ago.


#3

I have the same problem. Would love this to be resolved as it is very frustrating!


#4

Should have added - this started suddenly a few days ago. I can access Plex through my phone and laptop, just not through my Roku TV device.


#5

Hey guys trying to figure out problem. The app is working for most folks so trying to figure out what is wrong. which Roku model are all of you using? What version of Roku firmware is it running?


#6

Hello BigWhel thanks for the help. I have a Roku Express + regarding the firmware, not sure of that but I recently purchase the Roku (not even a month ago) and I have tried the Update System option so I assume it will be latest unless there is a different method to update it.

Regards


#7

Hello Big wheel. I have a Roku premiere plus and have the latest firmware on my box and plex app doesn’t load as of 4 days ago. Plex classic however does work fine but I require the modern version for direct play abilities. Please advise and if you need more info ask. Thx


#8

Hi big wheel i am having the same problem, on the roku streaming stick plex will not open. Worked fine up until the update on the 21/9/17, any help would be appreciated


#9

The PLEX playback issues seem to be a result of recent ROKU firmware updates. Check for more info here - https://forums.roku.com/viewtopic.php?f=28&t=104029

My Plex was running perfectly on Monday. Then ROKU pushed the latest firmware on Tuesday and Plex now works for maybe a minute and crashes.


#10

Hey all. I apologize for the current startup crash. We are unable to reproduce this, but understand it’s a real issue. I see the first report mentioned removing the channel, rebooting and reinstalling did not fix the issue, but it’s possible that scenario did not clear the settings properly. Could one of you experiencing the issue try these steps to see if it corrects the issue?

  1. Remove ALL plex channels from the Roku
  2. Reboot
  3. Reinstall the Plex channel

This will cover the grounds that a possible saved setting is causing the issue. To clear the settings, one has to remove all Plex channels (Plex, Plex Pass, etc), otherwise it retains the settings even after you reboot and reinstall.


It would also be good to know these two pieces of info

Software Version: Roku Home Screen -> Settings -> System -> About -> Software Version
Plex Version: Focus Plex channel on Roku home screen, click the * button


#11

I removed all plex apps (standard and classic). I reset the roku premiere plus and installed plex apps again. Classic works but standard app opens and closes within a second. It’s extremely annoying. I need my standard plex app back else the roku has no real function for me.


#12

Thanks for trying that @wellibob, and we agree we’d like to get this back asap. I’ll DM you shortly to see if we can debug this together.


#13

We’ve been in contact with Roku to try and isolate the reason for the startup crash. If you are affected, please message me your serial number and model number. This can be found in Roku Home Screen -> Settings -> System -> About.


#14

Hello ljunkie, will do. Hopefully your team can find a solution quickly


#15

Thanks for the info everyone. I forwarded the serials off to Roku yesterday to hopefully track down the startup crashes. I haven’t received anything yet, but I will update this thread as soon as I hear back from them.


#16

Hey all. New update today. Roku has provided a few steps to follow on your Roku that should provide them with the details on the crash. Please feel free to PM me for the info if you have the time to run through these steps.


#17

i have the same problem, any solution? thanks a lot :neutral:


#18

It seems Roku haven’t a clue why Plex won’t open on certain devices. It’s pretty unacceptable now as it’s been over 2 weeks. I’m about to get shot of the Roku’s tbh now.
Simply revert back to older firmware would solve but nope it seems they can’t replicate the issue in house so are by the looks avoiding it or it’s been filed away and those who are affected are to be forgotten. Rubbish service.


#19

Hello!

I have the roku 2 xs that goes black for a few seconds then goes to home screen at EXACTLY 2 min 39 seconds into a movie or show everytime. I’ve timed it.

I’ve gone as far as doing a factor restore of the roku and reinstalling plex. But it does the same thing.

I don’t see plex classic in the app store on roku?

My plex is version 5.0 build 1

Roku software version 7.70 build 4135-02


#20

Seem to be having the same issue with the newest version 1.9.2.4285… Roku, amazon firestick, xbox, and playstation are all having a hard time. LG smartv and browsers seem to be working okay