Plex Cloud error: "Unable to connect to the content server"

samsung-smart-hub

#1

Hi,

I have an Smart Hub Samsung TV from 2013. Connecting to my Plex Server works great, but when i try to play something from Plex Cloud, i keep getting "Unable to connect to the content server". I've already uninstalled and reinstalled the Plex App (2.007), and i've already tried resetting the TV, but it doesn't work. Can anyone help me out with this one?

Thx!


#2

Plex cloud might need secure connections to be enabled. This is a bug that I resolved in the upcoming version 2.008.


#3

@Orca said:
Plex cloud might need secure connections to be enabled. This is a bug that I resolved in the upcoming version 2.008.

Hi,

Thx for the fast reply! I've enabled "Secure connections", but the problem still exist.


#4

Hard to tell what's happening. A logfile might help. Go here to show you how to create one


#5

same issue on my 2012 Samsung 7 series. anyone gotten cloud server to work with Samsungs?
"There seems to be a problem, unable to connect to content server" I have tried both with and without secure connections.


#6

@torsteiner said:
same issue on my 2012 Samsung 7 series. anyone gotten cloud server to work with Samsungs?
"There seems to be a problem, unable to connect to content server" I have tried both with and without secure connections.

Works for me with 2014 Samsung and app 2.007 and secure settings enabled.


#7

Same problem with 2012 Samsung TV.


#8

2012 TV's need the latest firmware to connect, did you update it?


#9

Yes, I have the latest firmware installed.


#10

I would need some more information, could you create a log file as described here?


#11

Yes, I hope I did well.


#12

Hi, the error continues, would be possible a solution?, Do you need any other log or info?

Thanks.


#13

The problem seems to be that google is redirecting the request before it plays the file.
Redirection is something the older models do not like.
Setting the playback mode to Direct Streaming might help.

DEBUG - HTTP requesting GET https://www.googleapis.com/drive/v3/files.. 
DEBUG - HTTP 307 response from GET https://www.googleapis.com/drive/v3/files/..
WARN - [PlexforSamsung] [Player.js] - Player Connection Failed!

#14

It works!, thank you.


#15

Both my brother-in-law and I were having the same issue, and I can confirm that Orca's solution worked for both of us. So easy! Thanks!