Plex crashing on startup everytime after wiping data following sync getting stuck

android-mobile

#1

This discussion was created from comments split from: "An error occurred while attempting to play this video" for every video in Plex on android TV.


#2

I~~ have a related issue, and I figured this might be the best place for it.~~

Put simply, after plex started refusing to sync a number of videos I asked it to, I decided to wipe its data and try again; the old turn it off, turn it back on again approach.

Now plex crashes on startup everytime.

via adb logcat i found this;

E/AndroidRuntime(17763): FATAL EXCEPTION: AsyncTask #1
E/AndroidRuntime(17763): Process: com.plexapp.android, PID: 17763
E/AndroidRuntime(17763): java.lang.ArrayIndexOutOfBoundsException: length=36; index=36
E/AndroidRuntime(17763): at com.plexapp.plex.utilities.c.a.a(SourceFile:244)
E/AndroidRuntime(17763): at com.plexapp.plex.utilities.c.a.a(SourceFile:92)
E/AndroidRuntime(17763): at com.plexapp.plex.utilities.c.a.a(SourceFile:80)
E/AndroidRuntime(17763): at com.plexapp.plex.application.ag$1.run(SourceFile:175)
E/AndroidRuntime(17763): at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1112)
E/AndroidRuntime(17763): at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:587)
E/AndroidRuntime(17763): at java.lang.Thread.run(Thread.java:818)

I have reinstalled multiple times with no luck.

Hoping for a quick resolution (read, workaround) as I have a two flights totalling 20 hours next week I was hoping to use Plex during.


#3

Please provide full log file by emailing the device log to your mailbox and then attaching here - plus some info on exactly what actions you took before these crashes started

Please see Emailing Device Logs section on this support page to get the full log to yourself so that you can attach here as a file attachment

https://support.plex.tv/hc/en-us/articles/201573117-Android-and-GoogleTV-Logs


#4

I'm getting the exact same crash on startup. This is on a fresh install of Plex on a new phone. I can't email device logs because I can't even get the app to run at all. There is a previous error in the logcat. I don't know if it's related.

System  : ClassLoader referenced unknown path: /data/app/com.plexapp.android-1/lib/arm

#5

@newtonsbucket said:
I'm getting the exact same crash on startup. This is on a fresh install of Plex on a new phone. I can't email device logs because I can't even get the app to run at all. There is a previous error in the logcat. I don't know if it's related.

System  : ClassLoader referenced unknown path: /data/app/com.plexapp.android-1/lib/arm

what phone make / model ?
OS version ?
Plex for Android version?

Could you get more from logcat?


#6

Here's the entire logcat. The phone is a BLU R1 HD. Android version 6.0. Plex version 4.32.1.498.


#7

@newtonsbucket said:
Here's the entire logcat. The phone is a BLU R1 HD. Android version 6.0. Plex version 4.32.1.498.

Thank you. I have raised this with the Plex for Android development team


#8

@newtonsbucket said:
Here's the entire logcat. The phone is a BLU R1 HD. Android version 6.0. Plex version 4.32.1.498.

This has been investigated and the problem appears to be with the handling of the device name and seems to occur on some phones. A fix is being made to ensure the app does not crash


#9

@newtonsbucket said:
Here's the entire logcat. The phone is a BLU R1 HD. Android version 6.0. Plex version 4.32.1.498.

A fix has been released / see release notice for Plex for android 4.32.2