Plex for LG TV webos 3.0

smart-tv

#1

Hi please can you advise when the Plex app will be available on the above TV as I have spoken to LG and they said they needed Plex to sign up. I have tried PLAYz app but it does not do surround sound and I have also tried X Play app but it buffers a lot.

Regards

Capw00


#2

We're going through submission with LG for webOS 2 and 3 right now.


#3

Great Thanks for the update


#4

Awesome, thank you for the direct answer.


#5

Matt, any idea how long the submission process takes at LG?


#6

Just downloaded from the app store and working on my LG49UH770V.


#7

I am waiting for plex app for new LG webos 3.0. hopefully it will be available soon.


#8

now working on my B6P with no problems


#9

The app is now available for webOS 3.0 (in addition to webOS 1.0, 2.0, and NetCast).


#10

thats great news thanks for the update


#11

@erik.beeson said:
The app is now available for webOS 3.0 (in addition to webOS 1.0, 2.0, and NetCast).

And works fantastic. version: 2.6.9 on WebOS 1.0


#12

I want to report a bug:

Running Plex 2.6.9 on LG 4K WebOS 3.0 model 55UF7600 (firmware 04.00.95).

I'm able to use Direct Play for DTS 5.1 audio to my TV (works on Kodi also), but the audio is 3-5 sec delayed. I also cannot resume or fast forward when Direct Play to DTS is turned on, the video just freezes.


#13

I've dowloaded XPlay, a third party app for my LG OLED55E6 (WebOS 3.0) and it works fine. I also downloaded the native Plex app in the LG content store, but it doesn't function correct. I can log in, the app "sees" my added folders on my NAS (same settings as in XPlay) but it hangs during the loading of a MKV file.

Strange, the native app doesn't work, and a third party does the job? XPlay was still in demo mode, and I have to pay for it now. I rather use the Plex natve app, because I like the looks. XPlay comes close, but the GUI for the native Plex app is a better one imho.

My files are on a Synology NAS (DS212+) and the server is also running on it.


#14

After updating my LG B6 today with 3.15 WebOS, Plex is very non-responsive: video freezes running Direct Play, and this is the same NAS that worked great on my Samsung TV with Plex 2.05. Also, I see that when watching a DTS 5.1 movie, the AVR shows Dolby Digital...apparently they still haven't figured out how to handle all possible MKV sound data. Of course with the TV so new, it's hard to tell if the problems are the Plex app or WebOS...and thus the user is caught again in the middle.


#15

@rifer1 said:
After updating my LG B6 today with 3.15 WebOS, Plex is very non-responsive: video freezes running Direct Play, and this is the same NAS that worked great on my Samsung TV with Plex 2.05. Also, I see that when watching a DTS 5.1 movie, the AVR shows Dolby Digital...apparently they still haven't figured out how to handle all possible MKV sound data. Of course with the TV so new, it's hard to tell if the problems are the Plex app or WebOS...and thus the user is caught again in the middle.

Did u ever get the sound sorted out?


#16

I am also having problems with plex on webOS 3 with a 55UH8509 TV. Many vIdeos stutter. On camera pans you can clearly see that the movement is stopped about once a second for a short moment. Basically anything that has been encoded by Apple has this problem. If I force transcoding by deactivating direct play and direct stream the problem disappears. But the picture quality suffers, so this is not an option.
Also some videos just stop playback with three dots appearing and you can not skip beyond this point.


#17

I'd like to report a bug on webOS 3: you cannot play a 4k video. With XPlay I get direct play of a 4K video, but when I try the same video in the official plex app, the server starts transcoding to 1080p.


#18

So I just got a new TV for my kitchen (used to have an older smart hub 24' samsung there and wanted something bigger). So after I heard that webos 3 TV's are supported I got myself LG's 32LH604v (2016 model). That's supposedly running WebOs3.

The problem is very simple, app is not compatible with this TV (just in case tried both Russia and UK regions and on website). So my question is, if it's ever going to be supported? Is it in approval for that model? Someone forgot to include it in compatibility? Or what's the deal here, I bought that one specifically to get the newer OS so I can most reliably get plex on it. Otherwise I'd probably go for Samsung, but Tizen 2015 is not supported...

Any way, what's the deal with this model, can I count on having plex on it and when...?
@mattseeley , @"erik.beeson" any ideas?

Edit: Checked store app versions. RU, UK and US all on 2.0.1 according to lgappstv.com


#19

To those still having trouble finding the app: The app should be available for all NetCast, webOS 1.0, webOS 2.0, and webOS 3.0 devices in all regions. If you're not finding it, I promise it's not because we're trying to exclude you :)

(The one exception is a class of devices that LG calls "Simple Smart". LH57 is one such device. I'm not sure if there are others, but they don't seem to be very common, and there doesn't seem to be a lot of info about them. Supposedly it's a NetCast-based device, so I'm hopeful that we'll be able to work with LG to get Plex working on it.)

Thank you to those who have messaged me or reported here about having trouble finding the app in the store. I've contacted LG, and I'll keep you posted as soon as I hear from them.


#20

Bug report LG 65UF6450, LG S/W ver: 03.15.02
Subtitles are force played regardless of server setting and individual file setting. Please advise.